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1.0 Introduction and Scope

Operational Implementation of a Distributed Hydrologic Model

OHD ID #: NID 04-007

DCS-3416

The requirements for enhancements to the Distributed Hydrologic Model software for OB8.2 are
documented in the OSIP CONOPS and Requirement Specification Document. The features to
test in OB8.2 are in the following categories:

a) Precip grid copying to a user’s local directory only occurs when running DHM
b) Allow users to define times other than 12Z for grid output

C) Allow users to specify precipitation modifications (Mods)

d) Allow users to specify SAC state Mods

e) Allow users to model basins which use multiple upstream inflows

f) Develop a utility to create operational DHM grids from a previous

Calibration (DHM Grid Editor Program)

The test procedures in section 4 of the document use automated and manual tests to prove the
features are working as intended.

2.0 Document Overview

This document describes the test procedures for DHM in AWIPS. These tests are conducted prior to
delivering the software to AWIPS. This document contains:

e Test Procedures — A description of the procedures the tester will follow to verify the tests are
passing

3.0 Test Results

4.0 Test Procedures

4.1 Regression Tests - verify DHM functions as it did prior to OB8.2 changes.

» copy the tar-gzipped file XXXX into a local directory (e.g. the tester’s HOME
directory)

» extract the file using the following command:
tar -xvzf XXXX

» The package root directory, dnmtestpackage, has automated and manual tests
organized into two separate directories (dhmtestpackage/ofstests are automated and
dhmtestpackage/ifptests are manual).

* To run the automated batch mode tests:
cd to the directory dhmtestpackage/ofstests and run the script run_ofs_batch_tests.
After 3-5 minutes you should see a summary of the results on the command line:

XXX right, 0 wrong, 0 ignored, 0 exceptions.
* To run the manual IFP Tests
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Follow the test procedures shown in Appendix A

4.2 New Tests — Tests of OB8.2 DHM Enhancements.

4.2.1 Test precip grid copying only occurs when running DHM

Step A: make sure no old directories in /data/dhm/
 cd to /data/dhm/
* typels-R $LOGNAME
» if any directories exist under SLOGNAME remove them using rm —rf command

Step 1 — execute a test script to setup the data
« cd dhmtestpackage/ifptests
e runlFPWithDHMORP rls

Result - the two main IFP displays appear

Step 2 — Select the Forecast Group
« From the “Select Forecast Group and Carryover Date” display select DHMFG as the
Forecast Group and Julyl, 2002 12Z as the Carryover Date, Click Load
« From another terminal window cd to /data/dhm/
« Type the following Is -R
« You should see the same output as in step A

Step 3 — Select the dates to run
« From the Options Menu select Set Dates...
« Set End OF Observations to Jul 3 2002 12Z
« Set End Of Run to Jul 32002 12Z, Click Set

Step 4 — Run the DHMFG and verify precip grids only exist for the duratioin of the run
« From the “NWSREFS Interactive Forecast Program” display’s File Menu select Begin
« From another terminal window cd to /data/dhm/$LOGNAME
« Type the following Is —R precip
« You should see the following output

precip:

xmrg0701200213z xmrg0701200220z xmrg0702200203z xmrg0702200210z xmrg0702200217z xmrg0703200200z xmrg0703200207z
xmrg0701200214z xmrg0701200221z xmrg0702200204z xmrg0702200211z xmrg0702200218z xmrg0703200201z xmrg0703200208z
xmrg0701200215z xmrg0701200222z xmrg0702200205z xmrg0702200212z xmrg0702200219z xmrg0703200202z xmrg0703200209z
xmrg0701200216z xmrg0701200223z xmrg0702200206z xmrg0702200213z xmrg0702200220z xmrg0703200203z xmrg0703200210z
xmrg0701200217z xmrg0702200200z xmrg0702200207z xmrg0702200214z xmrg0702200221z xmrg0703200204z xmrg0703200211z
xmrg0701200218z xmrg0702200201z xmrg0702200208z xmrg0702200215z xmrg0702200222z xmrg0703200205z xmrg0703200212z
xmrg0701200219z xmrg0702200202z xmrg0702200209z xmrg0702200216z xmrg0702200223z xmrg0703200206z

Background Information: Prior to OB8.2 precip grids were copied after selecting “Load” from
the “Select Forecast Group and Carryover Date” display. After selecting load all the available
precip grids were copied to a user’s local directory. This caused the following problems at the
RFC:
1. precip grids are only needed for running DHM; non-DHM users were being impacted by grid
copying; “Load” took longer than before
2. in some cases /data/dhm/$LOGNAME was filling up

The solution in OB8.2 was to only copy when running DHM (from within the DHM operation), and to
only copy the precip grids needed for the current run.
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4.2.2 Test for writing grid output for times other than 12Z
Step A — verify only input grids (precip, parameters, states, and pet) and the input Connectivity

file exist

« From another terminal window cd to /data/dhm/$LOGNAME
« Type the following Is -R
« You should see the following output

Is-R

Connectivity parameters pet precip states

Iparameters:
rutpix_DS.gz

rutpix_ROUGH.gz sac_LZFPM.gz sac_LZSK.gz sac_PFREE.gz sac_RSERV.gz sac_UZK.gz

rutpix_QOCHN.gz rutpix_SLOPH.gz sac_LZFSM.gz sac_LZTWM.gz sac_REXP.gz sac_SIDE.gz sac_UZTWM.gz
rutpix_QMCHN.gz sac_ ADIMP.gz

Jpet:

pe_APR.gz pe_DEC.gz pe_JAN.gz pe_JUN.gz pe_MAY.gz pe_OCT.gz
pe_AUG.gz pe_FEB.gz pe_JUL.gz pe_MAR.gz pe_NOV.gz pe_SEP.gz

Jprecip:

xmrg0701200213z
xmrg0701200214z
xmrg0701200215z
xmrg0701200216z
xmrg0701200217z
xmrg0701200218z
xmrg0701200219z

xmrg0701200220z
xmrg0701200221z
xmrg0701200222z
xmrg0701200223z
xmrg0702200200z
xmrg0702200201z
xmrg0702200202z

xmrg0702200203z
xmrg0702200204z
xmrg0702200205z
xmrg0702200206z
xmrg0702200207z
xmrg0702200208z
xmrg0702200209z

xmrg0702200210z
xmrg0702200211z
xmrg0702200212z
xmrg0702200213z
xmrg0702200214z
xmrg0702200215z
xmrg0702200216z

xmrg0702200217z
xmrg0702200218z
xmrg0702200219z
xmrg0702200220z
xmrg0702200221z
xmrg0702200222z
xmrg0702200223z

sac_LZPK.gz sac_PCTIM.gz sac_RIVA.gz sac UZFWM.gz sac_ZPERC.gz

xmrg0703200200z
xmrg0703200201z
xmrg0703200202z
xmrg0703200203z
xmrg0703200204z
xmrg0703200205z
xmrg0703200206z

xmrg0703200207z
xmrg0703200208z
xmrg0703200209z
xmrg0703200210z
xmrg0703200211z
xmrg0703200212z

JIstates:

rutpix_areacl_initial.0701200212z.9z sac_adimpc_initial.0701200212z.gz sac_uzfwec_initial.0701200212z.9z
rutpix_areac2_initial.0701200212z.9z sac_lzfpc_initial.0701200212z.gz sac_uztwc_initial.0701200212z.9z
rutpix_areac3_initial.0701200212z.9z sac_lzfsc_initial.0701200212z.9z

rutpix_depth_initial.0701200212z.9z sac_lztwc_initial.0701200212z.9z

Step 1 — Configure DHM to write output grids for every 12 hours from 2002-07-01 12 Z to 2002-
07-0212 7
* From the “NWSREFS Interactive Forecast Program “Options Menu select “Configure
DHM Grid Output”
Result — You should see the following display

\, DHM Output Grids Configuration

Output Grids For: [All DHM Basins in FGroup |~ |

Start Date 2007-04-2312 7

End Date 2007-04-23 12 7
Time Interval: 15

Grid Types
[] Channel Flow

[]SAC State
[] Kinematic State

[] Total Runoff

e Set Output Grids For to “All DHM Basins in FGROUP”
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» Set Start Date to 2002-07-01 12Z

e Set End Date to 2002-07-02 12Z

e Set Time Interval to 12

» Select All Grid Types (Channel Flow, Sac State, Kinematic State, and Total Runoff)
* Select OK

Step 2 — Run DHMFG again and verify input and output grids exist

« From the “NWSREFS Interactive Forecast Program” display’s File Menu select
File=>Yes>No

« From the “Select Forecast Group and Carryover Date” display select DHMFG as the
Forecast Group and Julyl, 2002 12Z as the Carryover Date, Click Load

« From the “NWSREFS Interactive Forecast Program” display’s File Menu select Begin

« From another terminal window cd to /data/dhm/$LOGNAME

e Type the following Is -R

« You should see the following output. There are grids under channelflow, runoff, and

states.
Is-R

Connectivity channelflow parameters pet precip runoff states

Jchannelflow:
channelflow_0701200212z.0702200200z.gz channelflow_0701200212z.0702200212z.9z

Iparameters:

rutpix_DS.gz  rutpix ROUGH.gz sac_LZFPM.gz sac_LZSK.gz sac_PFREE.gz sac_RSERV.gz sac_UZK.gz
rutpix_QOCHN.gz rutpix_SLOPH.gz sac_LZFSM.gz sac_LZTWM.gz sac_REXP.gz sac_SIDE.gz sac_UZTWM.gz
rutpix_QMCHN.gz sac_ ADIMP.gz sac_LZPK.gz sac_PCTIM.gz sac_RIVA.gz sac_UZFWM.gz sac_ZPERC.gz

Jpet:
pe_APR.gz pe_AUG.gz pe DEC.gz pe FEB.gz pe_JAN.gz pe_JUL.gz pe_JUN.gz pe_MAR.gz pe_MAY.gz pe_NOV.gz pe _OCT.gz
pe_SEP.gz

precip:

xmrg0701200213z xmrg0701200219z xmrg0702200201z xmrg0702200207z xmrg0702200213z xmrg0702200219z xmrg0703200201z
xmrg0703200207z xmrg0701200214z xmrg0701200220z xmrg0702200202z xmrg0702200208z xmrg0702200214z xmrg0702200220z
xmrg0703200202z xmrg0703200208z xmrg0701200215z xmrg0701200221z xmrg0702200203z xmrg0702200209z xmrg0702200215z
xmrg0702200221z xmrg0703200203z xmrg0703200209zxmrg0701200216z xmrg0701200222z xmrg0702200204z xmrg0702200210z
xmrg0702200216z xmrg0702200222z xmrg0703200204z xmrg0703200210zxmrg0701200217z xmrg0701200223z xmrg0702200205z
xmrg0702200211z xmrg0702200217z xmrg0702200223z xmrg0703200205z xmrg0703200211zxmrg0701200218z xmrg0702200200z
xmrg0702200206z xmrg0702200212z xmrg0702200218z xmrg0703200200z xmrg0703200206z xmrg0703200212z

Jrunoff:
total_runoff_0701200212z.0702200200z.gz total_runoff_0701200212z.0702200212z.gz

Jstates:

rutpix_areacl_0701200212z.0702200200z.9z rutpix_depth_0701200212z.0702200212z.9z sac_lzfsc_initial.0701200212z.9z
rutpix_areacl_0701200212z.0702200212z.9z rutpix_depth_initial.0701200212z.9z sac_lztwc_0701200212z.0702200200z.gz
rutpix_areacl_initial.0701200212z.9z sac_adimpc_0701200212z.0702200200z.gz sac_lztwc_0701200212z.0702200212z.9z
rutpix_areac2_0701200212z.0702200200z.9z sac_adimpc_0701200212z.0702200212z.9z sac_lztwc_initial.0701200212z.9z
rutpix_areac2_0701200212z.0702200212z.9z sac_adimpc_initial.0701200212z.9z sac_uzfwc_0701200212z.0702200200z.9z
rutpix_areac?_initial.0701200212z.g9z sac_lzfpc_0701200212z.0702200200z.gz sac_uzfwc_0701200212z.0702200212z.9z
rutpix_areac3_0701200212z.0702200200z.9z sac_lzfpc_0701200212z.0702200212z.9z sac_uzfwec_initial.0701200212z.9z
rutpix_areac3_0701200212z.0702200212z.9z sac_lzfpc_initial.0701200212z.9z sac_uztwc_0701200212z.0702200200z.9z
rutpix_areac3_initial.0701200212z.9z sac_lzfsc_0701200212z.0702200200z.9z sac_uztwc_0701200212z.0702200212z.gz
rutpix_depth_0701200212z.0702200200z.9z sac_lzfsc_0701200212z.0702200212z.9z sac_uztwc_initial.0701200212z.9z

Background Information: Prior to OB8.2 there was no way to produce grid output when
running DHM through IFP. The only DHM grid output were initial SAC and Kinematic state
(those with _initial in there name) and channelflow grids, and these were only written as part of
batch mode carrysave runs through OFS/FCST.
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In OB8.2, intermediate sac and kinematic state grids (those without _initial in their name),
channelflow, and total runoff can be output when running DHM through IFP. These grids have
the format variableName_startMMDDYYYYHHZ.outputMMDDYYYYHHZ.gz For example the
grid total_runoff_0701200212z.0702200200z.gz is a grid covering the entire rfc showing total
runoff on July 2, 2002 00Z from a run with start date of July 1, 2002 12Z.

4.2.3 Test for defining DHM Precipitation Mods
Step 1 — Select the Forecast Group and dates to run
e From the “NWSREFS Interactive Forecast Program” display’s File Menu select
File->Yes>No
« From the “Select Forecast Group and Carryover Date” display select DHMFGMOD
as the Forecast Group and Julyl, 2002 12Z as the Carryover Date, Click Load

Result — the Forecast Group Topology map shown below is displayed

2% Forecast Group Topology

DHMFGMOD

Step 2 — Run the one segment in the Forecast Group without any mods
« From the “NWSREFS Interactive Forecast Program” display’s File Menu select Begin
« you should see the following tultable ( a table GUI in the background)

Day Hour |DHMOP1.SQIN|DHMOP2.5GIN
3 01 0.63 0.63 5
3 02 0.54 054
303 047 047
3 04 0.41 041
3 05 0.37 0.37
3 08 0.33 0.33
3 07 0.30 0.30
3 08 0.27 0.27
3 09 0.25 025
310 0.23 023
311 0.22 0.22
312 0.20 0.20
313 0.19 0.19 4
e — ]
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Background Information: The topology map shows DHMFGMOD consists of one segment.
(DHMMODS). By selecting this segment from the topology display and then selecting
Display->Operations Table from the “NWSRFS Interactive Forecast Program” display. You will
see the following operations table for this segment

2% Operations Table g@@

DHMMODS

DHM-0FP DHMOPL
DHM-0P DHMOPZ
FLOT-TUL DHMTWO
FLOT-TS DHMTWO

Show |

The display shows DHMMODS has two DHM-OP operations. By selecting each operation from
the table and selecting “Show”. The following information appears:

DHMOP1 : CONTENTS ID TYPE TIME INTERVAL BASINID
OUTLET FLOW DHMOP1 SQIN 1HOUR DHMMOD1.
DHMOP2 : CONTENTS ID TYPE TIME INTERVAL BASINID

OUTLET FLOW DHMOP2 SQIN 1HOUR DHMMOD1.

The operations table and segment definitions show DHMOP1 and DHMOP2 are modeling the
same basin (DHMODJ) and storing the resulting outlet flow into separate SQIN time series
(DHMOP1 and DHMOP?2 respectively)

Step 3 — Re-run the segment after applying a DPRECIP Mod
« From the the “NWSRFS Interactive Forecast Program” Modifications Menu select
“Other mods”
Result — The display below appears
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3¢ Mods for: DHMMODS

Available Operations —Available Run-time Mods—
(Show Mods for ALL — Mod selected DPRECIP — |
~Mod Value—— | [ Operations/Time-series

Mo value entry for this Mod Type / Name
DHM-OP DHMOP1
DHM-OP DHMOP2
—Mod Dates——— ~Time-series Dates

Mo dates to change for this Mod Mo DATE values for this Mod
—Options——— [ Display

Mo options for this Mod _I| Show Mods Viewer

Apply to:  SEGMENT — |

Create | Close | Undo | Preferencesl Help |

» From the “Mods Selected” tab select DPRECIP
Result — the display below appears

PRECIP Mod for: DHMMODS CExK

Operation Names |DHMOP1 =
Precip Multiplier |1.0

Start Date 2002-07-0112 Z
End Date 2002-07-0312 Z

Valid Date

o] [cane

e Operation Names = DHMOP1

« Select Start Date = 07/01/2002 12Z
« End Date =07/03/2002 12Z

« Precip Multiplier = 2.0

« OK
« From the “NWSRFS Interactive Forecast Program” display’s File Menu select Re-
Run...

Result — You should seep the following table in the background
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able EEX
Day Hour |DHMOP1.SQIN|DHMOP2.SGIN
301 079 0.63 Y
3 02 066 054
3 03 057 047
304 049 4
305 043 037
308 0.38 033
307 034 030
3 08 031 027
3 09 028 025
310 0.26 023
311 024 022
312 022 0.20
313 021 019 -
T — ]

The SQIN values for DHMOP1 are higher because of the precip multiplier

Step 4 — Re-run the segment after applying two DPRECIP Mods

« From the the “NWSRFS Interactive Forecast Program” Modifications Menu select
“Mods viewer”
Result — the display below appears

>4 Mods Viewer

Mode Edit —
— Mew Mods
I I3
=] |
=
—Mods from file
f I3
.DPRECIP 070102127 070302127 070302122 J
DHMMODS 2.00 / DHMOP1 .
|2} |
re
—FGroup/Range Mods from file
F 3]
|==) ]
re
— OFS Mods
F 3|
|=] |
re
— OFS FGroup/Range Mods
F 3|
=] |

« Remove the previous DPRECIP mod by selecting all the text in the “Mods from file”
pane and pressing the space bar
e From the the “NWSRFS Interactive Forecast Program” Modifications Menu re-select
“Mods viewer” and “Yes” to save changes
« From the the “NWSRFS Interactive Forecast Program” Modifications Menu select
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“Other mods”

Set:

Result —

From the “Mods Selected” tab select DPRECIP

Operation Names = DHMOP1

Select Start Date = 07/01/2002 12Z

End Date = 07/02/2002 00Z

Precip Multiplier = 1.5

OK

From the the “NWSRFS Interactive Forecast Program” Modifications Menu select
“Other mods”

From the “Mods Selected” tab select DPRECIP

Set:

Operation Names = DHMOP1

Select Start Date = 07/02/2002 00Z

End Date = 07/02/2002 12Z

Precip Multiplier = 2.0

OK

From the “NWSRFS Interactive Forecast Program” display’s File Menu select Re-
Run...

You should seep the following table in the background

Day Hour lm,m
301 .72 063 3
3 02 .61 054
3 03 053 047
3 04 046 041
3 05 041 037
3 06 0.36 033
3 07 0.33 0.30
3 08 030 0.27
3 09 0.27 0.25
310 0.25 0.23
311 023 0.22
312 0.22 0.20
313 0.20 0.19 4

s

4.2.4 Test for defining Sac State Mods

e From the the “NWSRFS Interactive Forecast Program” Modifications Menu select

“Mods viewer”

¢ Remove the previous DPRECIP mods by selecting all the text in the “Mods from file” pane
and pressing the space bar

e From the the “NWSRFS Interactive Forecast Program” Modifications Menu re-select

“Mods viewer” and “Yes” to save changes

e From the the “NWSRFS Interactive Forecast Program” Modifications Menu select

“Other mods”

e From the “Mods Selected” tab select DSACST

Result —

the display below appears
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2% DSACST Mod for: DHMMODS

Operation Names |DHMOPL :

Upper Zone Tension Water Contents |1.0
Upper Zone Free Water Contents [1.0
Lower Zone Free Primary Water Contents (1.0

Lower Zone Free Secondary Water Contents |1.0

Lower Zone Tension Water Contents [1.0

Additional Impervious Area Water Contents |1.0

Start Date

« Set Upper Zone Tension Water Contents to 2.0
» Set Upper Zone Free Water Contents to 2.0

« Select OK
« From the “NWSRFS Interactive Forecast Program” display’s File Menu select Re-
Run...

Result — You should seep the following table in the background

Day Hour |DHMOP1.SQIN|DHMOP2.SQIN
301 .65 0.63 A
302 0.56 054
303 0.49 047
304 043 0.41
3 05 038 037
3 06 035 033
3 07 0.3 030
3 08 0.29 027
3 09 0.26 025
310 024 023
311 023 022
312 021 0.20
313 0.20 0.19 -

425 Test for running a DHM segment with more than one inflow

Step 1 — Select Forecast group and dates to run
« From the “NWSREFS Interactive Forecast Program” display’s File Menu select
File>Yes>No
e From the “Select Forecast Group and Carryover Date” display select DHMINFL as
the Forecast Group and Julyl, 2002 12Z as the Carryover Date, Click Load
Result — the Forecast Group Topology map shown below is displayed
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Forecast Group Topology

DHMINFL

HUP  THFLOW
P2 Lovs|

Step 2 — Run the segment 1INFLOW
« From the “NWSREFS Interactive Forecast Program” display’s File Menu select Begin
« You should see the following tultable

able EEX
Day Hour ,m,m
3 01 7.00 12.39 A
3 02 £.30 12.72
3 03 £.80 13.34
304 7.20 1412
3 05 .60 14.92
3 06 7.80 15.61
3 07 8.00 16.21
3 08 8.20 16.75
3 09 8.40 17.27
310 8.50 17.70
3n 8.70 18.14
312 8.90 18.59
313 8.10 19.02 7

Step 3 — Run the segment 2INFLOWS
« From the “NWSREFS Interactive Forecast Program” display’s File Menu select Next
« You should see the following tultable
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able &(=)E3
Day Hour TEST2.QINE TEST3.QINE  |2INFLOWS.SQIN
3 01 B.60 1.40 12.39 Al
3 02 5.10 1.20 12.72
3 03 5.40 .40 13.34
3 04 5.60 1.60 14.12
3 05 5.80 1.80 1492
3 06 5.90 1.90 1561
3 07 $.00 2.00 16.21
3 08 B.10 2.10 16.75
3 09 B.20 9.20 07.27
310 $.20 2.30 17.70
3 11 $.30 D.40 18.14
312 $.40 250 18.59
313 B.50 260 19.02 <

Background Information: The topology map shows DHMINFL consists of five segments.
DHMUPL1 and 1INFLOW are an upstream-downstream combination where the operations table
in segment LINFLOW has a DHM-OP using the results from DHMUP1 (TEST1.QINE) as its
inflow. The other three segments (DHMUP2, DHMUP3, and 2INFLOWS) is a second
upstream-downstream combination where the results from DHMUP2 and DHMUP3
(TEST2.QINE and TEST3.QINE respectively) are used as inflows for the DHM-OP in segment
2INFLOWS. The DHM-OP definitions in segment 1INFLOW and 2INFLOWS are modeling
the same basin. The only difference is the DHM-OP in 1INFLOW uses 1 inflow timeseries, and
the DHM-OP in 2INFLOWS uses two. The Tulsa table shows the outlet flow from both DHM-
OPs (LINFLOW.SQIN and 2INFLOWS.SQIN) are the same. The magnitude of the inflow
flowing into 2INFLOWS (TEST2.QINE and TEST3.QINE equals the inflow flowing into
1INFLOW, TEST1.QINE)

4.2.6 Test Grid Editor Program

The Grid Editor Program is a utility to create operational DHM grids from previous
calibration.

The test procedures are shown in Appendix B.

Appendix A — IFP tests procedures
A. Generate test data and start IFP

After extracting the tar zipped testpackage:
1. cdto the directory ./dhmtestpackage/ifptests

2. execute the command runlFPwithDHMORP rls - this script creates a set ofs fs5files and
starts IFP

Result: filesize, filecrat, prdutil, sasmdb, goesdb, fcinit, and fcst run in the
background, the NWSRFS Interactive Forecast Program and Select Forecast
Group and Carryover Date windows pop up.
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B. Run a forecast group with a distributed headwater segment

1. Inthe Select Forecast Group and Carryover Date window Select the DHMFG forecast
group with Carryover date Jul 1, 2002 12, Z. Click the load button.

Result: A dialog saying "Please wait while....." and the Forecast Group
Topology window displays.

2. Inthe NWSRFS Interactive Forecast Program window Select Options—> Set dates...
In the NWSRFS run dates dialog Set End of observations to Jul 6 2002 12 Z and End of
run to Jul 6 2002 12 Z and Click the Set button.

Result: Run dates are ready.
3. Select File-> Begin

Result: In the background window used to start IFP, the DHM settings showed
below scroll by. And the IFP Plot window pops up with the plot showed below.

*hkhkhhkhkkkhkhkhkhirhhhhhhkhihirriiiixd D H M O pe ratl 0 n*************************

* Start of run period: 7/1/2002 12Z
* Start of forecast period : 7/6/2002 12Z
* End of run period: 7/6/2002 12Z
* Basin ID : DHMBASL1
* Upstream Basin ID:
* precipitation data directory : /data/dhm/$SLOGNAME/precip
* DHM Model data directory : $PWD/test_run_files
* D2D data directory : N/A
* DHM Notify data directory : N/A
* number of hour(s) of future precipitation: 0
* Carryover will not be saved

KhhkhkAhkhkhkikkhkhkrkhkhkhkkhkhkhkhhkhkkhhkhkirhkhihhkhkihhkhkrhkhkhhkhkrhkhkihhkhkihhkhkirhhkhhhkkhihkkhihkihhkhihkiiikkh
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4.

FP Plot: ROOT R. @ LANESBORO - HMDS - FOR DHM TESTING
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This completes the test for running a forecast group containing a segment with one
DHM-OP.

C. Run aforecast group with two distributed segments feeding a lumped down
stream segment.

1.

In the NWSRFS Interactive Forecast Program window Select File—>New Forecast
Group...

Result: The NWSRFS Interactive Forecast Program dialog pops up
Click the Yes button.

Result: The NWSRFS Interactive Forecast Program dialog pops down and the Copy
Run-time Mods to NWSRFS dialog pops up

Click the NO button.

Result: Dialog Copy Run-time Mods to NWSRFS pops down and the window Select
Forecast Group and Carryover Date pops up.
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Select the DHMFGA forecast group, Jul 1, 2002 12, Z as the Carryover date, Use
previous IFP files from the drop down menu, and click the Load button.

Result: The Forecast Group Topology window pops up.
In the NWSRFS Interactive Forecast Program window Click File->Begin...
Result: In the background window used to start IFP, the DHM settings for each segment
scrolls by. And the IFP Plot window showed below pops up.
*hkhkkkhkhkhkhkhkhkhkhkhkhhkhhhkhhhkhhhkhhiiik D H M O pe ratl 0 n*************************
* Start of run period: 7/1/2002 127
* Start of forecast period : 7/6/2002 12Z
* End of run period: 7/6/2002 12Z
* Basin ID : DHMBASL1
* Upstream Basin ID:
* precipitation data directory : /data/dhm/$LOGNAME/precip
* DHM Model data directory : $PWD/test_run_files
* D2D data directory : N/A
* DHM Notify data directory : N/A
* number of hour(s) of future precipitation: 0
* Carryover will not be saved
R AR R R R R R R R S R R R R R R R R R S R R R R R R R R R R S R R S R R S R R R S R S S R S R S R S S S S R S S S R S S S S S
******************************DHM Operati0n*************************
* Start of run period: 7/1/2002 12Z
* Start of forecast period : 7/6/2002 12Z
* End of run period: 7/6/2002 12Z
* Basin ID : DHMBAS2
* Upstream Basin ID:
* precipitation data directory : /data/dhm/$LOGNAME/precip
* DHM Model data directory : $PWD/test_run_files
* D2D data directory : N/A
* DHM Notify data directory : N/A
* number of hour(s) of future precipitation: 0
* Carryover will not be saved

KhhkhkAhhkhkAhkhkhkihhkhkrhkhkrhhkhhhkrihhkhhhkhhhkhhhkhkhhkhkihkhkkhhkhkkihkhkrhhkkihhkkihhkkihhkkikhhkkhiikiiikkx
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4.

Plot: ROOT R. @ LANESBORO - HMDSA - FOR DHM TESTING
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This completes the test for two DHM-OP segments feeding a lumped downstream
segment.

D. Run a forecast group where the downstream outlet hydrographs show the
total flow using lumped and distributed routing

1.

In the NWSRFS Interactive Forecast Program window Select File—>New Forecast
Group...

Result: The NWSRFS Interactive Forecast Program dialog pops up
Click the Yes button.

Result: The NWSRFS Interactive Forecast Program dialog pops down and the Copy
Run-time Mods to NWSRFS dialog pops up

Click the NO button.

Result: Dialog Copy Run-time Mods to NWSRFS pops down and the window Select
Forecast Group and Carryover Date pops up.

Select the DHMFGB forecast group, select Use previous IFP files from the drop down
menu, and click the Load button.
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Result: The DHMFGB forecast group loads. And Forecast Group Topology window
pops up.

5. Click File->Begin...
Result: In the background window used to start IFP, the DHM settings for both DHM-
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is completes the test of generating a hydrograph at a downstream distributed segment.

E. Run a forecast group with lumped (SAC-SMA and Unit Hydrograph) and
distributed (SAC-SMA and Kinematic Routing) modeling the same area.

1. Inthe NWSRFS Interactive Forecast Program window Select File->New Forecast
Group...

Result: The NWSRFS Interactive Forecast Program dialog pops up
2. Click the Yes button.

Result: The NWSRFS Interactive Forecast Program dialog pops down and the Copy
Run-time Mods to NWSRFS dialog pops up

3. Click the NO button.
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4. Result: Dialog Copy Run-time Mods to NWSRFS pops down and the window Select
Forecast Group and Carryover Date pops up.

5. Select the DHMFGC forecast group, select Use previous IFP files from the drop down
menu, and click the Load button.

Result: The DHMFGC forecast group loads. And Forecast Group Topology window
pops up.
6. Click File->Begin...

Result: In the background window, the DHM settings for the DHM-OP in DHMSEGC
scroll by. And the IFP-Plot window showed below pops up
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7. This completes the test of a distributed and lumped SAC-SMA feeding a lumped
downstream segment test.
F. This forecast group run is the same as in section B, but the amount of future
precipitation data DHM-OP uses is adjusted through the IFP GUI.
1. Inthe NWSRFS Interactive Forecast Program window Select File->New Forecast
Group...
Result: The NWSRFS Interactive Forecast Program dialog pops up
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2. Click the Yes button.

Result: The NWSRFS Interactive Forecast Program dialog pops down and the Copy
Run-time Mods to NWSRFS dialog pops up

3. Click the NO button.

Result: Dialog Copy Run-time Mods to NWSRFS pops down and the window Select
Forecast Group and Carryover Date pops up..

5. Inthe Select Forecast Group and Carryover Date window Select the DHMFG forecast
group with Carryover date Jul 1, 2002 12, Z. Click the load button.

Result: A dialog saying "Please wait while....." and the Forecast Group Topology
window displays..

6. Inthe NWSREFS Interactive Forecast Program window Select Options—> Set dates...
In the NWSRFS run dates dialog Set End of observations to Jul 6 2002 12 Z and End of
run to Jul 4 2002 12 Z and Click the Set button.

Result: Run dates are ready.
7. Click Options—=>Techniques—=>Universal...
Result: The Universal Techniques window shown below pops up.

2% Universal Technigues

Time Zone Units Miscellaneous
General
Input
Z ._| ~ English “* Metric .
: . - ==
Output Run-time kModifications Future Precipitation
z |.| English hkietric
™ Mods Warning
General ~ &
hMods SAC A ¥
¥ |.|
API ~ &
Set | Cancel | Help |

8.

Set Future Precipitation to 12 (this specifies the number of hours of gridded future
precipitation to use). Click the Set button.
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Result: Future Precipitation is set to 12 hours (the rest of the forecast period will use 0 for
future precipitation).

9. Click File->Begin...

Result: In the background window, the DHM settings are shown with future precipitation
set to 12 hours. And the IFP Plot window pops up with the display showed below.

*hkkkkkhkkhkkikkhkkhkkhkkhkhkkikkhkkikkkhkhkkkiikkkik D H M O pe I’atl 0 n*************************
* Start of run period: 7/1/2002 127

* Start of forecast period : 7/4/2002 12Z

* End of run period: 7/6/2002 12Z

* Basin ID : DHMBAS1

* Upstream Basin ID:

* precipitation data directory : /data/dhm/$LOGNAME/precip
* DHM Model data directory : $PWD/test_run_files
* D2D data directory : N/A
* DHM Notify data directory : N/A
* number of hour(s) of future precipitation: 12
* Carryover will not be saved

*hhkhkAhkhkhkkhkhkhkkhhkhkrhkhkikhhkhhhkhhhkhhhkhhhkhhhkhkkhhkhkihkhkkihhkhkkihkhkirhhkkihhkihhkkihhkkikihkkiiikiiikkx
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IFP Plot: ROOT R. @ LANESBORO - HMDS - FOR DHM TESTING
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10. This completes the test to show setting the amount of future precipitation used by DHM-
OP

G. End of IFP run.
1. Select File->Quit
Result: IFP windows pop down.
This completes the IFP portion of the DHM test.
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Appendix B — DHM Grid Editor Tests

Grid Editor Test Procedures
Do the following steps:
cd dhmtestpackage

Run setup script. Type:
. runsetup

Run the script “run_dhm_grid_editor”. Type:
cd $(gad util_rls)
run_dhm_grid_editor&

Result: The following display will pop up.

Grids Builder Display

| Output Directory Path ||jfs;hseb;pda;users;aiw;omzjdE\djsrc;dhmjdhmGuis;testoutput |

Input Directo

1y Paths
[ 5 2 |,ffsjhseb;pda;users;aiw;omz,fdewsrc,fdhmjdhmGuis;testData;WGRFd

Grids: |,ffsjhseb;pda;users;aiw;omz,fdewsrc,fdhmjdhmGuis;testData;WGRFd

|,ffsjhseb;pda;users;aiw;omz,fdewsrc,fdhmjdhmGuis;testData;WGRFd

| Connectivity File: | |,ffsjhseb;pda;users;aiw;omz,fdewsrc,fdhmjdhmGuis;testData,fWGRFq

Intitial State Date: 2007-04-27 12 7
Basin ID: | |V| | Load Basin IDs |

Enter Input and Output directory selection. Do the following steps:

- Click on “Connectivity File” button to enter connectivity file, select the file “Connectivity”.
- Click on *“State Grids” button to enter State grids input directory, select file “rdhmStatefiles”
- Click on “Parameter Grids” button to enter parameter grids input directory, select file
“parameters”

- Click on “PET Grids” button to enter the PET input directory, select file “aprioriPet”

- Click on “Initial State Date” button to enter date, select “July 1, 2002” for date

- Click on “Load Basin IDs” button

Result: The following display will pop up.
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rids Builder Display

| QOutput Directory Path ||,ffsjhseb,fpda}usersjai\mfob82,fdeWsrc,fdhm;dhmGuis;testoutput |

Input Directory Paths

lifs hseb fpa/users /aivo/obB2 fdew/src/dhm/dhmGuis ftestData/ WGRFC/rdhmstateFiles)|

| Parameter Grids: | |,ffsjhseb;pda}users;aiwmsz,fdE\d,fsrc,fdhm,fdhmGuis,ftestDatajWGRFC;parameters |
PET Grids: |,ffsjhseb;pda}users,fai\mfob82,fdewsrc,fdhm,fdhmGuis,ftestData,fWGRFijet |

| Connectivity File: | |,ffsjhseb;pda}users;ai\mmb&,fdE\d,fsrc,fdhm;dhmGuis,ftestData;WGRFC;CDnnecti\fitv |

Intitial State Date: 2002-07-0112 7

Basin ID: lacrT2 || | lLoad Basin IDs| |

Load Grid Tables

1) Test Change Parameter Grids using Operation Multiplier.

From the main window, do the following steps:
- Click on “Load Grid Tables” button
Result: the “Set ARCT2 Grids” display will pop up.

Set ACRT2 Grids

| Create Sac Grids r Create Kinematic Grids r Create PET Grids
Parameter Variable Names QOperation | Yalue State Variable Names Operation | Yalue
upper zone tension water masx multiplier 1||upper zone tension water contents multiplier 1
Upper zone free water max multiplier 1||upper zane free water contents multiplier 1
upper zone coefficient multiplier 1|[lower Zone tension water cantents multiplier 1
lower Zone tension water max multiplier 1|[lower zone free secondary water cantents  |multiplier 1
|ower Zone free primany max multiplier 1||lmwer zane free primary water contents multiplier 1
lower Zone free secondary max multiplier 1|(additional impervious area water contents  |[multiplier 1
lower Zone primary coefficient multiplier i
lower Zone secondary coefficient multiplier il
maximum percolation rate multiplier i
FEXP multiplier il
primary freg multiplier il
percent imperyious area multiplier i
additional impervious area multiplier T
riparian wegetation area multiplier i
FSERY multiplier il
SIDE multiplier 1
Create Grids H Set Defaults
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There are three display tabs “Create SAC Grids”, “Create Kinematic Grids”, and “Create PET
Grids” allowing the user to change grids values.

From “Create SAC Grids” table, Type:
- For parameter variable name: upper zone tension water max”, set “Value” =5

Result: the following display will pop up

et ACRT2 Grids =13
l/ Create 5ac Grids |/ Create Kinematic Grids r Create PET Grids |
Parameter Yariable Mames Qperation | Yalue State Wariahle Names Operation | value
UpPer Zone TeNsion Waler max multiplier Sllupper Zone tension water Contents multiplier 1
Upper zane free water max multiplier l{upper Zone free water contents multiplier 1
upper zone coefficient multiplier 1|[loweer zone tension water contents multiplier 1
lower Zone tension water max rmultiplier 1|lower zone free secondary water contents  (multiplier 1
lower zone free primary max multiplier 1|[loweer zone free primary water contents multiplier 1
lower zone free secandary max rmultiplier 1|ladditional impervous area water contents  (multiplier 1
lower Zone primary coefficient multiplier 1
lower zone secandarny coefficient rmultiplier 1
maximum percolation rate multiplier 1
FEXF multiplier 1
primary free multiplier 1
QDErCent impenious area multiplier 1
additional imperdous area multiplier 1
riparian wegetation area multiplier 1
RSERY rmultiplier 1
SIDE multiplier 1
Create Grids | | Set Defaults

- Click on “Create Grids”
Result: SAC Grid data have been written to the grid output data.

Verify correct data have been written to the file. Type:
cd dhmtestpackage/grideditortests
run_grid_editor_tests

Result: 2 right, 0 wrong, 0 ignored, 0 exceptions
2) Test Changing State Grids using Operation Percent.
From “Create SAC Grids” table, do the following steps:
- For state variable name: upper zone tension water contents” , set “Operation” to percent and

“Value” = 50
Result: the following display will pop up
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et ACRT2 Grids FEX
1/ Create 5ac Grids r Create Kinematic Grids r Create PET Grids |
Parameter Wariable Mames Operation | Walue | State Wariable Mames Qperation | Yalue
Upper Zone tension water max multiplier l{|upper Zone tensian water cantents percent (i S0
Upper Zone free water max multiplier 1||upper zone free water contents multiplier 1
upper zZone coefficient multiplier L|{lower zane tension water cantents multiplier 1
|ower Zone tension water max multiplier 1|[lower zone free secondary water cantents  |multiplier 1
lower Zone free primary max multiplier 1|[lower zone free primary water contents multiplier 1
lower Zone free secondary max multiplier 1|ladditional impervious area water contents  |multiplier 1
lower Zone primany caefficient multiplier 1
lower Zone secondary coefficient multiplier 1
maximum percolation rate multiplier 1
FE%P multiplier 1
primary free multiplier 1
percent impervous area multiplier 1
additional impervious area multiplier 1
riparian vegetation area multiplier 1
FSERY multiplier 1
SIDE multiplier 1
Create Grids H Set Defaults

- Click on “Create Grids”
Result: SAC Grid data have been written to the grid output data.

Verify correct data have been written to the file. Type:
cd dhmtestpackage/grideditortests
run_grid_editor_tests states

Result: 2 right, 0 wrong, 0 ignored, 0 exceptions

From the “Grid Builder Display” select “File”>EXxit” to close the program.

The test is completed.
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