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INTRODUCTIONtc \l1 "INTRODUCTION

This document is a guide for users on how to use the Historical Data Browser (HDB).  It gives information on how to enter information, select items, display information, locate stations of interest, write time series and get on-line help.

The Historical Data Browser allows a user to extract time series of historical data for use in subsequent applications.  The user can locate a station or a group of stations, display information about any station, compare station information and data, re-use queries from session to session and save the station selections.

Section 2 of this document discusses starting the Historical Data Browser.  Users search for stations with particular characteristics using the Station Search screen discussed in Section 3.  The stations found are plotted on the map display where the user can perform a variety of operations (Section 4).  Station information and data can be displayed using the Station Information screen (Section 5) and station information and data can be compared using the Compare Station screen (Section 6).  Stations are added to a Selected Station List (Section 7) for later extraction of time series (Section 8).  Time Series can be written in groups (Section 9) and input can be created for the MAT program (Section 10) and the PXPP program (Section 11).  Section 12 discusses user preferences.

SECTION 1
GENERAL INFORMATIONtc \l1 "GENERAL INFORMATION

In Build OB 7.2, The HDB applications have been ported to the Linux workstations. The Linux

version of HDB has some additional functionality not present in the Unix version of HDB. That additional functionality concerns mostly the “look and feel” of the main window which is the map display. The older version of HDB will remain the same with its functions and will continue to be launched from the HP machine. 

When HDB is started, a pop up window keeps the user informed of the progress of the initialization of the application. This dialog box is removed once the main window is successfully displayed. The appearance of the main window of the HDB application remains almost the same as that of the Shared Windows Server screen. The most obvious difference is that the tool area containing a button in the upper left side in the scrolling area was removed. The menu bar across the top of the main window now features two additional drops down menu items: Tools and Projections.

These menus and their contents will be discussed bellow (see section). Another difference in the main window is the missing zoom and recenter buttons in the lower left hand corner (yellow arrow). They have been moved to the mouse control and to Tools drop down menu.

The Linux application is written using functions from the GeoMapServer library which is a collection of C functions using X/Motif libraries to render and manage a geographic-based image.

Characteristics of HDB application are discussed below:

GUI Environment:  Methods for managing the GUI environment such as selecting items from a list or menu, entering data into a text field, scrolling and closing dialogs and screens are consistent with Motif standards.

Disk Space: The Historical Data Browser extracts data from historical data archives and stores it on disk in a location specified in the User Preferences (see Section 12).  The actual data is generally located remotely on OHD servers and is retrieved via the Internet.
In all cases when the data is viewed and when the time series are written, the information is stored on the user’s local system.  Additional disk space is not consumed during the search process.  It is consumed when the data is viewed or when time series are written.  This requires disk space!  The user should be aware that attempts to retrieve data from large numbers of stations will consume considerable disk space.  Retrieval over the Internet may also be slow on occasions.

User Preferences for First Time Users: Section 12 discusses User Preferences which are specific to each individual person (user_id).  There are default values for the User Preferences, however first time users should review these settings to ensure appropriate values.

Historical Data Browser resources: The application relies on the proper configuration of a number of resources.  These resources include tables which reside in “ob7_histdata” PostgresSql database, disk files, and user-controlled application tokens (also known as Apps_defaults).  

SECTION 2

STARTING THE HISTORICAL DATA BROWSERtc \l1 "STARTING THE HISTORICAL DATA BROWSER

To start the Historical Data Browser, you must have access to the runhdb script.  Type “runhdb” on the command line.  The map screen (Figure 2.1) will appear.

The Station Map is the HDB Graphical User Interface. It’s the first window which appears when the application is opened, and it is the primary controlling window for the HDB process. This simple window consists of a main menu bar across the top and a large display area. The user has extensive control over what is displayed in the display area. 







Figure 2.1
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SECTION 3

SEARCHING FOR STATIONStc \l1 "SEARCHING FOR STATIONS
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The Station Search screen (Figure 3.1) allows the user to find stations by specifying criteria such as location, data type, etc.  After the selection criteria have been entered, the search is begun by pressing the Find button.  Upon completion of the search, the stations which meet the search criteria are displayed geographically as shown in Figure 4.1 in section 4.







Figure 3.1
The Station Search screen consists of a number of data selection areas.  Data entered in these areas contributes to the selection criteria.  They are combined in an “and” clause rather than in an “or” clause.  For example if latitude and longitude are entered, and all other criteria are left blank, then information on all data for all stations within the lat/lon rectangle are plotted.  If station names are also entered, then only those stations which satisfy both the lat/lon and the name criteria are retrieved.

The search will find stations that satisfy the search criteria.  However, the stations found may have information besides the information specified in the search criteria.  For example, a search for daily precipitation stations is likely to find stations that collect temperature in addition to daily precipitation.  This becomes obvious when the user displays information about the station (Section 5).  The Station Information screen shows all information about the station, not just the information requested in the search criteria.
Enter Station Location in: This selection area allows the user to select stations within either a lat/lon rectangle or a particular state.  Note that you may not enter both the Lat/Lon rectangle and a state abbreviation.  The state is chosen by typing its two letter (U.S. Post Office) abbreviation or by selection from a list of states displayed using the list button.

Enter Data for Data Collected: You can require that only stations that were active within a certain time period are displayed by entering appropriate dates in numeric format.  Note; an active station may have data missing.  For example, to select data for 1962, you would enter 1, 1962, 12, and 1962 in the respective boxes.  The system will select stations that were active in 1962; however those stations are not guaranteed to have twelve months of complete record.

Minimum Number of Years Data Recorded: Often the user wants a continuous period of record.  To specify this as selection criteria, enter the number of years of continuous record here.

Data Types: This selection allows you to specify one or more data type as selection criteria.  Multiple data types are combined in an OR clause.  In other words, stations are displayed if they meet any of the specified data type selections.

Data Source: Select NCDC Coop, the only source left.

3.1 Saving Search Criteriatc \l2 "3.1  Saving Search Criteria
The selected search criteria can be saved to a file for later use.  To save the search criteria entered, press the Save button.  A file list dialog will appear as shown in Figure 3.2.  The search criteria will be written to the specified file and a message will appear stating that the search has been saved.
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Figure 3.2
3.2 Loading Search Criteriatc \l2 "3.2  Loading Search Criteria
To load a previously saved search, press the Load button and the file list dialog will appear.  The selected file will be read in and the search criteria will be entered onto the search screen.

3.3 Clearing Search Criteriatc \l2 "3.3  Clearing Search Criteria
To clear the search criteria, press the Clear button.  The system will ask if you are sure that you do want to clear the screen.  If you press the Yes button then the screen will be cleared of all selection criteria.  If you answer No then you will be returned to the Station Search screen without changing the specified selection criteria.

3.4 Performing the Searchtc \l2 "3.4  Performing the Search
To perform the search, press the Find button.  This will close the search screen and a blue circle will be turning around to let you known that the search is being processed.  When all stations that meet the given criteria are found, a message dialog will be displayed informing you how many stations were located.  The stations that have been found will be plotted geographically with color indication the type of station.
If you perform another search, you are asked whether or not you wish to keep the stations found in the prior search.  If you do not want to keep the stations from the previous search, then all of those stations will be removed from the Selected Station List screen, Station Information screen, Comparison screen, and the map display.  If you want to keep the stations found in the prior search, then the stations found in the subsequent search will be added to those found in the prior search. i.e. subsequent searches can add to or replace prior searches.

SECTION 4

STATION MAPtc \l1 "STATION MAP

This section of the document describes in greater detail all of the various utilities available through the menu bar displayed across the top of the HDB main window.

The user can set which overlays are shown during the execution of the application by selecting the various overlay options under the “Map Displays” menu. In addition to this, tokens exist to determine the appearance of the HDB application.

The purpose of this screen is to allow the user to select stations for the production of time series of historical data.  Stations are displayed geographically and the user adds stations to a “Selected Station List” which identifies stations for the production of the time series.  Stations that are on the Selected Station List appear as * and stations not on the Selected Station List appear as an open circle on the map.  The Map display screen displays a map showing the stations selected using the Search Screen, and a menu bar.  A variety of information about the stations can be depicted as discussed below.  An example of the Map display screen is shown below in 
Figure 4.1.








Figure 4.1
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4.1 Display Stations By Observation Timetc \l2 "4.1  Display Stations By Observation Time
Different colors are used for displaying stations based on observation time (default) or data source.  The different observation times displayed are: Daily and Hourly, Daily, Hourly and No Data.  To color stations by observation time, go to the Station Displays menu and select Stations by Observation Time.  The stations will then change color according to their individual observation times.  The Legends option under the Help menu provides a key to the meaning of each color. 
4.2 Displaying A Station’s Numbertc \l2 "4.3  Displaying A Station’s Number
Each station has a number based on its data source.  You are able to display the station’s number next to the station on the map.  To display the station’s number, go to the Station Displays menu and select Station’s Number option.  The station’s number will appear to the right of the station.  To turn off the station’s number select the option again and the station’s number will be removed.

4.3 Displaying A Station’s Elevationtc \l2 "4.4  Displaying A Station’s Elevation
You are able to display the station’s elevation next to the station on the map.  To display the station’s elevation, go to the Station Displays menu and select Station’s Elevation option.  The station’s elevation will appear to the right and a bit above the station.  To turn off the station’s elevation select the option again and the station’s elevation will be removed.

4.4 Displaying The Years A Station Collected Datatc \l2 "4.5  Displaying The Years A Station Collected Data
You are able to show the years that data was collected at the station.  To do so, go to the Station Displays menu and select Years Station Collect Data option.  The beginning year followed by the ending year will appear to the right and a bit below the station.  To turn off the display of the years, select the option again and it will removed from the map.

4.5 Displaying A Station’s Movestc \l2 "4.6  Displaying A Station’s Moves
You are able to display station’s moves.  To do so, go to the Station Displays menu and select Station Moves option.  All previous locations of the selected stations will be added to the display.  To turn off station moves, select the option again and the station moves will be removed.

4.6 Selecting A Station For The Selected Stations Listtc \l2 "4.7  Selecting A Station For The Selected Stations List
To add a station to the selected station list from the Map screen, go to the Actions menu and select Add Station to Selected Stations List option.  Move cursor over the station you want to add to the list and press the mouse button.  The station will be added to the list and the list will appear with all the selected stations.
4.7 Selecting A Group Of Stations For The Selected Stations Listtc \l2 "4.8  Selecting A Group Of Stations For The Selected Stations List
You can add a group of stations using a selection rectangle.  To add a group of stations all at once to the selected station list from the Map screen, go to the Actions menu and select Add Group Of Station to Selected Stations List option.  Move the cursor to the upper left corner of the group of stations you want and press the mouse button. While holding down the mouse button, move the cursor to the lower right corner of the group of stations you want, a rectangle will be drawn on the screen in response to the mouse movement. To add the stations within the rectangle, release the mouse button and all enclosed stations will be added to the list.  The list will appear with all the new stations added to it.
4.8 Displaying Station Informationtc \l2 "4.9  Displaying Station Information
To display station information about a given station on the Map screen, select the Station Information option under the Station Displays menu.  Select the station from the geographic display and the Station Information screen will appear.  If the station contains 3 or fewer data types, all the data types will be displayed on the station information screen.  If the station has more than 3 types of data, then a selection list screen will appear.  Select the data types you want to view.  No more than 3 data types may be displayed at one time.  See Section 5 for a more detailed discussion of the Station Information screen.

4.9 Adding Station To Station Comparison tc \l2 "4.10  Adding Station To Station Comparison 
The user can compare the information for a particular data type from up to three stations using the Compare Station screen.  This screen is discussed in more detail in Section 6.  Stations for comparison are selected from the map display and added to the Compare Station screen.  To add a station to the station comparison screen, select Add Station to Station Comparison from the Action menu.  Move the cursor over the station you want to add and press the mouse button.  The station comparison screen will appear if there are no more than 3 stations on the screen.  If you try to add a fourth station, you will get an error message.  If this is the first station on the screen then a selection list will appear, so that you can select which data type you want to view.

4.10 Load Previously Saved Selected Stations Listtc \l2 "4.11  Load Previously Saved Selected Stations List
The user can reload a previously saved Selected Station List.  This allows the user to continue working with a group of stations.  To load the previously saved list, select Load Saved Selected Stations from the Station Displays menu.  A File List Dialog (Figure 3.2) will appear.  Enter the file name Selected Stations List you wish to load and press the OK button.  If stations were already displayed on the map prior to loading the list, then the system will ask you if you wish to keep the currently displayed stations.  If you answer no then the Selected Station List for the current session will be cleared before loading the list from disk.  Otherwise the stations from the loaded list will be added to the current stations.  Once the stations are loaded they will appear on the map and the updated Selected Station List screen will appear. 

4.11 Zooming/Panning/Recentering
The user has the option to zoom in and out of the map; to pan north, east, south, and west; and to recenter the display on any selectable portion of the map. To use the map orientating tools, You can either popup up a menu by a single click of the right mouse button or choose the individual “Zoom”, “Pan”, and “Recenter” options on the “Tools” menu. The popup menu contains the options shown in the table bellow:

	                                                       Table: Pop up Menu Options

	In – Zoom the map in

	Out – Zoom the map out

	Recenter - Recenter the map on the point where the user clicks next.

	Up - Pan the map up.

	Down - Pan the map down.

	Left- Pan the map left

	Right- Pan the map right

	Lat/Lon - Turn on or off the latitude / longitude information that chases the cursor.


In addition, there is a Tool bar which is a new option. It’s a toggle button that enables or disables the display of the application’s toolbar.  This toolbar by default is “off”. When it is enabled through this menu option, it is displayed just below the main menu bar (Figure 4.2). This toolbar contains the following items from left to right: the pan up button, the pan down button, the pan left button, the pan right button, the recenter button, the zoom in button, the zoom out button, the latitude box, and the longitude box. These buttons offer an alternative means of accessing the map zoom, recenter, and pan functions.  An example of a map screen with the toolbar is shown in the figure bellow:






Figure 4.2
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Figure 4.2

SECTION 5

STATION INFORMATION SCREEN tc \l1 "STATION INFORMATION SCREEN 

This screen displays information about the selected station.  The stations name, number, source, latitude, longitude, elevation and station history are displayed.  The data availability is plotted and data values can be displayed in text format or plotted.  If the station has no data types then a message dialog will be displayed. An example of the station information screen (Figure 5.1) is shown below. 







Figure 5.1
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5.1 Displaying Data Completenesstc \l2 "5.1  Displaying Data Completeness
To display the completeness of the data, select the Data Completeness option under the View menu.  The data completeness will be displayed graphically for each of the data types.  The vertical axis of the plot is the number observations available for the particular month as a percent of the number of observations which could have been available.  For example, in a 28 day month, if 336 observations are available for an hourly observing station, the abscissa value would be 50%.  To remove the data completeness, select the Data Completeness option again and it will be removed from the data type graph scroll window. 

5.2 Displaying Data Valuestc \l2 "5.2  Displaying Data Values
To display data values for each data type, select the Data Values option under the View menu.  The data values will be plotted in the graph scroll window and written to the text window.  It may take some time to display the information depending on the quantity of data being retrieved.

When retrieving information for display or the writing of a time series, the Historical Data Browser first checks to see if the data has already been extracted from the archive and stored locally in the directory specified in the user preferences.  If the data is not local then the application goes out and gets the data and stores it.  The contents of the local storage directory are can be erased upon exit from the Historical Data Browser based upon the User Preferences.  Different users can have different preferences but can share the same local directory and so data that one user thought should be retained locally may be erased by a second user.  Be careful with your local disk space - you can cause it to be filled up quickly by viewing long periods of record! 

Also under the user preferences, you can set whether to keep the data after you exit the application. You are also able to set where station data is to be stored.

To turn off the display of data values, select the option again and the graph and text will be removed.

5.3 Changing Data Types Being Displayedtc \l2 "5.3  Changing Data Types Being Displayed
You are able to change which data types you are viewing if the station has more than 3 data types.  If you want to see different data types or change the number of data types you are viewing then select Data Types option from the View menu.  A dialog will appear with all the data types available for the station.  Select the data types you want to view but no more than 3.  Once you have selected the data types you want, press the OK button and the new data types will be displayed.  If you press the Cancel button then your selections are ignored and you are returned back the station information screen with the data types you previously had selected.

5.4 Changing Time Range Of Data Being Displayedtc \l2 "5.4  Changing Time Range Of Data Being Displayed
You are able to examine a smaller set of the data based on a specified time range.  Select Data between Dates option from the View menu.  The Time range dialog will appear.  Enter the months and the years that you want to view.   Press the Ok button to accept the new time frame.  Select Data type for which you want to display data for and click OK button.  This will update the graphs and text value being displayed to the new time range.  If you press the Cancel button then any changes will be ignore and the dialog will be closed.

5.5 Changing Scale of Plot Axestc \l2 "5.5  Changing Scale of Plot Axes
You are able to change the scales of the plot axes.  Select the Data Type Scales option from View menu.  The data type scale dialog will appear.  Update any range you want to change.  Press the OK button to accept the changes.  Once the changes have been accepted, they are applied.  Press the Cancel button if you do not want to accept the changes.

5.6 Adding Station To Selected Stations Listtc \l2 "5.6  Adding Station To Selected Stations List
You are able to add the station currently being displayed to the Selected Stations List by selecting Add to Selected Station List option under the File menu.  The station is added to the list and the list is displayed.

5.7 Adding Station To Station Comparison Screentc \l2 "5.7  Adding Station To Station Comparison Screen
You are able to add the station currently being displayed to the station comparison screen by selecting Add Station to Comparison Screen under the File menu.  You can only add a station to the station comparison screen if there are fewer than 3 stations already being displayed on the screen.  If you try to add the station and there are already 3 stations being displayed, you will get an error message.  If this is the first station to be added to the station comparison screen, then a list of data types will be display so that you can select which to display.

5.8 Writing Time Seriestc \l2 "5.8  Writing Time Series
You are able to write time series for the currently displayed station.  To do this, select Write Time Series under the File menu.  The writing time series dialog will be displayed.  The options for writing a time series are discussed in more detail in Section 8.

5.9 Create Input for the MAT Programtc \l2 "5.9  Create Input for the MAT Program
You are able to create correctly formatted input for the MAT program, (namely the time series file as well as the header card file) for the currently displayed station.  To do this, select Create MAT Input under the File menu.  The MAT Input dialog will be displayed.  The options for creating this input are discussed in more detail in Section 10.

SECTION 6

COMPARING STATIONStc \l1 "COMPARING STATIONS

The station comparison screen allows you to compare stations against each another.  You may compare up to 3 stations at any time.  You are able to add and remove stations from the screen, change the data type being displayed, display data completeness and data values, reset the scale of the plot axes and limit the time frame being examined.  For each station, the name, number, latitude, longitude, elevation, source, data completeness and data values can be displayed.  The Compare Stations screen (Figure 6.1) is displayed by selecting the Add Station to Compare Information option from the Action menu of the map display screen as indicated in Section 4.1.







Figure 6.1
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6.1 Displaying Data Completenesstc \l2 "6.1  Displaying Data Completeness
Data completeness can be displayed as discussed in Section 5.1

6.2 Displaying Data Valuestc \l2 "6.2  Displaying Data Values
Data values can be displayed and plotted as discussed in Section 5.2

6.3 Changing Data Types Being Displayedtc \l2 "6.3  Changing Data Types Being Displayed
You are able to change which data types you are viewing as discussed in Section 5.3

6.4 Changing Time Range Of Data Being Displayedtc \l2 "6.4  Changing Time Range Of Data Being Displayed
You are able to limit the time frame of the data being examined as discussed in Section 5.4.

6.5 Changing Scale That Data Is Displayed Againsttc \l2 "6.5  Changing Scale That Data Is Displayed Against
You are able to change the scale of the plot axes as discussed in Section 5.5

6.6 Adding Station To Selected Stations Listtc \l2 "6.6  Adding Station To Selected Stations List
You are able to add the stations currently being displayed to the Selected Stations List as discussed in Section 5.6

6.7 Displaying Station Informationtc \l2 "6.7  Displaying Station Information
You are able to display station information about any one of the stations on the screen.  Select the Station Information option under the File menu and a list of the currently displayed stations will appear.  Select the station for which you want the information press the OK button.  The station information will appear if the station has 3 or fewer data types.  Otherwise, a list of data types for that station will appear you can select.  You may not select any more than 3 data types.  Once you have selected the data types, press the OK button.  The Cancel button removes the selection dialog.

6.8 Write Time Seriestc \l2 "6.8  Write Time Series
You are able to write time series for any of the stations being displayed as discussed in Section 5.8 and in more detail in Section 8.

SECTION 7

SELECTED STATION LISTtc \l1 "SELECTED STATION LIST
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The selected station list allows you to keep a list of stations that you are interested in.  You are able to add stations to the list, remove stations from the list, display station information about any station, compare stations, save the Selected Station List and write time series.  As time series are written, during the current session, the system will update the Selected Station List indicate which time series were written for each station.  The information about which time series where written is also saved when saving the selected station list.  An example of the Station List screen is shown below in Figure 7.1.







Figure 7.1
7.1 Removing Station(s) From Listtc \l2 "7.1  Removing Station(s) From List
To remove one or more stations from the Station List, select the station you want to remove.  Then select the Remove Stations from the Edit menu.  The station that you selected will be removed from the list.

7.2 Displaying Station Informationtc \l2 "7.2  Displaying Station Information
You are able to display station information about any one of the stations on the Station List screen.  Do so by selecting station on the list and then select the Station Information option under the File menu.  The station information will appear if the station has 3 or less data types.  Otherwise, a list of data types for that station will appear and you need to select which data type you want to view.  You may not select any more than 3 data types.  Once you have selected the data types, press the OK button.  Pressing the Cancel button will remove the dialog window.

7.3 Adding Station(s) To Station Comparison Screentc \l2 "7.3  Adding Station(s) To Station Comparison Screen
You are able to add one or more stations to the station comparison screen.  You may not have more than 3 stations being displayed on the station comparison screen at any time.  Select the stations you want and then select the Add Station to Comparison Screen under the File menu.  The stations will appear on the station comparison screen.  If a data type has not been previously selected for the comparison screen, then a list of all the data type available to the station will appear.  Select the data type you want to view and press the Ok button.  If you press the Cancel button then no data type will be displayed.

7.4 Write Time Seriestc \l2 "7.4  Write Time Series
You are able to write time series for any of the stations on the Selected Stations List.  To do this, select the station for which time series are to be written and then select Write Time Series under the File menu.  The time series dialog will be displayed.  The options associated with writing Time Series are discussed in Section 8.

7.5 Writing Groups of Time Seriestc \l2 "7.5  Writing Groups of Time Series
You are able to write a group of time series for stations on the Selected Stations List.  To do this, select the station(s) for which time series are to be written and then select Write Group of Time Series under the File menu.  The time series dialog will be displayed.  The options associated with writing Time Series are discussed in Section 9.

7.6 Create Input for the MAT Programtc \l2 "7.6  Create Input for the MAT Program
You are able to create correctly formatted input for the MAT program, (namely the time series file as well as the header card file) for any stations on the Selected Station List.  To do this, select the stations for which the information is to be written and then select Create MAT Input under the File menu.  The MAT Input dialog will be displayed.  The options for creating this input are discussed in more detail in Section 10.

7.7 Create Input for the PXPP Programtc \l2 "7.7  Create Input for the PXPP Program
You are able to create correctly formatted input for the PXPP program, (namely the time series file as well as the header card file) for any stations on the Selected Station List.  To do this, select the stations for which the information is to be written and then select Create PXPP Input under the File menu.  The PXPP Input dialog will be displayed.  The options for creating this input are discussed in more detail in Section 11.

7.8 Saving Selected Station Listtc \l2 "7.8  Saving Selected Station List
You are able to save all the stations that appear on the selected station list to a file.  This allows you to save your work and continue it at a later time.  To do this, select Save Selected Stations under the File menu.  The File List Dialog (see Figure 3.2 in section 3) will appear.  Enter the file name and press the OK button.  All the stations and their information will be saved to the file.  A notice will appear when the stations have been saved.

7.9 Writing Selected Station List For External Usetc \l2 "7.9  Writing Selected Station List For External Use
You are able to write the Selected Station List to a file.  The list is written as an ASCII file as a convenience for use by other software, it cannot be read back in by the Historical Data Browser.  The station number, name, latitude, longitude, elevation and source will be written in the same format as displayed on the dialog.  To do so, select the Write Selected Station List For External Use option under the File menu.  A file list dialog will be displayed.  Enter the name of the file in the selection field.  Press the OK button and the list will be written to the file you specified.  An information dialog will appear once the file has been written.

SECTION 8

WRITING TIME SERIEStc \l1 "WRITING TIME SERIES

You can write time series for a station or a group of stations.  Time series are written in OH Data Card format.  Time series are written one station at a time from the Selected Station List.  The station name and number are displayed for you.  The starting and end date is set to the time range that the station collected data.  You are able to change the time range.  The station’s data types are also listed for your selection.  An example for the dialog is displayed below in Figure 8.1.
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Figure 8.1

8.1 Writing Time Seriestc \l2 "8.1  Writing Time Series
To write a time series you need to select which data types you want, set time range, units and Calendar or Water Year.  Once you have made your selections, press the write button.  When the time series has been written, a message will be displayed.  The time series are written into the directory specified by the User Preferences (Section 12).

8.2 Next Stationtc \l2 "8.2  Next Station
The Next button allows you to go to the next station in the Selected Station List.  If there are no other stations, then this button is grayed out.  Once you have written time series for the current station or just want to skip the current station and move on to the next station in the list just press the Next button and the station name, number and time frame will change according to the new station.

SECTION 9

WRITING GROUPS OF TIME SERIEStc \l1 "WRITING GROUPS OF TIME SERIES

You can write a group of time series all at once.  Time series are written in OH Data Card format.  The station’s name and number are displayed for you.  You need to enter the starting and ending year, and select what type of units, what type of year and data type(s) to write.   The data types listed are common to all the stations.  An example of the dialog is displayed below in Figure 9.1.
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Figure 9.1
9.1 Writing Time Seriestc \l2 "9.1  Writing Time Series
To write a group of time series you need to select which data types you want, set time range, units and Calendar or Water Year.  Once you have made your selections, press the write button.  When the group of time series has been written, a message will be displayed.  The time series are written into the directory specified by the user preferences (Section 12).

SECTION 10

CREATE INPUT FOR MAT PROGRAMtc \l1 "CREATE INPUT FOR MAT PROGRAM

You are able to create correctly formatted input for the MAT program, (namely the time series file as well as the header card file).  The time series are written in OH Data Card format.  The header card file for the MAT program contains the F, G, H and Q cards.

The stations that you have selected that contain temperature data are listed in the dialog.  Enter the time range for the stations, units, data type and filename for the card file.  An example of the dialog is displayed below in Figure 10.1.
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Figure 10.1
10.1 Create Input for MAT Programtc \l2 "10.1  Create Input for MAT Program
To create the header card file and the associated time series that are required for the MAT program, enter the time range, select units and data type and enter a file name for the card file.  The file will be written to the directory identified in the User Preferences (Section 12).  Once you have entered the information, press the create button.  The card file will be created along with all the times series selected.  A message dialog will appear when everything has been written.  If a time series file already exists, a dialog will appear asking if you wish to over-write the pre-existing file.

SECTION 11

CREATE INPUT FOR PXPP PROGRAMtc \l1 "CREATE INPUT FOR PXPP PROGRAM

You are able to create correctly formatted input for the PXPP program, (namely the time series file as well as the header card file).  The time series are written in OH Data Card format. 

The stations that you have selected are listed in the dialog.  Enter the time range for the stations, units, data type, base station id, observation time and filename for the card file.  An example of the dialog is displayed below in Figure 11.1.
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Figure 11.1
11.1 Create Input for the PXPP Programtc \l2 "11.1 Create Input for the PXPP Program
To create the header card file and the associated time series that are required for the PXPP program, enter the Station ID and the time range, select units and data type and enter a file name for the card file.  The file will be written to the directory identified in the User Preferences (Section 12).  Once you have entered the information, press the create button.  The card file will be created along with all the times series selected.  A message dialog will appear when everything has been written.  If a time series file already exists, a dialog will appear asking if you wish to over-write the pre-existing file.

SECTION 12

USER PREFERENCEStc \l1 "USER PREFERENCES

The User Preference screen allows you to modify and save individual preferences for behaviors such as colors, plot scales, basin boundaries and where to store lists and time series.  You are able to change any preferences at any time.  Individual preferences are stored in the user’s home directory in the file; .hdb_resource.  An example of the dialog is shown below in Figure 12.1.
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Figure 12.1
12.1 Keep Station Data After Exitingtc \l2 "12.1  Keep Station Data After Exiting
Station data that is transferred from a remote archive is stored in a temporary location on local disks as specified in Section 12.4 below.  Prior to transferring, the system checks to see if the data already exists in the temporary location.  The user can choose whether or not to delete this data upon exiting the system by selecting the appropriate button on the User Preference screen.

Caution 1:  If the location chosen is shared with other users, the system will delete their temporarily stored data as well.

Caution 2: Choosing not to delete the data may lead to significant consumption of disk space.

12.2 Location for Writing Time Seriestc \l2 "12.3  Location for Writing Time Series
The path name for the directory to which time series are written should be entered here.  The path name should end with a “/”.

12.3 Location for Temporary Storagetc \l2 "12.4  Location for Temporary Storage
The path name for the directory to which temporary data is written should be entered here.  The path name should end with a “/”.  See Section 12.1 for further discussion.

12.4 Setting Scalestc \l2 "12.5  Setting Scales
Default scales exist for each data type.  You are able to change these by pressing the Scale button and a dialog with all the data types and the scale ranges will appear.  Make your changes and press the OK button to accept changes.  Press the Cancel button to ignore changes and close the dialog.  You still need to press the OK button on the parent User Preference screen to save new scale settings.
12.5 Saving Preferencestc \l2 "12.7  Saving Preferences
Press the OK button to save preferences.  The preferences are saved into your .hdb_resource file.  If you press the Cancel button, nothing is saved.

SECTION 13

SYSTEM SETUPtc \l1 "SYSTEM SETUP

User Preferences discusses parameters which can be tailored for each user.  There are two additional sets of parameters, one set which is user specific and is maintained in the runhdb script and a second set which is site specific and is maintained in the Apps_default file.  These parameters are discussed below:

13.1 runhdb scripttc \l2 "13.1  runhdb Script
The user executes this application by executing the command “runhdb”.  This will set up the environment so that HDB can run correctly.  Then it will launch the HDB application.

13.2 Apps_default Filetc \l2 "13.2  Apps_default File
The Apps_defaults file contains parameters for the Historical Data Browser and the Postgres database. The Apps defaults token is a user-configurable value used throughout the HDB application.  Tokens may be easily changed by the user and directly affect the performance and appearance of HDB. Changing a token does not require the recompilation of the program.  The user needs only to restart the application once the token has been modified.

Tokens are defined in one or more of four different locations: a national apps defaults file, a site apps defaults file, a user apps defaults file, or in the environment of the shell that the application is running under.  If the token is defined in more than one of these locations, then a set of rules of precedence decide which token value is actually used.  The value of a token defined in the shell environment overrides the value of a token defined in a user’s apps defaults file which takes precedence over a token defined in the site’s apps defaults file which takes precedence over a token defined in the national apps defaults file.  Since many HDB tokens are, by default, defined in the national apps defaults file, the user may override these values by adding the modified token definition to the site apps defaults file, the user apps defaults file or by setting it in the shell environment.  The user must never modify the national apps defaults file. This file is overwritten with every software build, and local changes made to it will be lost.

The paths and filenames of the national, site and user apps defaults files are defined by the environmental variables APPS_DEFAULTS, APPS_DEFAULTS_SITE, and APPS_DEFAULTS_USER, respectively.  The APPS_DEFAULTS and APPS_DEFAULTS_SITE variables are set in the /awips/hydroapps/set_hydro_env file which are sourced by HDB start up script. Start scripts which also source the /awips/fxa/readenv.sh, define the APPS_DEFAULTS_USER variable as well.  The value it is set to depends on platform.  For HDB, the national apps defaults file is defined as /awips/hydroapps/ob72/.Apps_defaults while the site file is set as  /awips/hydroapps/.Apps_defaults_site.  This means that when HDB looks up a token’s value, it will look in these files (unless, of course the token is defined in the environment).

In order to change the .apps_defaults, .apps_defaults_site, or .apps_defaults_user files used by 

HDB, the user must modify the set_hydro_env file where the APPS_DEFAULTS and APPS_DEFAULTS_SITE definitions are specified.  If desired, the APPS_DEFAULTS_USER variable must be defined after the line in set_hydro_env where the file /awips/fxa/readenv.sh file is sourced.

hdb_dir:pathname - where pathname is the directory that contains support files for the Historical Data Browser (help, scripts, etc)

hdb_db_name:ob7_histdata - where ob7_histdata is the name of the Postgres Sql database that contains information about the historical data.

hdb_ config _dir: $(hdb_dir))/app_defaults - this is the directory that contains the file named hdb_overlay_configuration. This file controls all of the overlays displayable on HDB application.

hdb_help_dir:$(hdb_dir)/help_files - this is the location of the help files.  This syntax will automatically use to the location specified by hdb_dir above.  However it is provided in the Apps_default file to allow a different pathname to be specified. The help files contain detailed explanations and instructions about the various HDB windows.

 Basically, each help topic is stored in a separate file with a name that easily distinguishes it 
 from all of the other help files.  
hdb_script_directory :$(hdb_dir)/scripts - this is the location of the script files used by the Historical Data Browser.  This syntax will automatically use to the location specified by hdb_dir above.  However it is provided in the Apps_default file to allow a different pathname to be specified.

hdb_height_in_pixels 

: 900 - this is the HDB map height in pixels 

hdb_width_in_pixels

: 1200 - this is the HDB width in pixels 

hdb_center_lat


: 35- this is the HDB initial center latitude

hdb_center_lon 
      

: -88.9 - this is the HDB initial center longitude

      hdb_map_width 


: 2999.862 - width in nautical miles of the area displayed

       




         in HDB.

hdb_disclosure_limit 

: 60 - this is the disclosure limit for displaying finer detail 
 




          in the city overlay 

      hdb_map_projection

: FLAT- this is the initial map projection used by                                                                                            hdb. Possible values:  FLAT, POLAR    

SECTION 14

REPORTING PROBLEMStc \l1 "REPORTING PROBLEMS

Report any problems or concerns to Loubna Bousaisdi at (301) 713-1669 x156 or email at loubna.bousaidi@noaa.gov.

