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1.0 SCOPE 

See TO10 Software Test Plan. 
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2.0 APPLICABLE DOCUMENTS 

2.1 Source Documents 
• None 

 
2.2 Reference Documents 

• Legacy NWS Test Cases: Baseline_HydroTS (OB8.3); 
Baseline_HydroTS_OB8.1; Checkout_HydroTS_OB8.1. 

• Software Test Plan for the Advanced Weather Interactive Processing System 
Project, Contract #DG133W-05-CQ-1067, January 2009. 

• The Silver Spring NWS AWIPS I test bed application. 
• Rational RequisitePro. 
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3.0 TEST CASE DESCRIPTION 
This test case demonstrates that AWIPS provides the capability to execute the WHFS Hydro 
Time Series. The Hydro Time Series allows a WFO to monitor hydrologic points of interest by 
providing the interface to information necessary for daily hydrologic monitoring and forecasting. 
Hydro Time Series allows for the observation of X_Y plots, and tabular listing of stage data and 
precipitation data. This test case also verifies, through the Time Series tool, the ingest and 
storage of precipitation data in the IHFS database. 
 
3.1 Assumptions, Constraints, and Preconditions 

• TO10 software has been installed successfully. 
• CAVE and EDEX are running. 
• Data has been ingested. 
• The Test Group is set up. 
• Actions, Results, and Requirements highlighted in gray indicate requirements 

and/or capabilities to be included in the scope of future task orders. They are 
included here for purposes of continuity and traceability with the original 
AWIPS I test case documents. 

 
3.2 Recommended Hardware 
See TO10 Software Test Plan. 
 
3.3 Test Inputs 
Section 4.0 contains the test procedures for this test case. Sections 2.2 – 2.9 of the TO10 
Software Test Plan contain general test inputs applicable to all TO10 test cases. Grayed out test 
step(s) indicate functionality not yet delivered. 
 
3.4 Test Outputs 
The results outlined in section 4.0 are met. 
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4.0 TEST SCENARIO 

Step # Action Result Pass/Fail 
1.  In CAVE, Mouse Button (MB) 1 click on the 

Perspectives icon and select ‘Hydro’ from the 
dropdown menu if available. If not available, 
select ‘Other…’. Then select ‘Hydro’ from the 
Open Perspective dialog. 

The Hydro Perspective displays in CAVE.  

2.  MB1 click ‘Time Series Graphs/Tables…’ 
from the Live Data submenu. 

The Time Series dialog opens.  

3.  In the Search box, search for a reservoir 
forecast point (station) with data. 
Hydroview can help the user do this by 
selecting ‘Live Data’ -> ‘Stations Reporting 
Status/Latest Observations…’. 

The station selected is highlighted in the 
box below. 

 

4.  Select the ‘Table’ button. The Tabular Time Series window opens.  
5.  In the top of the Tabular Time Series 

window, highlight a ‘Loc, PE, Dur,  
TS, E’ combination line that has data.  

If a line that has data was chosen, the data 
is displayed in the middle of the window. 

 

6.  Select the ‘Close’ button in the Tabular Time 
Series window. 

The Tabular Time Series window closes.  

7.  Near the bottom of the Time Series window, 
highlight all the lines with a PE (Physical 
Element) starting with ‘H’ (e.g., HG and HT) 
or any with data. 
Hold the Ctrl key down and MB1 click each 
item to highlight multiple lines. 

One or more lines are highlighted. 
(Only the first two in the list will be 
displayed.) 

 

8.  Select the ‘Graph’ button. The Time Series Display window opens 
with the available physical element data 
represented as time series. 

 

9.  From the Graph menu, select ‘Toggle Off the 
Show Latest Forecast Only’ option. 

Time series for forecasts with earlier basis 
times are displayed, if any. 

 

10.  From the Graph menu, select ‘Data and 
Categories’ from the Scale Stages cascading 
menu. 
 

If flood categories are defined in 
HydroBase for the station, they will be 
displayed as yellow, red, and blue 
horizontal lines. The y-axis scale may 
adjust to fit the flood stages.  

 

11.  From the Graph menu, select ‘Data Only’ 
from the Scale Stages cascading menu. 

Only the data appear, and the y-axis scale 
may adjust to fit the data. 

 

12.  From the options menu, select ‘Points’ from 
the Plot cascading menu. 
 
 

The lines connecting the points in the time 
series plots disappear. The time series 
data are represented by points only. 

 

13.  Redisplay the lines by selecting ‘Both’ from 
the Plot cascading menu. 

The lines and points are displayed.  
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Step # Action Result Pass/Fail 
14.  From the Edit menu, select ‘Select Trace’. The mouse icon becomes a hand when 

hovering over a point, signifying that it is 
ready to select a trace. 

 

15.  Select a time series by MB1 clicking on the 
trace of a time series. 
 

All the time series are represented by 
points and lines. The time series selected 
is highlighted in white, signifying that it can 
be edited. 

 

16.  Select ‘Insert’ from the Edit menu. 
Then MB1 click on about half a dozen places 
around the active trace. 

Points are added where the mouse button 
is clicked. 
A line connects the points.  

 

17.  Select ‘Delete’ from the Edit menu. 
Then MB1 click on a point in the active time 
series. 

The point selected is deleted.  

18.  Select ‘Move’ from the Edit menu. The Move option is selected.  
19.  MB1 click and drag a point on the active time 

series. 
The point can be moved vertically but not 
horizontally. 

 

20.  Select ‘Cancel Changes’ from the Edit menu. All the changes in the graph that were 
made in Steps 16–19 are undone, and the 
time series returns to its original state 

 

21.  From the Edit menu, select ‘Select Trace’. The mouse icon becomes a hand when 
hovering over a line, signifying that it is 
ready to select a trace. 

 

22.  Select a time series by MB1 clicking on a 
trace of a time series. 
 

All the time series are represented by 
points and lines. The time series selected 
is highlighted in white, signifying that it can 
be edited. 

 

23.  Select ‘Insert’ from the Edit menu. 
Then MB1 click on about half a dozen places 
around the active trace. 

Points are added where the mouse button 
is clicked. 
A line connects the points.  

 

24.  Select ‘Save’ from the Edit menu. A Save window opens.  
25.  Select ‘Cancel’ in the Save window. The Save window closes. 

The changes in the trace are not saved to 
the database. 

 

26.  Select ‘Insert’ from the Edit menu. 
Then MB1 click on about half a dozen places 
around the active trace. 

Points are added where the mouse button 
is clicked. 
A line connects the points.  

 

27.  Select ‘Save’ from the Edit menu. A Save window opens.  
28.  Select ‘OK’ in the Save window.  The Save window closes. 

The changes in the trace are saved to the 
database. 

 

29.  Select ‘File’ and ‘Quit’ to exit the Time Series 
Display window. 

The Time Series Display closes.  

30.  Redisplay the changes to the graph by 
selecting the ‘Graph’ button. 

The trace is displayed with the changes.  
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Step # Action Result Pass/Fail 
31.  Select ‘Quit’ from the File menu of the Time 

Series Display window. 
The Time Series Display closes.  

32.  In the Time Series window,  
MB1 click the Mode dropdown arrow (Station 
Selection) and select ‘Predefined Group’. 

The Time Series window changes to 
Predefined Group mode. 

 

33.  Select ‘TestGroup’. 
Then MB1 click the ‘Table’ button.  
Note: This step assumes the TestGroup was 
set up prior to running this step. 

The Tabular Time Series window opens 
with data for the predefined groups of 
stations. 

 

34.  MB1 click the ‘Close’ button in the Tabular 
Time Series window. 

The Tabular Time Series window closes.  

35.  Select ‘Graph’ in the Time Series window. The Time Series Display window opens. 
The Time Series Display window shows 
data for stations defined in the 
/awips/hydroapps/whfs/local/data/app/Time 
Series/group_definition.cfg configuration 
file. 

 

36.  Press the ‘PgDown’ key. The second page of data defined in the 
configuration file is shown (if there are two 
pages). 

 

37.  Select ‘Quit’ from the File menu in the  
Time Series Display window. 
 

The Time Series Display window closes.  

38.  MB1 click the ‘Close’ button in the Time 
Series window. 

The Time Series window closes.  

End of Test 
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5.0 REQUIREMENTS VERIFICATION TRACEABILITY MATRIX (RVTM) 

Number Description Test 
Step(s) 

SYSR3179 

CAVE shall provide the user the capability to launch Time Series from the 
CAVE Menu resulting in the display of the Time Series Control Dialog, an 
SWT Dialog, on the CAVE Workstation. 

1 - 38 

SYSR3180 
The Time Series Control Dialog shall provide a Station Selection Mode to 
view data. 3 

SYSR3181 
The Time Series Control Dialog shall provide a Predefined Group Mode to 
view data. 32 - 34 

SYSR3182 
The Time Series Control Dialog shall allow the user to select either a Station 
Mode or a Predefined Group Mode. 3, 32 -33 

SYSR3183 The Time Series Control Dialog shall default to the Station Mode. 3 

SYSR3187 
The Time Series Control Dialog shall allow the user to see a full list of 
available stations while in Station Mode. 3 

SYSR3190 
The Time Series Control Dialog shall allow the user to search for a station in 
the Station List by ID in Station Mode. 3 

SYSR3191 

The Time Series Control Dialog shall select the station in the Station List that 
is the closest matching entry to what the user entered in the Search box in 
Station Mode. 

3 

SYSR3192 
The Time Series Control Dialog shall allow the user to select one of the 
displayed stations in Station Mode. 3 

SYSR3193 
The Time Series Control Dialog shall display the available traces (defined 
data types) for the selected station in Station Mode. 7 – 8 

SYSR3197 
The Time Series Control Dialog shall allow the user to select traces in 
Station Mode. 14 – 15 

SYSR3200 
The Time Series Control Dialog shall allow up to two different PE 
combinations to be selected in Station Mode. 7 

SYSR3201 
The Time Series Viewer shall plot two different PE combinations on two 
separate graphs on the same page in a vertical layout. 8 

SYSR3202 
The Time Series Control Dialog shall display the selected traces on a single 
page in Station Mode. 8 

SYSR3203 
The Time Series Control Dialog shall display a list of predefined groups 
when in Predefined Group Mode. 32 – 33 

SYSR3204 
The Time Series Control Dialog shall allow a user to select a single group 
from the list of predefined groups in Predefined Group Mode. 33 

SYSR3207 
The Time Series Control Dialog shall allow the user to exit the application by 
clicking the "Close" button. 38 

SYSR3210 
The Time Series Viewer shall allow the requested plots to occupy the entire 
Graphical Time Series window except for the menu bar at the top. 8 

SYSR3211 
The Time Series Viewer's Menu Bar shall provide the user five distinct 
pulldown menus: File, Page, Graph, Options, and Edit. 14 – 31 

SYSR3216 
The Time Series Viewer's File pulldown's Close selection shall close the 
Time Series window. 38 

SYSR3218 
The Time Series Viewer's Page pulldown's Page Down selection shall 
display the Next page.  36 

SYSR3224 
The Time Series Viewer's Graph pulldown's Show Latest Forecast Only 
selection shall display only the forecast time series with the latest basis time.  

SYSR3225 
The Time Series Viewer's Graph pulldown's Scale Stages->Data Only 
selection shall scale the vertical axis to fit the HG time series data values. 10 -11 

SYSR3226 

The Time Series Viewer's Graph pulldown's Scale Stages->Data Only, Show 
Categories shall scale the vertical axis to fit the HG time series data values 
and display the lines for flood categories if the fall within the range of the 

10 - 11 



Test Case Time Series Heavy  DCN AWP.TE.SWCTR/T010-0012 
 
 

Contract DG133W-05-CQ-1067 / DCN AWP.TE.SWCTR/TO10-0012 / 6 Feb. 2009 8 
Use or disclosure of data contained on this sheet is subject to the restriction on the title page of this document. 

HARD COPY UNCONTROLLED 

data (default). 

SYSR3227 

The Time Series Viewer's Graph pulldown's Scale Stages ->Data and 
Categories selection shall scale the vertical axis so that the lines for flood 
categories are always shown 

10 -11 

SYSR3229 
The Time Series Viewer's Options pulldown's Plot->Points selection shall 
display the data as points only. 12  

SYSR3231 
The Time Series Viewer's Options pulldown's Plot->Both selections shall 
display the data as lines and points (default). 13 

SYSR3235 
The Time Series Viewer's Edit pulldown's Select Trace selection shall invoke 
the edit mode. 14 – 15 

SYSR3236 
The Time Series Viewer's Edit pulldown's Insert selection shall allow a user 
to insert a point in a trace. 16  

SYSR3237 
The Time Series Viewer's Edit pulldown's Delete selection shall allow a user 
to delete one or more data points from the trace. 17 

SYSR3238 
The Time Series Viewer's Edit pulldown's Move selection shall allow a user 
to modify an existing data point by moving it to a new location. 18 – 19 

SYSR3239 
The Time Series Viewer's Edit pulldown's Save to Database selection shall 
save the modifications to the IHFS database. 25 – 30 

SYSR3240 
The Time Series Viewer's Edit pulldown's Cancel Changes selection shall 
cancel the modifications, restoring the original time series. 20 

SYSR3251 The Time Series Viewer shall display the flood stage for a river PE. 10 

SYSR3252 
The Time Series Viewer shall display the corresponding stage or discharge 
value of H* or Q* PE types by annotating the right y-axis. 10 

SYSR3253 
The Time Series Control Dialog shall allow the user to view the selected data 
in Tabular format by clicking the "Table" button. 4 – 5 

SYSR3254 
The Table button shall open a Tabular Time Series window if one is not 
already open. 4 – 5 

SYSR3263 

The Tabular Time Series shall display the time series which were set up for 
the group that was selected in the Time Series Control Dialog at the time the 
Table button was pushed. 

33 - 34 

SYSR3264 

The Tabular Time Series shall display the time series available for the 
station that was selected in the Time Series Control Dialog at the time the 
Table button was pushed. 

5 

SYSR3306 
The Tabular Time Series Close button shall close the Tabular Time Series 
Window. 6 
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