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SCOPE 

See TO10 Software Test Plan. 



Test Case MPE  DCN AWP.TE.SWCTR/T010-0014 
 

Contract DG133W-05-CQ-1067 / DCN AWP.TE.SWCTR/TO10-0014 / 6 Feb. 2009 2 
Use or disclosure of data contained on this sheet is subject to the restriction on the title page of this document. 

HARD COPY UNCONTROLLED 

APPLICABLE DOCUMENTS 

Source Documents 
None. 

 
Reference Documents 

• Legacy NWS Test Cases: Baseline_HYDRO_WHFS_MPE_OB8.1. 
• TO10 Software Test Plan for the Advanced Weather Interactive 

Processing System Project, Contract #DG133W-05-CQ-1067, January 
2009. 

• The Silver Spring NWS AWIPS 1 test bed application. 
• Rational RequisitePro. 
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TEST CASE DESCRIPTION 

This test case tests and verifies the functionality found within the WHFS MPE Data Viewer 
application known as MPE Editor. As new functionality is added to this application, these test 
procedures will be updated to contain the steps required to test this new functionality. The MPE 
FieldGen application is also demonstrated in this test case. 
 
Assumptions, Constraints, and Preconditions 

• TO10 software has been installed successfully. 
• CAVE and EDEX are running. 
• Data has been ingested. 
• Actions, Results, and Requirements highlighted in gray indicate requirements 

and/or capabilities to be included in the scope of future task orders. They are 
included here for purposes of continuity and traceability with the original 
AWIPS I test case documents. 

 
Recommended Hardware 
See TO10 Software Test Plan. 
 
Test Inputs 
Section 4.0 contains the test procedures for this test case. Sections 2.2 – 2.9 of the TO10 
Software Test Plan contain general test inputs applicable to all TO10 test cases. Grayed out test 
step(s) indicate functionality not yet delivered. 
 
Test Outputs 
The results outlined in section 4.0 are met. 
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TEST SCENARIO 

Step # Action Result Pass/Fail 
1.  In CAVE, Mouse Button (MB) 1 click on 

the Perspectives icon and select ‘MPE’ 
from the dropdown menu if available. If 
not available, select ‘Other…’. Then select 
‘MPE’ from the Open Perspective dialog. 

The MPE Perspective and MPE Choose 
Data Period window displays in CAVE. 

 

2.  Under the MPEControl menu, select 
'Choose Hour'.  On the 'Choose Data 
Period' window, select the date along the 
top of the window and the hour from the 
MPE Options. MB1 click the ‘Display MPE 
Data’ button. 

The Choose Data Period window opens. 
The Choose Data Period window closes.   
A MPE field for the selected date and 
hour displays in the MPE viewer. 
Note: If no precipitation is available to 
verify DPA data has been ingested, open 
pgAdmin3 and navigate to ‘Databases’ -> 
‘hd_ob83oax’ -> ‘Schemas’ -> ‘public’ -> 
‘Tables’ -> ‘dpradar’ and open the table. 

 

3.  From the ‘Help’ pull-down menu (on the 
right side top corner of the window), select 
‘About CAVE’. 

An About CAVE window displays the 
application’s name, version number and 
date. 

 

4.  Select ‘OK’ from the About CAVE window. The About CAVE window closes.  
5.  From the ‘File’ pull-down menu, select 

‘Save Image As...’. 
The Save Image As window launches.  

6.  In the Save Image As window, use the 
Filter and Directories selection boxes to 
choose a directory to save a PNG screen 
capture. In the Name box, enter the name 
of the file (including the directory) followed 
by the ‘.png’ file extension. For best 
results move the Save Image As... 
window off of the MPE display. Click ‘OK’. 

The Save Image As window closes. 
 
 
The file is saved in the location specified 
as xxxx.png 

 

7.  In a terminal, go to the directory in which 
the screen capture was saved. Use the 
display command to display the PNG file. 

The MPE screen capture displays.  

8.  From the ‘File’ pull-down menu, select 
‘Print Image’. 
 
Note: You can print in color (lp2) printer 
by uncomment out the ‘whfs_print_color 
and whfs_printcommand_LX’ tokens 
under 
/awips/hydroapps/.Apps_defaults_site file. 

The MPE image is sent to the printer 
specified by the whfs_printcommand_LX 
token. By default it is printed on lp1 (gray) 
printer. 

 

9.  From the ‘File’ pull-down menu, select 
‘Print Reverse Image’. 

The MPE image is sent to the printer 
specified by the whfs_printcommand_LX 
token. The image displays in reverse 
video (i.e., black as white and white as 
black). 
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Step # Action Result Pass/Fail 
10.  From the ‘Tools’ pull-down menu, select 

‘Point Zoom’. Then click ‘Out’. 
The center of the geographic display 
zooms out. 

 

11.  From the ‘Tools’ pull-down menu, select 
‘Point Zoom’. Then click ‘In’.  

The center of the geographic display 
zooms in. 

 

12.  From the 'Tools' pull-down menu, select 
'Areal Zoom', or select the magnifying 
glass button on the toolbar.  Draw a 
rectangle on the geographic display by 
holding down and dragging MB1. 

The geographic display zooms in on the 
rectangular area drawn by the MB1 
button. 

 

13.  From the ‘Tools’ pull-down menu, select 
‘Areal Zoom’ again. 
From the toolbar, select the Pan button. 

The display returns to its previous zoom 
level. 
The Panning capability is activated. 

 

14.  From the ‘Tools’ pull-down menu, select 
‘Pan’. Then click ‘Up’. 

The geographic display moves North.  

15.  From the ‘Tools’ pull-down menu, select 
‘Pan’. Then click ‘Down’. 

The geographic display moves South.  

16.  From the ‘Tools’ pull-down menu, select 
‘Pan’. Then click ‘Right’. 

The geographic display moves East.  

17.  From the ‘Tools’ pull-down menu, select 
‘Pan’. Then click ‘Left’. 

The geographic display moves West.  

18.  From the Toolbar, MB1 click the ‘Up’ 
button. 

The geographic display moves North.  

19.  From the Toolbar, MB1 click the ‘Down’ 
button. 

The geographic display moves South.  

20.  From the Toolbar, MB1 click the ‘Right’ 
button. 

The geographic display moves East.  

21.  From the Toolbar, MB1 click the ‘Left’ 
button. 

The geographic display moves West.  

22.  From the ‘Tools’ pull-down menu, select 
‘Recenter’. 

The cursor changes from an arrow into a 
leftward pointing hand that indicates that 
recenter functionality is active. 

 

23.  Click on an area that is not in the center of 
the display. 

The display recenters on the selected 
area. 

 

24.  From the ‘Tools’ pull-down menu, select 
‘Recenter’ again. Then click on the area 
that was originally at the center of the 
display. 

The geographic display returns to its 
previous viewing state and center. 

 

25.  From the ‘Tools’ pull-down menu, select 
‘Tool Bar’. 

A tool bar appears just below the row of 
pull-down menus. The icons shown 
perform the same functions as the Zoom 
and Pan options found in the ‘Tools’ pull-
down menu. 

 

26.  From the ‘Tools’ pull-down menu, select 
‘Tool Bar’ again. 

The tool bar disappears.  
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Step # Action Result Pass/Fail 
27.  From the ‘Gages’ pull-down menu, select 

‘Show Gage Identifiers’. 
(Note: The user may have to adjust the 
hour to see data appear.) 

Alphanumeric gage labels appear on the 
MPE display. 

 

28.  From the ‘Tools’ pull-down menu, select 
‘Set Font’. Then try selecting different font 
sizes. 

The alphanumeric gage labels change 
size. 

 

29.  From the ‘Gages’ pull-down menu, select 
‘Show Gage Identifiers’. 

The gage labels disappear from the 
display. 

 

30.  From the ‘Tools’ pull-down menu, select 
'MPE Color Manager...'. 

The MPE Color Scale Manager window 
appears. 

 

31.  MB1 click ‘PrecipFields’ -> ‘Gage Only 
Analysis’. 

The Gage Only Analysis displays in 
CAVE. 

 

32.  On the MPE Color Scale Manager 
window, select ‘Gage Only Analysis’ from 
the ‘Data Type’ dropdown manu. 
Then select the ‘<Min’ item on the top bar.  
MB1 click the ‘Change…’ button. 
Select ‘BLUE1’ from the Color Chooser 
list and then MB1 click ‘OK’.   
MB1 click the ‘Add/Update’ button. 
MB1 click the ‘Save as: root’ button. 

The selections are saved.  

33.  Close the MPE Color Scale Manager 
window 

The MPE Color Scale Manager window 
closes. 

 

34.  MB1 click ‘MPEControl’ -> ‘Next Hour’. The image updates with the new colorbar.  
35.  MB1 click ‘MPEControl’ -> ‘Previous 

Hour’. 
The image maintains the colors in the 
updated new colorbar. 

 

36.  From the ‘Tools’ pull-down menu, select 
'MPE Color Manager...'. 

The MPE Color Scale Manager window 
appears. 

 

37.  On the MPE Color Scale Manager 
window, select ‘Gage Only Analysis’ from 
the ‘Data Type’ dropdown manu. 
Then select the ‘<Min’ item on the top bar.  
MB1 click the ‘Change…’ button. 
Select ‘BLACK’ from the Color Chooser 
list and then MB1 click ‘OK’.   
MB1 click the ‘Add/Update’ button. 
MB1 click the ‘Save as: root’ button. 

The selections are saved.  

38.  Close the MPE Color Scale Manager 
window. 

The MPE Color Scale Manager window 
closes. 

 

39.  MB1 click ‘MPEControl’ -> ‘Next Hour’. The image updates with the saved 
colorbar. 

 

40.  MB1 click ‘MPEControl’ -> ‘Previous 
Hour’. 

The image maintains the colors in the 
updated/saved colorbar. 
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Step # Action Result Pass/Fail 
41.  On the ‘Tools’ pull-down menu, select 

‘View’. Then click ‘Split Screen’. 
The MPE display splits into two 
geographic areas, each with its own 
legend. 

DR #1914 

42.  On the ‘Tools’ pull-down menu, select 
‘View’. Then click ‘Full Screen’. 

The MPE display shows one geographic 
area with only one legend. 

 

43.  On the 'MPEControl' pull-down menu, 
select ‘Clear MPE Data’. 

A dialog box indicating that the data has 
not been saved displays. Click ‘OK’ in this 
dialog box. 
All the data on the map will be cleared 
and returned to the blank map. 

 

44.  On the ‘Tools’ pull-down menu, verify the 
‘Restore Initial’ option exists.  

Verified.  

45.  On the ‘Tools’ pull-down menu, verify the 
‘Find Station’ option exists. 

Verified.  

46.  From the ‘Projections’ pull-down menu, 
select ‘Polar Stereographic’. 

The geographic display uses a Polar 
Stereographic projection. 

 

47.  From the ‘Projections’ pull-down menu, 
select ‘HRAP’. 

The geographic display uses a HRAP 
projection. 

 

48.  From the ‘Projections’ pull-down menu, 
select ‘Flat Lat/Lon’. 

The geographic display uses a Flat 
Latitude/Longitude projection. 

 

49.  From the 'Overlays' pull-down menu, 
select 'State/County Boundaries'. 

MPE displays a blank screen (no maps).   

50.  From the 'Overlays' pull-down menu, 
select 'Lakes'. 

All streams or lakes display on the 
geographic display if defined in the 
Overlay Configuration file. 

 

51.  From the 'Overlays' pull-down menu, 
select 'Lakes'. 

The streams and lakes are removed from 
the geographic display. 

 

52.  From the ‘Overlays’ pull-down menu, 
select ‘River Drainage Basins’. 

This toggles the display of Basin 
Boundary outlines on the geographic 
display if defined in the Overlay 
Configuration file. 

 

53.  From the ‘Overlays’ pull-down menu, 
select ‘River Drainage Basins’. 

The River Drainage Basins are removed 
from the geographic display. 

 

54.  From the 'Overlays' pull-down menu, 
select 'County Boundaries'. 

This toggles the display of County outlines 
on the geographic display if defined in the 
Overlay Configuration file. 

 

55.  From the 'Overlays' pull-down menu, 
select 'County Boundaries'. 

County Boundaries are removed from the 
geographic display. 

 

56.  From the ‘Overlays’ pull-down menu, 
select ‘County Warning Areas’. 

This toggles the display of CWA outlines 
on the geographic display if defined in the 
Overlay Configuration file. 

 

57.  From the ‘Overlays’ pull-down menu, 
select ‘County Warning Areas’. 

The County Warning Areas are removed 
from the geographic display. 

 



Test Case MPE  DCN AWP.TE.SWCTR/T010-0014 
 

Contract DG133W-05-CQ-1067 / DCN AWP.TE.SWCTR/TO10-0014 / 6 Feb. 2009 8 
Use or disclosure of data contained on this sheet is subject to the restriction on the title page of this document. 

HARD COPY UNCONTROLLED 

Step # Action Result Pass/Fail 
58.  From the ‘Overlays’ pull-down menu, 

select ‘RFC Boundaries’. 
This toggles the display of RFC Boundary 
outlines on the geographic display if 
defined in the Overlay Configuration file. 

 

59.  From the ‘Overlays’ pull-down menu, 
select ‘RFC Boundaries’. 

The RFC Boundaries are removed from 
the geographic display. 

 

60.  From the 'Overlays' pull-down menu, 
select 'State Boundaries'. 

This toggles the display of State Borders 
on the geographic display if defined in the 
Overlay Configuration file. 

 

61.  From the 'Overlays' pull-down menu, 
select 'State Boundaries'. 

The State Boundaries are removed from 
the geographic display. 

 

62.  From the ‘Overlays’ pull-down menu, 
select ‘Forecast Zones’. 

This toggles the display of Zones on the 
geographic display if defined in the 
Overlay Configuration file. 

 

63.  From the ‘Overlays’ pull-down menu, 
select ‘Forecast Zones’. 

The Forecast Zones are removed from 
the geographic display. 

 

64.  From the ‘Overlays’ pull-down menu, 
select ‘Cities/Towns’. 

This toggles the display of City locations 
on the geographic display if defined in the 
Overlay Configuration file. 

 

65.  From the ‘Overlays’ pull-down menu, 
select ‘Cities/Towns’. 

The Cities/Towns are removed from the 
geographic display. 

 

66.  From the 'Overlays' pull-down menu, 
select 'Interstates'. 

This toggles the display of Interstates on 
the geographic display if defined in the 
Overlay Configuration file. 

 

67.  From the 'Overlays' pull-down menu, 
select 'Interstates'. 

The Highways or Roads are removed 
from the geographic display. 

 

68.  From the 'Overlays' pull-down menu, 
select 'ACARS Airport Locations'. 

This toggles the display of ACARS Airport 
Locations on the geographic display if 
defined in the Overlay Configuration file. 

 

69.  From the 'Overlays' pull-down menu, 
select 'ACARS Airport Locations '. 

The ACARS Airport Locations are 
removed from the geographic display. 

 

70.  From the 'Overlays' pull-down menu, 
select 'ARTCC hi-level sectors'. 

This toggles the display of ARTCC hi-level 
sectors on the geographic display if 
defined in the Overlay Configuration file. 

 

71.  From the 'Overlays' pull-down menu, 
select 'ARTCC hi-level sectors'. 

The ARTCC hi-level sectors are removed 
from the geographic display. 

 

72.  From the 'Overlays' pull-down menu, 
select 'Airports'. 

This toggles the display of Airports on the 
geographic display if defined in the 
Overlay Configuration file. 

 

73.  From the 'Overlays' pull-down menu, 
select 'Airports'. 

The Airports are removed from the 
geographic display. 

 

74.  From the 'Overlays' pull-down menu, 
select 'Canada'. 

This toggles the display of Canada on the 
geographic display if defined in the 
Overlay Configuration file. 

 

75.  From the 'Overlays' pull-down menu, 
select 'Canada'. 

The Canada map is removed from the 
geographic display. 
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Step # Action Result Pass/Fail 
76.  From the 'Overlays' pull-down menu, 

select 'County Names'. 
This toggles the display of County Names 
on the geographic display if defined in the 
Overlay Configuration file. 

 

77.  From the 'Overlays' pull-down menu, 
select 'County Names'. 

The County Names are removed from the 
geographic display. 

 

78.  From the 'Overlays' pull-down menu, 
select 'Fire Wx Zones'. 

This toggles the display of Fire Wx Zones 
on the geographic display if defined in the 
Overlay Configuration file. 

 

79.  From the 'Overlays' pull-down menu, 
select 'Fire Wx Zones'. 

The Fire Wx Zones are removed from the 
geographic display. 

 

80.  From the 'Overlays' pull-down menu, 
select 'FireWxAOR'. 

This toggles the display of the 
FireWxAOR overlay on the geographic 
display if defined in the Overlay 
Configuration file. 

 

81.  From the 'Overlays' pull-down menu, 
select 'FireWxAOR'. 

The FireWxAOR  overlay is removed from 
the geographic display. 

 

82.  From the 'Overlays' pull-down menu, 
select 'Fixed Buoy Locations'. 

This toggles the display of Fixed Buoy 
Locations on the geographic display if 
defined in the Overlay Configuration file. 

 

83.  From the 'Overlays' pull-down menu, 
select 'Fixed Buoy Locations'. 

The Fixed Buoy Locations are removed 
from the geographic display. 

 

84.  From the 'Overlays' pull-down menu, 
select 'High_Sea_Marine Zones'. 

This toggles the display of 
High_Sea_Marine Zones on the 
geographic display if defined in the 
Overlay Configuration file. 

 

85.  From the 'Overlays' pull-down menu, 
select 'High_Sea_Marine Zones'. 

The High_Sea_Marine Zones are 
removed from the geographic display. 

 

86.  From the 'Overlays' pull-down menu, 
select 'HiRes Topo Image'. 

This toggles the display of the HiRes 
Topo Image on the geographic display if 
defined in the Overlay Configuration file. 

DR #1913 

87.  From the 'Overlays' pull-down menu, 
select 'HiRes Topo Image'. 

The HiRes Topo Image is removed from 
the geographic display. 

 

88.  From the 'Overlays' pull-down menu, 
select 'ISC_all'. 

This toggles the display of the ISC_all 
overlay on the geographic display if 
defined in the Overlay Configuration file. 

 

89.  From the 'Overlays' pull-down menu, 
select 'ISC_all'. 

The ISC_all overlay is removed from the 
geographic display. 

 

90.  From the 'Overlays' pull-down menu, 
select 'Interstates_and_US_Highways'. 

This toggles the display of Interstates and 
US Highways on the geographic display if 
defined in the Overlay Configuration file. 

 

91.  From the 'Overlays' pull-down menu, 
select 'Interstates_and_US_Highways'. 

The Interstates and US Highways are 
removed from the geographic display. 

 

92.  From the 'Overlays' pull-down menu, 
select 'METAR Station Locations'. 

This toggles the display of METAR Station 
Locations on the geographic display if 
defined in the Overlay Configuration file. 
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Step # Action Result Pass/Fail 
93.  From the 'Overlays' pull-down menu, 

select 'METAR Station Locations'. 
The METAR Station Locations are 
removed from the geographic display. 

 

94.  From the 'Overlays' pull-down menu, 
select 'RAOB Station Locs'. 

This toggles the display of RAOB Station 
Locations on the geographic display if 
defined in the Overlay Configuration file. 

 

95.  From the 'Overlays' pull-down menu, 
select 'RAOB Station Locs'. 

The RAOB Station Locations are removed 
from the geographic display. 

 

96.  From the 'Overlays' pull-down menu, 
select 'Railroads'. 

This toggles the display of Railroads on 
the geographic display if defined in the 
Overlay Configuration file. 

 

97.  From the 'Overlays' pull-down menu, 
select 'Railroads'. 

The Railroads are removed from the 
geographic display. 

 

98.  From the 'Overlays' pull-down menu, 
select 'Synoptic Station Locations'. 

This toggles the display of Synoptic 
Station Locations on the geographic 
display if defined in the Overlay 
Configuration file. 

 

99.  From the 'Overlays' pull-down menu, 
select 'Synoptic Station Locations'. 

The Synoptic Station Locations are 
removed from the geographic display. 

 

100.  From the 'Overlays' pull-down menu, 
select 'TWEB Routes'. 

This toggles the display of TWEB Routes 
on the geographic display if defined in the 
Overlay Configuration file. 

 

101.  From the 'Overlays' pull-down menu, 
select 'TWEB Routes'. 

The TWEB Routes are removed from the 
geographic display. 

 

102.  From the ‘Overlays’ pull-down menu, 
select ‘HRAP’. 

This toggles the display of the HRAP grid 
on the geographic display if defined in the 
Overlay Configuration file. 

 

103.  From the ‘Overlays’ pull-down menu, 
select ‘Lat/Lon 10 Over Ocean’. 

This toggles the display of Latitude and 
Longitude lines on the geographic display 
if defined in the Overlay Configuration file. 

 

104.  From the ‘Overlays’ pull-down menu, 
select ‘Lat/Lon 10 Over Ocean’. 

The Lat/Lon Lines are removed from the 
geographic display. 

 

105.  From the ‘Overlays’ pull-down menu, 
select ‘Time Zones’. 

This toggles the display of Time Zone 
boundaries on the geographic display if 
defined in the Overlay Configuration file. 

 

106.  From the ‘Overlays’ pull-down menu, 
select ‘Time Zones’. 

The Time Zones are removed from the 
geographic display. 

 

107.  From the ‘Overlays’ pull-down menu, 
select ‘WSR-88D Stations’. 

This toggles the display of Radar 
locations on the geographic display if 
defined in the Overlay Configuration file. 

 

108.  From the ‘Overlays’ pull-down menu, 
select ‘WSR-88D Stations’. 

The Radar Locations are removed from 
the geographic display. 
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Step # Action Result Pass/Fail 
109.  From the 'Overlays' pull-down menu, 

select 'State/County Boundaries'. 
This toggles the display of State/County 
Boundary locations on the geographic 
display if defined in the Overlay 
Configuration file. (Note: To view the 
county boundaries, the user may have to 
zoom in to a level where the county lines 
appear. 

 

110.  From the ‘Overlays’ pull-down menu, 
select ‘Radar Rings’. 

This toggles the display of the outline of 
the Radar’s coverage area on the 
geographic display if defined in the 
Overlay Configuration file. Note the colors 
of the radar rings. A red radar ring 
indicates that there is no data for that 
radar site. A green radar ring indicates 
that there is data for the radar site. 

 

111.  On the Overlays pull-down menu, verify 
the ‘Basin Names’, ‘Hydro Service Areas’, 
and ‘Maps Foreground’ options exist. 

Verified.  

112.  From the ‘MPEcontrol’ pull-down menu, 
select ‘Previous Hour’. 

A dialog box indicating that this hour’s 
MPE field has not been saved displays. 
Select ‘OK’ from this dialog to display the 
previous hour’s MPE field. 

 

113.  From the ‘MPEcontrol’ pull-down menu, 
select ‘Next Hour’. 

A dialog box indicating that this hour’s 
MPE field has not been saved displays. 
Select ‘OK’ from this dialog to display the 
next hour’s MPE field. 

 

114.  From the ‘MPEcontrol’ pull-down menu, 
select ‘Choose Hour’. 

The Choose Data Period window 
displays. 

 

115.  From the Choose Data Period window, 
click the ‘Close’ button. 

The Choose Data Period window closes.  

116.  From the ‘MPEcontrol’ pull-down menu, 
select ‘Save Best Estimate Top’. 

The currently displayed MPE field is 
saved as the best estimate QPE. To verify 
this, go to 
/awips/hydroapps/precip_proc/local/data/
mpe/qpe and verify the time stamp on the 
xmrg file for this hour. 

 

117.  From the ‘MPEcontrol’ pull-down menu, 
the ‘Save Best Estimate Bottom’ option 
only applies when in split screen mode. 
When in split screen mode, this option 
saves the MPE field displayed in the lower 
window as the best estimate QPE. 

The MPE field displayed is saved as the 
best estimate QPE. 

 

118.  From the ‘MPEcontrol’ pull-down menu, 
select ‘Regenerate Hour Fields’. 

The Regenerate Hour Fields Dialog 
window displays. 
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Step # Action Result Pass/Fail 
119.  From the ‘Regenerate Hour Fields Dialog’ 

window, click ‘Yes’. 
In the Data not Saved, ok to proceed? 
popup window, MB1 click ‘OK’ 

MPE Fieldgen is rerun for the displayed 
hour’s MPE data. To verify this, go to 
/awips/hydroapps/precip_proc/local/data/
mpe/rmosaic and verify the timestamp on 
the RMOSAIC file for this hour or verify in 
pgAdmin3 the ‘rwresult’ table has updated 
(last_saved_time). 

 

120.  From the ‘Precipfields’ pull-down menu, 
select ‘Radar Mosaic’. 

The Radar Mosaic Precip Field displays.  

121.  From the ‘Precipfields’ pull-down menu, 
select ‘Average Radar Mosaic’. 

The Average Radar Mosaic field displays. 
If the ‘Average Radar Mosaic’ option is 
grayed out, then AVGRMOSAIC is not 
listed in either the mpe_generate_list 
token or the mpe_base_radar_mosaic 
token. 

 

122.  From the ‘Precipfields’ pull-down menu, 
select ‘Max Radar Mosaic’. 

The Maximum Radar Mosaic field 
displays. If the ‘Max Radar Mosaic’ option 
is grayed out, then MAXRMOSAIC is not 
listed in either the mpe_generate_list 
token or the mpe_base_radar_mosaic 
token. 

 

123.  From the ‘Precipfields’ pull-down menu, 
select ‘Field Bias Radar Mosaic’. 

The Field Bias Radar Mosaic displays. If 
the ‘Field Bias Radar Mosaic’ option is 
grayed out, then BMOSAIC is not listed in 
the mpe_generate_list token or 
MMOSAIC is not listed in the 
mpe_generate_list token. 

 

124.  From the ‘Precipfields’ pull-down menu, 
select ‘Local Bias Radar Mosaic’. 

The Local Bias Radar Mosaic displays. If 
the ‘Local Bias Radar Mosaic’ option is 
grayed out, then LMOSAIC is not listed in 
the mpe_generate_list token or 
MLMOSAIC is not listed in the 
mpe_generate_list token. 

 

125.  From the ‘Precipfields’ pull-down menu, 
select ‘Gage Only Analysis’. 

The Gage Only Analysis displays. If the 
‘Gage Only Analysis’ option is grayed out, 
then GAGEONLY is not listed in the 
mpe_generate_list token. 

 

126.  From the ‘Precipfields’ pull-down menu, 
select ‘Satellite Precip’. 

The Satellite Precipitation field displays. If 
the ‘Satellite Precip’ option is grayed out, 
then SATPRE is not listed in the 
mpe_generate_list token. 

 

127.  From the ‘Precipfields’ pull-down menu, 
select ‘Local Bias Satellite Precip’.  

The Local Bias Satellite Precipitation field 
displays. If the ‘Local Bias Satellite Precip’ 
field option is grayed out, then LSATPRE 
is not listed in the mpe_generate_list 
token. 
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Step # Action Result Pass/Fail 
128.  From the ‘Precipfields’ pull-down menu, 

select ‘Multisensor Mosaic’. 
The Multisensor Mosaic displays. If the 
‘Multisensor Mosaic’ option is grayed out, 
then MMOSAIC is not listed in the 
mpe_generate_list token. 

 

129.  From the ‘Precipfields’ pull-down menu, 
select ‘Local Bias Multisensor Mosaic’. 

The Local Bias Multisensor Mosaic 
displays. If the ‘Local Bias Multisensor 
Mosaic’ option is grayed out, then 
LMOSAIC is not listed in the 
mpe_generate_list token. 

 

130.  From the ‘Precipfields’ pull-down menu, 
select ‘Triangulated Local Bias Mosaic’. 

The Triangulated Local Bias Mosaic 
displays. If the ‘Triangulated Local Bias 
Mosaic’ option is grayed out, then 
P3LMOSAIC is not listed in the 
mpe_generate_list token. 

 

131.  From the ‘PrecipFields’ menu, select ‘Best 
Estimate QPE’. 

The Best Estimate QPE field displays.  

132.  From the ‘Basefields’ pull-down menu, 
select ‘Local Span’. 

The Local Span Field displays if 
LMOSAIC or MLMOSAIC is listed in the 
mpe_generate_list token. 

 

133.  From the ‘Basefields’ pull-down menu, 
select ‘Local Bias’. 

The Local Bias Field displays if LMOSAIC 
or MLMOSAIC is listed in the 
mpe_generate_list token. 

 

134.  From the ‘Basefields’ pull-down menu, 
select ‘Height Field’. 

The Height Field displays.  

135.  From the ‘Basefields’ pull-down menu, 
select ‘Radar Coverage Field’. 

The Radar Coverage Field displays.  

136.  From the ‘Basefields’ pull-down menu, 
select ‘Gage Triangles’. 

The Gage Triangles displays if 
P3LMOSAIC is specified in the 
mpe_generate_list token. (note**: it is 
grayed out) 

 

137.  On the ‘Gages’ pull-down menu, verify the 
‘QC Precipitation’ option exists. 

Verified.  

138.  On the ‘Gages’ pull-down menu, verify the 
‘QC Temperature’ option exists. 

Verified.  

139.  On the ‘Gages’ pull-down menu, verify the 
‘QC Freezing Level’ option exists. 

Verified.  

140.  On the ‘Gages’ pull-down menu, verify the 
‘Save Level 2 Data’ option exists. 

Verified.  

141.  From the ‘Precipfields’ pull-down menu, 
select ‘Gage Only Analysis’. 

The Gage Only Analysis displays.  

142.  From the ‘Gages’ pull-down menu, select 
‘Add Pseudo Gage’. 

The mouse pointer turns into a left 
pointing hand. 

 

143.  Double MB1 click on a location inside the 
currently displayed ‘Gage Only Analysis’ 
field. 

The Add Pseudo Gage window appears.  
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Step # Action Result Pass/Fail 
144.  Using the Pseudo Gage Accumulation 

slider bar on the Add Pseudo Gage 
window, choose ‘0.50 inches’ and click 
the ‘OK’ button. 

The Add Pseudo Gage window closes.  

145.  From the ‘MPEcontrol’ pull-down menu, 
select Regenerate Hour Fields. Select 
‘Yes’ in the pop up confirmation window. 
MB1 click ‘OK’ in the Data not Saved 
window. 

The MPE_ Fieldgen process is run for the 
chosen hour. After MPE_ Fieldgen has 
run, the Gage Only Analysis field is 
regenerated. The field appears to be 
altered in the vicinity of the newly created 
pseudo gage.  

 

146.  From the ‘Gages’ pull-down menu, select 
‘Gage Table’. 

The Gage Table displays.  

147.  Select ‘by Gage Value’ from the ‘Gage 
Table Sort Gages’ menu. 

The gages are sorted by descending 
value. 

 

148.  Select by ‘by Radar ID’ from the ‘Gage 
Table Sort Gages’ menu. 

The gages are grouped and sorted by 
ascending Radar ID. 

 

149.  Select ‘by Gage ID’ from the ‘Gage Table 
Sort Gages’ menu. 

The gages are grouped and sorted by 
ascending Gage ID. 

 

150.  From the ‘Gages’ pull-down menu, select 
‘Show Gage Identifiers’. 

The gage identifiers are drawn on the 
MPE display. 

 

151.  From the ‘Gages’ pull-down menu, select 
‘Show Gage Values’. 

The gage values are drawn on the MPE 
display. 

 

152.  Find a zero-valued gage on the MPE 
display and locate this gage in the Gage 
Table window. 

The gage is located.  

153.  In the Edit column, modify the value of 
this gage to a large non-zero amount. 

The value of the gage is modified to a 
large non-zero amount. 

 

154.  Select ‘Quit’ from the ‘Control’ menu in the 
Gage Table window. 

The Gage Table closes. The edited gage 
value is saved. Note**: Value is not saved 

 

155.  From the ‘MPEcontrol’ pull-down menu, 
select ‘Regenerate Hour Fields’. 

The Rerun FieldGen Dialog window 
displays. 

 

156.  From the Rerun FieldGen Dialog window, 
click ‘Yes’. 

MPE_ Fieldgen is rerun for the hour’s 
MPE data being displayed. After MPE_ 
Fieldgen has run, the MPE window shows 
the results of the gage edit on the Gage 
Only Analysis precipitation field. 

 

157.  From the ‘Gages’ pull-down menu, select 
‘Show Missing Gages’. Then select ‘All 
Missing’ from the ‘Missing Gages’ 
submenu. 

Gages with missing values display in the 
MPE window with values of ‘M’. There 
may not be any. 

 

158.  MB1 click ‘Gages’ -> ‘Gage Color’ -> 
‘Contrast Color’. 

The gage identifiers and gage values 
display in white. 

 

159.  MB1 click ‘Gages’ -> ‘Gage Color’ -> 
‘Color By QC’. 

The gage identifiers and gage values 
display in a sandy brown color. 
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Step # Action Result Pass/Fail 
160.  MB1 click ‘Gages’ -> ‘Gage Color’ -> 

‘Color By Value’. 
The gage identifiers and gage values 
display in the color as assigned by the 
colorbar. 

 

161.  From the ‘Gages’ pull-down menu, select 
‘Gage Color’ -> ‘Solid Color’. 

The gage identifiers and gage values 
display in a sandy brown color. 

 

162.  Select ‘Display 7 x 7’ from the ‘Gages’ 
pull-down menu. 

The pointer changes shape so that the 
user can choose a gage. 

 

163.  Double click MB1 near a gage in the grid 
region (“area of responsibility”). The tester 
should choose a gage in an area that has 
precipitation (e.g., a pseudo gage). 

A Display 7x7 Gage Editing Utility window 
opens for the precipitation gage closest to 
the area selected. 

 

164.  In the Display 7x7 Gage Editing Utility 
window, slide the Edit Gage Value bar 
partially to the right. Then select ‘Set 
Value’. 
From the Display 7x7 Gage Editing Utility 
window, select ‘Close’. 

The Display 7x7 Gage Editing Utility 
window closes. 

 

165.  Select ‘Regenerate Hour Fields’ from the 
‘MPEcontrol’ pull-down menu. 

The Rerun FieldGen Dialog window 
appears. 

 

166.  Select ‘Yes’ in the Rerun FieldGen Dialog 
window. 
MB1 click ‘OK’ in the Data not Saved 
window. 

The MPE_ Fieldgen process is run for the 
chosen hour. After MPE_ Fieldgen has 
run, the MPE window shows the results of 
the gage edit on the Gage Only Analysis 
precipitation field.  The change is 
accepted. The gage value shown directly 
beneath the gage identifier in the Display 
7x7 Gage Editing Utility window updates 
to the value chosen on the Edit Gage 
Value slider bar.  The rwresult table in 
pgAdmin3 also updates. 

 

167.  From the Polygons pull-down menu, 
select ‘Draw Polygons’. 

The option is selected.  

168.  Using single MB1 clicks, draw a polygon 
on the displayed MPE data field.  

A line connecting the polygon vertices 
defined by the MB1 click points is drawn 
on the MPE display. 

 

169.  Perform a single MB3 click to close the 
polygon. 

The displayed polygon outline is closed by 
a line connecting the last polygon vertex 
to the first polygon vertex. The Edit 
Precipitation window displays. 

 

170.  From the Edit Precipitation window, select 
a nonzero value on the Adjust 
Precipitation Value slider. Then click the 
‘Set’ button below the slider. 

The drawn polygon fills with a solid color 
representing the value chosen on the 
Adjust Precipitation Value slider. 

 

171.  From the Edit Precipitation window, select 
‘Close’. 

The Edit Precipitation window closes.  
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Step # Action Result Pass/Fail 
172.  From the ‘Polygons’ pull-down menu, 

select ‘Delete Polygons’. 
The Delete Polygons window displays. In 
its text field, there should be an entry for 
the polygon just drawn. 

 

173.  In the Delete Polygons window, select the 
entry corresponding to the polygon just 
created. Click the ‘Undisplay’ button. 

The polygon is removed from the MPE 
display. Its displayed flag is set from ‘T’ to 
‘F’. 

 

174.  In the Delete Polygons window, select the 
‘Display’ button. 

The polygon is shown on the MPE 
display. Its displayed flag is set from ‘F’ to 
‘T’. 

 

175.  In the Delete Polygons window, select 
‘Delete’. 

The polygon is permanently removed from 
the MPE display. Its entry is removed 
from the Delete Polygons window. 

 

176.  In the Delete Polygons window, select 
‘Close’. 

The Delete Polygons window closes.  

177.  From the ‘Polygons’ pull-down menu, 
select ‘Draw Polygons’. 

The option is selected.  

178.  Using single MB1 clicks, draw a polygon 
on the displayed MPE data field. Try to 
draw the polygon around one or more 
areas of precipitation on the MPE display. 

A line connecting the polygon vertices 
defined by the MB1 click points is drawn 
on the MPE display. 

 

179.  Perform a single MB3 click to close the 
polygon. 

The displayed polygon outline is closed by 
a line connecting the last polygon vertex 
to the first polygon vertex. The Edit 
Precipitation window displays. 

 

180.  On the Edit Precipitation window, set the 
‘Adjust Precipitation Value’ to a value 
midway between the highest and lowest 
precipitation values contained within the 
polygon. For example, if the polygon 
encompasses precipitation amounts 
ranging from 0 to 0.50 inches, then set the 
slider bar to 0.25 inches. 

The slider bar is set.  

181.  On the Edit Precipitation window, click the 
‘Raise’ button. 

All values within the edit polygon drawn 
on the MPE display which are below the 
value selected on the Adjust Precipitation 
slider bar are raised to the slider bar 
value. All values within the edit polygon 
which are above the value set on the 
slider bar are left unchanged. 

 

182.  Using single MB1 clicks, draw another 
polygon on the displayed MPE data field. 
Try to draw the polygon around one or 
more areas of precipitation on the MPE 
display. Try to draw this polygon so it 
does not overlap the previously drawn 
polygon. 

A line connecting the polygon vertices 
defined by the MB1 click points is drawn 
on the MPE display. 
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Step # Action Result Pass/Fail 
183.  Perform a single MB3 click to close the 

polygon. 
The displayed polygon outline is closed by 
a line connecting the last polygon vertex 
to the first polygon vertex. The Edit 
Precipitation window displays. 

 

184.  On the Edit Precipitation window, set the 
Adjust Precipitation Value slider bar to a 
value midway between the highest and 
lowest precipitation values contained 
within the polygon. For example, if the 
polygon encompasses precipitation 
amounts ranging from 0 to 0.50 inches, 
then set the slider bar to 0.25 inches. 

The slider bar is set.  

185.  On the Edit Precipitation window, click the 
‘Lower’ button. 

All of the values within the polygon which 
have a value higher than the value 
selected on the Adjust Precipitation Value 
slider bar are lowered to the slider bar 
value. All values within the polygon which 
have a value lower than the value on the 
slider bar are left unchanged. 

 

186.  On the Edit Precipitation window, set the 
Adjust Precipitation Value slider bar to 
0.50. Click the ‘Scale’ button. 

All values within the previously drawn 
polygon are reduced by half (multiplied by 
0.50). 

 

187.  On the Edit Precipitation window in the 
Select Field to Substitute section, select 
an MPE field different from the one 
currently shown in the MPE display. Click 
the ‘Substitute’ button.  

Precipitation data from the selected field 
are placed into the previously drawn 
polygon. 

 

188.  On the Edit Precipitation window, select 
the ‘Close’ button. 

The Edit Precipitation window closes.  

189.  From the ‘Climo’ pull-down menu, select 
the ‘Monthly Prism Precip’ option. 

PRISM data representing average 
precipitation for the current month display 
in the MPE display. 

 

190.  From the ‘Misc’ pull-down menu, select 
the ‘Display Bias Table’ option. 

The Edit Bias Table window displays.  

191.  From the Edit Bias Table window, click a 
button corresponding to a radar site in the 
radar column. 

A window appears listing the number of 
gage/radar pairs, the mean gage value, 
the mean radar value, and the resulting 
bias for each of 10 memory spans. 

 

192.  In the Edit Bias Table window, for a radar 
site, modify the bias value by entering a 
new value in the text field located to the 
right of the radar id button. 

The ‘NO’ label in the manually specified 
box should change to ‘YES’. 

 

193.  From the radar-specific memory span 
window, select ‘Close’. 

The radar-specific memory span window 
closes. 

 

194.  From the ‘Edit Bias’ table, click the ‘Close’ 
button. 

The Edit Bias table closes.  
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Step # Action Result Pass/Fail 
195.  Select ‘Review Hourly Radar’ from the 

‘Misc’ pull-down menu. 
The Radar Sites window displays. It 
contains a list of all of the radars which 
contribute to the MPE analysis. 

 

196.  Select a radar site from the Radar Sites 
window. Then select ‘OK’. 

The four paned Single Radar Site window 
displays. Clockwise from the upper left 
pane, it displays the Raw Radar, Radar 
Climatology, Radar Coverage Map, and 
the Mean Field Bias Corrected Radar for 
the selected radar site for the selected 
hour. 

 

197.  From the Single Radar Site window 
‘Options’ pull-down menu, select ‘Edit 
Bias Value’. 

The Edit Bias Value window appears.  

198.  On the Edit Bias Value window, use the 
slider bar to adjust the bias value for the 
radar for which the Single Site Radar 
window was opened. Click the ‘OK’ 
button. 

The Edit Bias Value window closes.  

199.  On the Single Radar Site window 
‘Options’ pull-down menu, select ‘Ignore 
Radar’. 

The ‘Ignore Radar’ option on the Single 
Radar Site window Options pull-down 
menu relabels to ‘Unignore Radar’. 

 

200.  On the Single Radar Site window 
‘Options’ pull-down menu, select 
‘Unignore Radar’. 

The ‘Unignore Radar’ option on the Single 
Radar Site window ‘Options’ pull-down 
menu relabels to ‘Ignore Radar’. 

 

201.  On the Single Radar Site window 
‘Options’ pull-down menu, select ‘Display 
Adaptable Param’. 

The Adaptation Parameter Viewer 
displays. It shows the adaptation 
parameters for the selected radar site. 

 

202.  On the Adaptation Parameter Viewer 
window, click the ‘Close’ button. 

The Adaptation Parameter Viewer window 
closes. 

 

203.  On the Single Radar Site window 
‘Options’ pull-down menu, select ‘Display 
Supplemental Data’.  
Note**: It is grayed out. 

The Supplemental Data Viewer displays. 
This shows the supplemental data for the 
selected radar. 

 

204.  On the Supplemental Data Viewer, select 
the ‘Close’ button. 

The Supplemental Data Viewer closes.  

205.  Select ‘Close’ from the ‘Control’ menu of      
the Single Radar Site window. 

The Single Radar Site window closes.  

206.  From the ‘Misc’ pull-down menu, select 
‘Time Lapse’. Then select ‘6 Hr’ from the 
‘Time Lapse’ submenu. 

The currently displayed MPE field will time 
lapse over the past 6 hours worth of data. 

 

207.  From the ‘Misc’ pull-down menu, select 
‘Time Lapse’. Then select ‘End Loop’ from 
the ‘Time Lapse’ submenu.  
Note**: It is grayed out. 

The 6 hour time lapse ends. The MPE 
field from the original date and hour 
displays. 

 

208.  From the ‘Misc’ pull-down menu, select 
‘Multi-Hour QPE’. 

The Multi-Hour Precipitation Accumulation 
window displays.  
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Step # Action Result Pass/Fail 
209.  From the Multi-Hour Precipitation window, 

select ‘Accumulation Interval Setup’ and 
set the duration to 24 hours. From the 
Accumulation Display Control, click the 
‘Show Data’ button. 

The MPE display shows an accumulation 
of the past 24 hours worth of Best QPE 
fields. 

 

210.  From the Multi-Hour Accumulation 
window, select the ‘Close’ button. 

The Multi-Hour Precipitation Accumulation 
window closes. 

 

211.  Close the MPE Perspective. The MPE Perspective closes.  
Test – MPE Output for Display in CAVE 
212.  In CAVE, Mouse Button (MB) 1 click on 

the Perspectives icon and select ‘MPE’ 
from the dropdown menu if available. If 
not available, select ‘Other…’. Then select 
‘MPE’ from the Open Perspective dialog. 

The MPE Perspective and MPE Choose 
Data Period window display in CAVE. 

 

213.  In the Choose Data Period window, adjust 
the ‘Hours’ field and click ‘Display MPE 
Data’ button to check if there is data 
(image) shown for that hour. It is better to 
have data for the test. But if not, it is still 
ok. 
 
Note: Write down the 
year/month/data/hour from the Choose 
Data Period for later validation. 

The data (image) for the selected hours 
displays. 

 

214.  Under the ‘Polygons’ menu, select ‘Draw 
Polygons’. 

The polygon is selected.  

215.  MB1 click on the black area of the screen 
repeatedly to draw a circle or oval shape. 
Then MB3 click to join the end of the 
shape. 

The Edit Precipitation window displays.  

216.  Adjust the precipitation value to the 
desired position by using the slider bar. 
Click on the ‘Set’ button. Then select the 
‘Close’ button. 

The new polygon (shape) drawn displays 
on the screen. 

 

217.  Under the ‘MPEControl Menu’ in the main 
window, select ‘Save Best Estimate Top’. 

The polygon is saved.  

218.  Navigate to the OHD xmrg files located at 
/awips/hydroapps/precip_proc/local/data/
mpe/qpe. Look for the xmrg file with the 
date/time written in step 154 (e.g., 
xmrgmmddyyyyhhz) 

The xmrg file should match.  

219.  Navigate to the generated GRIB files in 
/awips/hydroapps/precip_proc/local/data/
mpe/qpe_grib. Look for the grib file with 
the date/time written in step 154. (e.g., 
yyyymmddhhz.grib) 

The grib file should match.  
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Step # Action Result Pass/Fail 
220.  Toggle to the D2D Perspective. The D2D Perspective and associated 

main window opens. 
 

221.  Click on the ‘Scale’ drop-down menu and 
select ‘Region’ or ‘State’. 

The selected scale displays.  

222.  Under ‘NCEP/Hydro’ menu, go to the 
‘Hydro’ section and select ‘QPE >> 1 hour 
WFO Local MPE’. 

The ‘1 hour WFO Local MPE’ option is 
selected. 

 

223.  Click on the icon ‘<’ (Step Back) to the 
date/time written in step 154. 

The polygon (shape/image) from step 158 
displays. 

 

224.  Close the MPE Perspective The MPE Perspective closes.  
End of Test 
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HARD COPY UNCONTROLLED 

REQUIREMENTS VERIFICATION TRACEABILITY MATRIX (RVTM) 

Number Description Test Step(s) 

SYSR3100 
The AWIPS system shall implement Precipitation processing storage in 
the IHFS database (initial pattern for Precipitation Processing Library). 112-211 

SYSR3109 

The AWIPS system shall implement MPE (Multisensor Precipitation 
Estimator) Interactive Editor in an MPE perspective (reuse CAVE GFE 
look and feel). 

ALL 

SYSR3114 
The AWIPS system shall integrate the MPE_Fieldgen capability with 
configuration controls. 119-211 
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