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1.0 SCOPE 

See TO10 Software Test Plan. 
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2.0 APPLICABLE DOCUMENTS 

2.1 Source Documents 
• None 
 

2.2 Reference Documents 
• Legacy NWS GFE Acceptance Test Case ID Number: ac009 
• Legacy NWS GFE Test Cases for Test Areas AC – VP 
• Section 3.1.3 of the AWIPS D-2D User’s Manual Build 8.1 
• Software Test Plan for the Advanced Weather Information Processing System 

Project, Contract #DG133W-05-CQ-1067, August 2008 
• The Silver Spring NWS AWIPS 1 test bed application 
• Release OB8.1 and OB8.2 of the Weather Event Simulator (WES) 
• Rational RequisitePro 
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3.0 TEST CASE DESCRIPTION 
This test case exercises and demonstrates the Smart Tools functionality developed during TO9 and 
Procedures developed in TO10. 
 

3.1 Assumptions, Constraints and Preconditions 
• Several weather elements are loaded 
• There are multiple grids available for the weather elements (at minimum T, Td, Wind, Wx, 

and Hazards weather elements) 
• TO10 software has been installed successfully 
• CAVE and EDEX are running 
• Data has been ingested 
• A Convective Watch (e.g., Severe Thunderstorm or Tornado Watch) is readily 

available to be ingested. 
• The GFE Perspective is displayed 
• Procedures MergeHazards and SeparateHazards are tested in the Hazards Grids test case.  

(Note: MakeHazards is no longer a procedure but has been implemented in Java.) 
 

3.2 Recommended Hardware 
See Software Test Plan. 
 

3.3 Test Inputs 
Section 4.0 below contains the test procedures for this test case. Sections 2.2 – 2.9 of the Software 
Test Plan contain general test inputs applicable to all TO9 test cases. Grayed out test step(s) 
indicate functionality not yet delivered. 
 

3.4 Test Outputs 
The Smart Tools will be executed on images displayed in CAVE and the results outlined in section 
4.0 are met. The GFE GUIs to be tested include: 

• Copy All Grids From 

• Edit Action Dialog 

• Weather Element Browser 

• Save Forecast 

• ProcedureCmds Values 

• QPF_SmartTool Values 

• MixHgt_Init Values 

• Item Delete 
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4.0 TEST SCENARIO 

Step Action Result Pass/Fail
Procedures 

1. 

If weather elements are not populated in 
the Grid Manager (GM), Mouse Button 
(MB) 1 click ‘Populate’ -> ‘Copy All 
Grids From…’.  

The Copy All Grids From dialog 
opens. 

 

2. 

From the Copy All Grids From dialog, 
select an available model and MB1 click 
‘OK’.  
Note: If the Empty Edit Area Warning 
dialog displays, MB1 click on the ‘Do not 
show this message again’ and MB1 click 
‘Yes’. 

Grids are created from model data 
and placed into the Fcst database. 

 

3. 
In the Grid Manager, MB1 click and drag 
over a 12 hour period on the temperature 
grids where grids are present. 

Grids are highlighted in the Grid 
Manager. 

 

4. 

MB1 click in the square box for the 
following weather elements (if grids are 
present) to highlight the same time period 
highlighted in step 3: 
Td, RH, Wind, PoP, QPF, SnowAmt, 
SnowLevel and FzLevel. 

The same time period is highlighted 
for the selected weather elements. 

 

5. MB1 click ‘Grids’ -> ‘Interpolate’. The Interpolation dialog appears.  

6. In the Interpolation dialog, select ‘Gaps’ 
and MB1 click the ‘OK’ button. 

The empty grids fill in with 
interpolated data. 

 

7. 

For weather elements without grids, create 
scratch grids for the first hour and last 
hour for the same period highlighted in 
steps 3 and 4. 
To do this, MB3 click over the first empty 
block corresponding to the first hour and 
select ‘Create From Scratch’. 
Repeat for the last hour in the time range. 
 
Note: For grids with time ranges longer 
than one hour (e.g., MaxT and MinT), 
create a scratch grid MB3 clicking on the 
grid block that overlaps the time range 
highlighted in steps 3 and 4. 

Scratch grids are created.  

8. MB1 click and drag over the 12 hour 
period on the scratch grids. 

Grids are highlighted in the Grid 
Manager. 

 

9. MB1 click in the square box for the 
weather elements where scratch grids were 

The same time period is highlighted 
for the selected weather elements. 
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Step Action Result Pass/Fail
created to highlight the same time period 
highlighted in step 8. 

10. MB1 click ‘Grids’ -> ‘Interpolate’. The Interpolation dialog appears.  

11. In the Interpolation dialog, select ‘Gaps’ 
and MB1 click the ‘OK’ button. 

The empty grids fill in with 
interpolated data. 

 

12. MB1 click on the Edit Action Dialog (E) 
button.  

The Edit Actions Dialog window 
opens. 

 

13. 

For grids created from scratch, Smart 
Tools will need to be run to populate the 
grids with data.  To do this, MB1 click on 
one of the grids for one weather element.   

The default grid color displays in 
the Spatial Editor. 

 

14. 
MB1 click and drag over the 12 hour 
period for the scratch grids for the selected 
element. 

Grids are highlighted in the Grid 
Manager. 

 

15. 

MB1 click the associated Smart Tool for 
the selected weather element  
(SmartTool -> WeatherElement).   
For example: 
MaxT_SmartTool -> MaxT  
MinT_SmartTool -> MinT 
WindGust_Tool -> WindGust 
WindChillTool -> WindChill 
HeatIndexTool -> HeatIndex  

All available grids have data.  
Smart Tools populate grids with 
data.  
 

 

16. Close the Edit Actions dialog when 
completed. 

The Edit Actions Dialog window 
closes. 

 

17. 

MB1 click ‘WeatherElement’ -> ‘Weather 
Element Browser…’. From the Weather 
Element Browser dialog, load in the Fire 
Wx and Marine weather element groups 
selecting ‘File’ -> ‘Load Weather Element 
Group’ -> ‘Fire Wx’, and ‘File’ -> ‘Load 
Weather Element Group’ -> ‘Marine’. 
MB1 click ‘Load and Dismiss’.  

The fire weather and marine 
weather elements load into the 
GFE. 

 

18. 

Scroll through the weather elements in the 
GM.  
Use the Copy All Grids From functionality 
to populate the GM. 

The GM populates with the fire 
weather and marine weather 
elements.  Data is available for most 
of the elements.  Some of the 
elements are ‘very long’, e.g., a 
single grid spanning many days. 
Examples of this include HrsOfSun 
and InvBurnOffTemp. 

DR 
#1346 

19. 
MB1 click ‘WeatherElement’ -> ‘Weather 
Element Groups’ -> ‘Public’ to load just 
the public elements.  

Only the public elements appear. 
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Action Result Pass/Fail

20. 

Bring up the Weather Element Browser 
selecting ‘WeatherElement’ -> ‘Weather 
Element Browser’. Add ‘MixHgt’ to the 
list of weather elements to be loaded by 
pulling down the Field menu. Then MB1 
click ‘Load and Dismiss’. 

MixHgt is added to the list of 
weather elements. 

 

21. 

Save all forecast data by MB1 clicking the 

toolbar button. From the Save Forecast 
dialog, ensure all weather elements are 
selected. Then MB1 click the ‘Save 
Forecast’ button. 

The Save Forecast dialog appears. 
All weather elements are selected. 
The grids are saved as indicated by 
the replacement of the green locks 
with a black background. 
The Save Forecast dialog closes. 

 

22. MB1 click ‘Populate’ -> 
‘ProcedureCmds’.   

A ProcedureCmds Values dialog 
displays. 

 

23. 

From the ProcedureCmds Values dialog, 
select ‘All’ for the Model Elements, select 
an entry for the Model, a beginning hour, 
and select an entry from the Initialize 
Model. Then MB1 click ‘Run/Dismiss’.  

A dialog displays stating ‘Loading 
Grids’. When the procedure 
finishes, the small dialog is 
dismissed. Many grids have been 
modified. Some are interpolated. 
Some errors may be reported, such 
as no grids to interpolate or no 
corresponding grids. 

 

24. Save all forecast data using the  toolbar 
button. 

The weather elements save.  

25. 

MB1 click ‘GFE’ -> ‘Show Warnings’ -> 
‘Show Empty Edit Area Warning’ to 
unselect the option.  MB1 click ‘GFE’ -> 
‘Show Warnings’ -> ‘Show Edit Action 
Time Range Warning’ to unselect the 
option. 

The Show Empty Edit Area 
Warning and Show Edit Action 
Time Range Warning lines are not 
checked. 

 

26. 

MB1 click on a T grid in the GM. Then 
MB1 drag over several T grids in the GM 
to select them. Include the grid that was 
just clicked upon. Select the Sample Tool 

 from the toolbar and MB1 click at 
several points on the displayed grid. Note 
the data values and the appearance of the 
grid. Clear any existing edit area using the 

 toolbar button. MB1 click ‘Edit’ -> 
‘ExProc1’.   

The grid and Spatial Editor are set 
up for the next step. 
The data selected in the GM is 
modified by running the Adjust_Up 
smart tool followed by the Smooth 
tool. 

 

27. Save all forecast data using the  toolbar 
button. 

The forecast is saved.  
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Action Result Pass/Fail

28. 

MB1 click ‘Verify’ -> ‘ExProc2’. From 
the ExProc2 Values dialog, select one of 
the GFS80 or NAM12 models. Then MB1 
click ‘Run/Dismiss’.  

Several T grids are created from 
scratch as shown by the S indicator 
in the GM and the green locks in 
the GM. Elements T, Wind, and Wx 
are copied from the selected model 
into the Fcst database, as shown by 
the model name (or abbreviation) in 
the GM and additional green locks 
in the GM. Another dialog is 
displayed labeled ExSS4 Values. 

 

29. 

Choose one of the NAM12 models from 
the ExSS4 Values Dialog and press Ok.  

The ExSS4 smart tool is executed 
which makes a numerical sounding, 
and then calculates the T based on 
the model sounding data and the 
topography. Some of the T grids 
which were created from scratch in 
step #10 will now show an ‘m’ for 
modified due to the smart tool 
execution. 

 

30. Save all forecast data using the toolbar 
button. 

  

CheckTandTd Procedure 

31. Select a MinT grid.   The MinT grid displays in the 
Spatial Editor. 

 

32. 
MB1 click ‘20’ on the colorbar.  Then 
MB3 click and hold within the Spatial 
Editor and select ‘Assign Value’. 

The value of the MinT grid is set to 
20. 

 

33. Select the next available MaxT grid.   The MaxT grid displays in the 
Spatial Editor. 

 

34. 
MB1 click ‘1’ on the colorbar.  Then MB3 
click and hold within the Spatial Editor 
and select ‘Assign Value’. 

The value of the MaxT grid is set to 
1. 

 

35. Select ‘Consistency’ -> ’CheckTandTd’ 
from the main menu. 

The Title Values window opens.  

36. Leave the radio button on ‘check only’.  
MB1 click the ‘OK’ button. 

The Title Values window closes.  

37. 
Confirm that a new grid, 
‘MaxLessThanMin’, has been added to the 
grid manager. 

Verified.  

38. 

Verify the time range matches the time 
range of the MaxT grid.  Verify it has a 
value of 0 everywhere except within the 
site edit area where MaxT was less than 
MinT. 

Verified.  
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Step Action Result Pass/Fail

39. Select a MaxT grid.   The MaxT grid displays in the 
Spatial Editor. 

 

40. 
MB1 click ‘1’ on the colorbar.  Then MB3 
click and hold within the Spatial Editor 
and select ‘Assign Value’. 

The value of the MaxT grid is set to 
1. 

 

41. Select the next available MinT grid (create 
one from scratch if one does not exist).   

The MinT grid displays in the 
Spatial Editor 

 

42. 
MB1 click ‘20’ on the colorbar.  Then 
MB3 click and hold within the Spatial 
Editor and select ‘Assign Value’. 

The value of the MinT grid is set to 
20. 

 

43. Select ‘Consistency’ -> ‘CheckTandTd’ 
from the main menu. 

The Title Values window opens.  

44. Leave the radio button on ‘check only’.  
MB1 click the ‘OK’ button. 

The Title Values window closes.  

45. 
Confirm that a new grid, 
‘MinGreaterThanMax’, has been added to 
the grid manager. 

Verified.  

46. 

Verify the time range matches the time 
range of the MinT grid.  Verify it has a 
value of 0 everywhere except within the 
site edit area where MinT was greater than 
MaxT 

Verified.  

47. 
Generate a T grid that where its 
temperature value is less than MinT for a 
time range overlapping MinT grid. 

The T grid has a value less than that 
in the MinT grid. 

 

48. Run the ‘CheckTandTd’ procedure in 
‘check only’ mode. 

A ‘TLessThanMin’ grid is produced 
for the same time range as T.  

 

49. 
Generate a T grid that where its 
temperature value is greater than MaxT for 
a time range overlapping MaxT grid. 

The T grid has a value greater than 
that in the MaxT grid. 

 

50. 
Run the ‘CheckTandTd’ procedure in 
‘check only’ mode. 

A ‘TGreaterThanMax’ grid is 
produced for the same time range as 
T.  

 

51. 
Generate a Td grid that where its 
temperature value is greater than the 
corresponding T grid. 

The Td grid has a value greater than 
the corresponding T grid. 

 

52. 
Run the ‘CheckTandTd’ procedure in 
‘check only’ mode. 

A ‘TdGreaterThanT’ grid is 
produced for the same time range as 
T.  

 

53. 
Generate a T grid that where its 
temperature value is less than MinT for a 
time range overlapping MinT grid. 

The T grid has a value less than that 
in the MinT grid. 

 

54. Run the ‘CheckTandTd’ procedure in 
‘force’ mode. 

The T grid becomes equal to the 
MinT grid within the site edit area 
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Step Action Result Pass/Fail
where the values are ‘upside-down’. 

55. 
Generate a T grid that where its 
temperature value is greater than MaxT for 
a time range overlapping MaxT grid. 

The T grid has a value greater than 
that in the MaxT grid. 

 

56. 
Run the ‘CheckTandTd’ procedure in 
‘force’ mode. 

The T grid becomes equal to the 
MaxT grid within the site edit area 
where the values are ‘upside-down’. 

 

57. 
Generate a Td grid that where its 
temperature value is greater than the 
corresponding T grid. 

The Td grid has a value greater than 
the corresponding T grid. 

 

58. 
Run the ‘CheckTandTd’ procedure in 
‘force’ mode. 

The Td grid becomes equal to the T 
grid within the site edit area where 
the values are ‘upside-down’. 

 

CheckTTdWind Procedure 

59. Select a Wind grid.   The Wind grid displays in the 
Spatial Editor. 

 

60. 

MB1 click ‘3640’ (360 degrees direction – 
40kts wind speed) on the colorbar.  Then 
MB3 click and hold within the Spatial 
Editor and select ‘Assign Value’. 

The value of the Wind grid is set to 
40. 

 

61. 
Modify a WindGust grid for an 
overlapping time range and location with a 
wind speed of 39kts or lower. 

The WindGust grid contains values 
less than or equal to 39kts. 

 

62. 

Run the ‘CheckTTdWind’ procedure in 
‘check only’ mode.  Confirm that the 
appropriate ‘WindGreaterThanGust’ grid 
is created for the ‘check only’ mode. 

Verified.  

63. 

With the Wind grid contining wind speeds 
greater than the corresponding WindGust 
grid, run the ‘CheckTTdWind’ procedure 
in ‘force’ mode. 

The WindGust grid becomes equal 
to the Wind grid within the site edit 
area where the values are ‘upside-
down’. 

 

PlotSPCWatches Procedure 

64. 

Obtain a Severe Thunderstorm or Tornado 
Watch as issued by the Storm Prediction 
Center that includes counties that fall in 
the OAX WFO's area. 

A Watch is available.  

65. 

Modify the watch's start and end time to be 
a time in the near future (within the next 
24 hours or so).  Do this by changing the 
times on all of the VTEC lines  
(e.g., 081016T2230Z translates to 2008-
10-16 at 2230Z). 
See Figure 5-1 on page 20 for a SPC 
Watch example.   

The watch is modified accordingly.  
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Step Action Result Pass/Fail
(Note: This example may be used when 
copied and pasted into a separate 
document and the shaded regions updated 
with the appropriate time and date.) 

66. 

Ingest the watch product by copying the 
Watch text product from the SPC into 
EDEX's sbn/warning directory.   
(Refer to the Warning Ingest Instructions 
document for instructions on how to ingest 
products into the sbn/warning directory.) 
Watch Guardian for a notification message 
that a watch was received from the SPC.   

The watch is ingested.  

67. In the GFE perspective, select ‘Hazards’ -
> ‘PlotSPCWatches’. 

The PlotSPCWatches procedure 
runs. 

 

68. Once it's complete, verify a new hazards 
grid appears in the Hazards parm. 

Verified.  

69. 

Select that hazards grid to view it.  Verify 
the hazard matches the type of watch, has 
the watch number as issued by the SPC 
and covers the correct counties. 

Verified.  

70. Save the hazards grids. The hazards grids are saved.  
QPF_SnowAmt Procedure 

71. 

Ensure there are valid grids for a single 
range of time with the following 
requirements: 
-Temperature grids with values < 32F 
-Wind grids are available 
-QPF grids with values > 0 
-Freezing Level grids with values < 2000ft 

The grids are available.  

72. Create scratch grids for SnowAmt. SnowAmt grids are created.  

73. 

Highlight a range of SnowAmt and QPF 
grids. 
Then MB1 click ‘Edit’ -> 
‘QPF_SnowAmt’. 

A range of SnowAmt and QPF 
grids are highlighted. 
The Title Values dialog opens. 

 

74. 
Set the Vertical Motion Influence to any 
value and MB1 click the ‘OK’ button. 

The Title Values dialog closes.  The 
QPF and SnowAmt grids modify 
accordingly. 

 

75. MB1 click the Save button to save all 
modified grids. 

All modified grids are saved.  

Smart Tools 

76. 

MB1 click on a QPF grid with some non-
zero QPF values that also has a 
corresponding Wind grid.  MB3 popup 
over the main area of the Spatial Editor 

A Title Values dialog appears. 
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Step Action Result Pass/Fail
(SE) and select ‘QPF_SmartTool’.  

77. 

Set the Vertical Motion Influence to the 
maximum value and MB1 click ‘OK’.  

The grid indicator in the GM turns 
cyan to indicate that grid is being 
calculated. The progress bar in the 
status bar moves from left to right 
as the grid points are calculated. 
After the calculation is finished, the 
QPF field is modified based on 
upslope/downslope conditions 
derived from the wind and 
topography. 

 

78. 
MB1 click on the first T grid that 
corresponds to the time for the edited QPF 
grid.  

The T grid is selected for the same 
time period as the edited QPF grid. 

 

79. MB1 click between 20 and 30 on the 
colorbar to set the pickup value.  

The value is set in the colorbar.  

80. 
MB3 popup over the same T grid in the 
GM and select ‘Assign xxx’, where xxx is 
your pickup value.   

The T grid in the Spatial Editor 
updates to the selected temperature 
value. 

 

81. 

MB1 click on the corresponding (valid for 
the same time) FzLevel grid. MB1 click on 
the color bar on a value that represents the 
elevation that is below most of your 
terrain.  

The FzLevel grid is selected for the 
same time period as the edited QPF 
and T grids. 

 

82. 
MB3 popup over the same FzLevel grid in 
the GM and select ‘Assign xxx’, where 
xxx is your pickup value.  

The FzLevel grid in the Spatial 
Editor updates to the selected value. 

 

83. 

MB1 click on the corresponding SnowAmt 
grid. MB3 popup over the main area of the 
SE and select ‘SnowAmt_SmartTool’.   

The SnowAmt data is changed 
based on the QPF, T, and FzLevel 
values. (You might need to use 
MB3 popup over the color bar and 
select ‘Fit To Data’ -> ‘Single Grid’ 
to see the detail.) 

 

84. 

Load the FireWx weather element group 
MB1 clicking ‘WeatherElement’ -> 
‘Weather Element Groups’ -> ‘FireWx’. 
Answer ‘Save First’ to the Modified 
Weather Element(s) dialog that is 
displayed.  

The modified data is saved and the 
FireWx elements are loaded. 
 

 

85. 

Bring up the Weather Element Browser 
MB1 clicking ‘WeatherElement’ -> 
‘Weather Element Browser’. Select ‘T’ 
from the Field pull-down and MB1 click 
‘Load and Dismiss’.  

T is added to the GFE.  
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Action Result Pass/Fail

86. MB1 click ‘GFE’ -> ‘Editing Preferences’ 
-> ‘Missing Data Mode’ -> ‘Create’. 

  

87. 
MB1 click on a MixHgt grid in the GM. 
MB3 popup over the main area of the SE 
and select ‘MixHgt_Init’.  

The MixHgt_Init Values dialog 
displays. 
 

 

88. 
Choose one of the previous NAM12 
models that are presented in the dialog and 
MB1 click ‘Run/Dismiss’.  

The mixing height grid is 
calculated. 

 

89. 

Revert your modified grids by selecting 
‘Edit’ -> ‘Revert Forecast’. Load the 
Public weather element group MB1 
clicking ‘WeatherElement’ -> ‘Weather 
Element Groups’ -> ‘Public’.  

Modified data is discarded and the 
public weather elements are 
displayed. 
 

 

90. 

MB1 click on the same SnowAmt grid as 
in step #17. Bring up the Edit Actions 

Dialog window using the  toolbar 
button.  Select ‘ExTool1’.  

The SnowAmt grid is modified to 
contain 10*QPF. 
 

 

91. 
Select ‘ExTool2’.  The SnowAmt grid is modified 

again, this time determined by T 
and QPF.  

 

92. 

Select ‘ExTool3’. The ExTool3 Values 
dialog appears. Enter a snow level 
corresponding to the topography in your 
area. MB1 click ‘Run/Dismiss’.  

The SnowAmt grid is modified 
again. 
 

 

93. 

MB1 click on a QPF grid in the GM that 
contains some QPF values. Select ‘ExSS1’ 
from the Edit Actions Dialog window.  

The QPF values are recalculated 
based on the existing QPF data and 
the QPF data from the NAM12 
model. 

 

94. 

Select ‘ExSS2’ from the Edit Actions 
dialog. The ExSS2 Values dialog displays. 
Select one of the models that generate 
QPF, but not NAM12.  

The QPF values are recalculated. 
Areas where 0 QPF existed on the 
grid, but the model has QPF values 
are replaced with the model's QPF 
values. 

 

95. 

MB1 click on a T grid that corresponds to 
00z or 12z. Select ‘ExSS4’ from the Edit 
Actions dialog. Select one of the NAM12 
models and MB1 click ‘Run/Dismiss’.  

A numerical sounding is calculated 
and the T determined from the 
model data. 

 

96. 

MB1 click on another T grid that 
corresponds to 00z or 12z. Select ‘ExSS5’ 
from the Edit Actions dialog. Select a 
different model (e.g., GFS80) and MB1 
click ‘Run/Dismiss’.  

A numerical sounding is calculated 
and T is determined from the model 
data. 
 

 

97. MB1 click on a T grid that has a 
corresponding Td grid. Select ‘ExSS6’ 

A new weather element is created 
with the name of TempRH and the 
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Action Result Pass/Fail
from the Edit Actions dialog.  model name of TempModel. It 

appears near the bottom of the GM. 
It contains the calculated RH from 
the T and Td grids. 

98. 

MB1 click on a Wx grid in the GM that 
has a corresponding PoP grid. The PoP 
grid should have a range of values from 0 
through 100%. Select ‘ExSS7’ from the 
Edit Actions dialog. 

The Wx grid is modified based on 
the PoP.  
 

 

99. 

MB1 click on a PoP grid that has a 
corresponding Wx grid. The Wx grid 
should have some areas of <NoWx>, Chc 
RW-, Sct RW-, and Wide R. Select 
‘ExSS8’ from the Edit Actions dialog.  

The PoP grid is modified based on 
the Wx. 

 

100

Click on a T grid. Select ‘ExUtil1’ from 
the Edit Actions dialog. The ExUtil1 
Values dialog displays. Select one of the 
NAM12 models and MB1 click 
‘Run/Dismiss’.  

The T grid is recalculated and on 
the terminal window where GFE 
was run, a statement of ‘Using 
Utility Version of convertFtToM’ 
displays. 

 

101
Save all forecast data by MB1 clicking the 

 toolbar button. 

The forecast data is saved.  

102

MB1 click on a T grid in the GM that 
corresponds to a grid within the ‘Tonight’ 
period as displayed in the time scale. 

Select the Sample Tool  from the 
toolbar. MB1 click on several samples; 
some within the ISC_OAX edit area, and 
some outside. 

The T grid displays. 
The Samples display within and 
outside of the ISC_OAX edit area. 

DR 
#1364 

103

From a terminal window, and from the 
GFESuite ‘bin’ directory, issue the 
following command: 
runProcedure -n ExProc1 -d 
xxx_GRID__Fcst_00000000_0000 -u 
GFETEST -c gfeConfig -a 
ISC_Send_Area -t Tonight 
where xxx is your siteID. 

T grids that overlap the Tonight 
period will be modified. The T data 
will be increased by 1 degree and 
then smoothed, within the 
ISC_Send_Area. 

 

New Smart Tool 

104
Bring up the Edit Actions Dialog using 

the   toolbar button. 

The Edit Action dialog box opens.  

105

MB3 popup over the Edit Actions Dialog 
window and select ‘New’.  On the dialog 
that will be displayed, ensure that 
‘Numeric’ is selected on the radio buttons 

The Python editor 
window/perspective appears 
containing the smart tool template. 
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Action Result Pass/Fail
(at the bottom). Enter ‘TEST001’ for the 
tool name at the top. Select ‘T’ as the 
weather element to edit.  MB1 click ‘OK’. 

106

Replace the execute() function in the 
template with the following code, leaving 
the rest of the template alone:  
    def execute(self, T):  
        ‘Increment T’  
        # Determine new value  
        T = T + 5  
        # Return the new value  
        return T 

The code is modified.  

107

On the Python editor window, MB1 click 
‘File’ -> ‘Save’.  MB1 click the ‘X’ on the 
Python Editor window.  Then close the 
Python perspective. 

The edited code is saved.  

108
MB1 click the Draw Edit Area tool  
icon. Draw a closed area using MB1 drag 
on the displayed grid. 

An enclosed area appears on the 
GFE display. 

 

109
MB1 click on the ‘TEST001’ entry in the 
Edit Actions dialog.  

The smart tool is executed and the 
data values increase incrementally 
by 5.0. 

 

110

MB1 drag across several T grids in the 
GM to select them. MB1 click on the 
‘TEST001’ entry in the Edit Actions 
Dialog window. 

The smart tool is executed and the 
data values increase incrementally 
by 5.0 in each of the grids.  

 

111
MB3 popup over the Edit Actions Dialog 
window entry of TEST001 and select 
‘Modify’.  

The Python editor window pops up, 
containing the smart tool template. 

 

112

Replace the execute() function in the 
template with the following code, leaving 
the rest of the template alone:  
    def execute(self, T, Td):  
        ‘Assign T to Td+10’  
        # Determine new value  
        T = Td + 10  
        # Return the new value  
        return T 

The code is modified.  

113

On the Python editor window, MB1 click 
‘File’ -> ‘Save’.  MB1 click the ‘X’ for the 
Python Editor window.  Then close the 
Python perspective. 

The edited code is saved.  

114 Using the Draw Edit Area tool  icon, An enclosed area appears on the 
GFE display. 
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Step Action Result Pass/Fail
draw a closed area using MB1 drag on the 
displayed grid. 

115

MB1 click on a T grid in the GM to make 
the T grid visible and editable. The T grid 
selected must have a corresponding Td 
grid (i.e., valid at the same time). If not, 
create from scratch a Td grid at the same 
time and then MB1 click again on the T 
grid. 

The T grid is visible and in edit 
mode. 
If necessary, a Td grid is created. 

 

116
MB1 click on the ‘TEST001’ entry in the 
Edit Actions Dialog window.  

The smart tool is executed and the 
data values are set to 10 degrees 
above the corresponding Td field. 

 

117

MB3 popup over the TEST001 entry on 
the Edit Actions Dialog window and MB1 
click ‘Delete’.  Select ‘OK’ in the Item 
Delete dialog to remove the ‘TEST001’ 
smart tool. 
Verify the ‘TEST001’ smart tool entry is 
removed from the Edit Actions dialog. 

The TEST001 entry is removed 
from the Edit Actions dialog 
window.  

 

118 Exit GFE. GFE closes.  
End of test. 
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5.0 TO9 REQUIREMENTS VERIFICATION TRACEABILITY MATRIX (RVTM) 

Number Description Test Step(s) 

SYSR2071 

The AWIPS system shall implement the GFE Smart Tool Widgets 
(create a set of GUI widgets that are accessible from a Smart Tool 
script). 

ALL 

SYSR2072 The AWIPS system shall implement the GFE Smart Tool Interface. ALL 

SYSR2100 
The AWIPS system shall implement the Smart Init Interface to 
enable initializing from model data. 

1 

SYSR2102 
The AWIPS system shall implement the Smart Tool Interface with 
a library of functions for use by smart tools 

15 

SYSR2118 
The AWIPS GFESuite shall implement the GFE Smart Tools and 
Procedures. 

ALL 

SYSR2491 
The AWIPS GFESuite shall implement ifpServerText - Smart 
Tools. 

ALL 

SYSR2597 
The AWIPS GFESuite shall implement Create, Modify, and Delete 
smart tools to modify scalar weather elements. 

104-118 

SYSR2601 

The AWIPS GFESuite shall implement Create, Modify, and Delete 
a Procedure that consists of tools that modify the same weather 
element. 

 

SYSR2602 

The AWIPS GFESuite shall implement Create, Modify, and Delete 
a Procedure that consists of tools that modify various weather 
elements. 
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Table 5-1. SPC Tornado Watch to be used for the PlotSPCWatches procedure.  The shaded areas require times 
or dates that should be updated. 
 
WOUS64 KWNS 031635 
WOU9 
    
BULLETIN - IMMEDIATE BROADCAST REQUESTED 
TORNADO WATCH OUTLINE UPDATE FOR WT 439 
NWS STORM PREDICTION CENTER NORMAN OK 
1035 AM CDT TUE FEB 03 2009 
 
TORNADO WATCH 439 IS IN EFFECT UNTIL 500 PM CDT FOR THE 
FOLLOWING LOCATIONS 
    
IAC001-003-009-029-071-077-085-129-137-145-155-159-165-173-175- 
032300- 
/O.NEW.KWNS.TO.A.0439.090203T1700Z-090203T2300Z/ 
 
IA  
.    IOWA COUNTIES INCLUDED ARE 
    
ADAIR                ADAMS               AUDUBON              
CASS                 FREMONT             GUTHRIE              
HARRISON             MILLS               MONTGOMERY           
PAGE                 POTTAWATTAMIE       RINGGOLD             
SHELBY               TAYLOR              UNION                
 
 
KSC013-043-117-131-032300- 
/O.NEW.KWNS.TO.A.0439.090203T1700Z-090203T2300Z/ 
 
KS  
.    KANSAS COUNTIES INCLUDED ARE 
 
BROWN                DONIPHAN            MARSHALL             
NEMAHA                
 
 
MOC003-005-025-063-075-087-147-227-032300- 
/O.NEW.KWNS.TO.A.0439.090203T1700Z-090203T2300Z/ 
 
MO  
.    MISSOURI COUNTIES INCLUDED ARE 
    
ANDREW               ATCHISON            CALDWELL             
DEKALB               GENTRY              HOLT                 
NODAWAY              WORTH                
    
    
NEC025-055-067-097-109-127-131-133-147-153-032300- 
/O.NEW.KWNS.TO.A.0439.090203T1700Z-090203T2300Z/ 
    
NE  
.    NEBRASKA COUNTIES INCLUDED ARE 
    



Test Case Smart Tools (ac009)       DCN AWP.TE.SWCTR/T010-0027 
 

Contract DG133W-05-CQ-1067 / DCN AWP.TE.SWCTR/TO10-0027 / 6 Feb. 2009 21 
Use or disclosure of data contained on this sheet is subject to the restriction on the title page of this document. 

HARD COPY UNCONTROLLED 

CASS                 DOUGLAS             GAGE                 
JOHNSON              LANCASTER           NEMAHA               
OTOE                 PAWNEE              RICHARDSON           
SARPY                 
 
 
ATTN...WFO...DMX...OAX...EAX...TOP... 
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