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Test Case #: Baseline_TextDB_OB8.1
Test Case Description: This test case demonstrates the capability of AWIPS to recall and display text products, and to allow for the editing and transmission of those products.  This test case also demonstrates the capability of AWIPS to update and alarm products on the text workstation, and to allow the user to write text scripts and TAF/TWEB products.

Requirements:
AWIPS shall provide the capability to distribute data among AWIPS sites.

AWIPS shall provide the user with the capability to specify Point-to-Point distribution control parameters.

AWIPS shall have the capability to automatically generate the following routine forecast products from information contained in the forecaster-prepared digital database:

(l)
Transcribed Weather Broadcast (TWEB)

(m)
Terminal Aerodrome Forecast (TAF)

Prior to full implementation of the digital database capabilities, AWIPS shall be able to format the TAF by extracting the data from station-specific forecast guidance products.

AWIPS shall provide a “fixed-format” capability to aid in the generation of products whose structure requires specific and rigidly controlled user input.  This fixed-format capability will allow a user to create, modify, and store “fill-in-the-blank” forms, and use these forms to generate and modify products.

AWIPS shall provide the capability to retrieve data stored locally.
 AWIPS shall provide the capability to enter and modify data stored at the site.

AWIPS shall provide the user the capability to specify retrieval criteria.  The retrieval criteria include any combination of:

(a)
time

(e)
location (site, sensor, geographic area)

(f)
product

(g)
source (product, task)

(h)
forecaster identifier

AWIPS shall provide the capability to store the types of data defined in Appendix F and Section 3.1.4.3.1.

AWIPS shall provide the capability to store and retrieve hydrometeorological data. Hydrometeorological data include the following types of data:

(a)
Guidance Products

(c)
Radar Data

(d)
Observational Data

(e)
Local Area Data

(f)
Official User Products

AWIPS shall provide the capability to automatically detect and log the following system events:

(f)
Receipt of Specified Data

(h)
Performance Parameters

AWIPS shall provide the user the capability to define actions to be taken upon detection of a system event.

AWIPS shall retain all data stored and under edit at the time of system shutdown.

AWIPS shall automatically monitor observations, forecasts, and guidance data, and notify the user when detection criteria are met.

AWIPS shall also provide the user the capability to define and modify detection criteria.

AWIPS shall provide the capability for the user to simultaneously display up to at least 8 data windows on each workstation’s monitor.

AWIPS shall provide the capability to display text in data windows on any workstation monitor.

AWIPS shall provide the capability for the user to display the previous and next versions of displayed products stored locally.

AWIPS shall (9) provide the capability for the user to move any data window.
AWIPS shall  provide the capability for the user to resize any data window.

AWIPS shall  provide the capability for the user to display the date and time of day on each workstation monitor.

AWIPS shall provide the capability for the user to replace a displayed product with another product of the same type.

AWIPS shall provide the capability for the user to automatically update displayed data products with newly received product versions.

AWIPS shall provide the following capabilities for the user to manipulate displayed text:

(a)
Change the character size and font

(b)
Move text from one window to another

(c)
Copy text from one window to another

(d)
Page through text

(e)
Scroll through text

(f)
Move to the beginning of text

(g)
Move to the end of text

(h)
Append text

(I)
Highlight text

AWIPS shall provide the capability for the user to edit displayed text on any workstation monitor.

AWIPS shall provide an automatic text backup and recovery capability such that backed up text can be recovered at any workstation.

AWIPS shall provide the capability for the user to create and save a sequence of interactions, called a user-defined procedure.

AWIPS shall provide the capability for the user to modify a user-defined procedure.

AWIPS shall provide the capability for the user to single step through the execution of a user-defined procedure.

AWIPS shall require all users to provide a valid user name and password to log on to the system.

Data Input: N/A
Prerequisite Conditions:  The general prerequisite conditions for testing apply to this test case.  In addition, this test case requires the following:

·
The text workstation must be at the login prompt window
·
The text workstation Beep sound must be turned on

·
D2D must be up on one of the graphics display monitors
	Step #
	Action / Inputs
	Expected Outputs
	Pass(P)/Fail(F)
Pending(Pen)
	DR#, Name and Description for failed step
	Special Needs /
Comments

	1. 
	Login to a Linux workstation as an AWIPS user. Click and hold the left mouse button on the desktop background. Select AWIPS start-up menu, select D2D.
	D2D GUI opens.
	
	
	

	2. 
	Log into the text workstation. 


	A Text Workstation Control window, a Monitoring Controller window, and a Text 1 window open.  The current date and time (local and Universal Time Coordinated [UTC]) appear in the Text Workstation Control window and the Monitoring Controller window.
	
	
	

	3. 
	From the Windows menu, select New
 Window.


	A new Text 5 bar appears in the Text Workstation Control window.
	
	
	

	4. 
	Select New Window three more times
 so that there are eight text windows 
listed in the Text Workstation Control
 window.
	Window selected
	
	
	

	5. 
	From the Windows menu, select Show
 All.
	Eight text windows are opened on the display.
	
	
	

	6. 
	From the Windows menu, select Hide
 All.
	All eight windows are closed.


	
	
	

	7. 
	From the Text Workstation Control 
window, select Text 1.
	The Text 1 window opens.
	
	
	

	8. 
	Select the AFOS Browser button in
 the Text 1 window.
	The Text 1 AFOS Browser window opens.
	
	
	

	9. 
	From the Origin:  menu of the Text 1
 AFOS Browser window, select East. 

(Already on East)
	The selections in the Node section change accordingly.
	
	
	

	10. 
	In the Node section of the Text 1 
AFOS Browser window, select WBC
	WBC becomes highlighted.  Selections appear in the Ctgry section.  WBC appears in the AFOS Cmd:  command line in the Text 1 window.
	
	
	

	11. 
	 In the Ctgry section, select ZFP.


	ZFP becomes highlighted and is added in the AFOS Cmd:  command line in the Text 1 window.  Selections appear in the Designator and DISPLAY sections.
	
	
	

	12. 
	In the Designator section, select LWX
 (site ID for Baltimore, 
MD/Washington, DC WFO).


	 LWX and its associated time become highlighted, and the word ALL:  appears in the DISPLAY section.  LWX is also added in the AFOS Cmd:  command line in the Text 1 window.
	
	
	

	13. 
	 Select Load and Continue in the Text
 1 AFOS Browser window
	The selected product is displayed in the Text 1 window.  The product name appears in the Text 1 window title.
	
	
	

	14. 
	Press and hold mouse button 1 in the
 title bar of the Text 1 AFOS Browser.
  Move the cursor to the top of the 
screen, and release the button.
	 The Text 1 AFOS Browser window moves with the cursor to a new location at the top of the screen, uncovering the Text 1 window.
	
	
	

	15. 
	Move the cursor to the bottom edge of 
the Text 1 AFOS Browser window.


	The cursor changes shape, indicating that it is ready to resize the window.
	
	
	

	16. 
	Press and hold mouse button 1, move
 the cursor downward, and release 
mouse button 1.


	The Text 1 AFOS Browser window increases in size to the location where mouse button 1 was released.
	
	
	

	17. 
	In the Text 1 AFOS Browser window,
 in the DISPLAY section, select ALL:.
	The word ALL:  becomes highlighted and is added along with the product name to the AFOS Cmd:  command line in the Text 1 window.
	
	
	

	18. 
	Select Load and Close.


	The Text 1 AFOS Browser window closes, and all versions of the selected product that are in the database appear in the Text 1 window, replacing the previously displayed product in the window.  The most recent available version of the product is displayed first.  The product name appears in the Text 1 window title.
	
	
	

	19. 
	Use the vertical scroll bar on the right
 side of the Text 1 window to scroll 
through the text in the window.
	Vertical scroll bar used
	
	
	

	20. 
	Press mouse button 1 anywhere in the
 Text 1 window.
	The window is now active.


	
	
	

	21. 
	Press the <Page Down> key on the
 keyboard
	 The next page of the text appears.
	
	
	

	22. 
	Press the <Page Up> key on the
 keyboard.
	The previous page of the text appears.
	
	
	

	23. 
	Press the <End> key on the keyboard.
	The end of the text appears
	
	
	

	24. 
	 Press the <Home> key on the 
keyboard.
	The beginning of the text appears.
	
	
	

	25. 
	In the Text 1 window, type:  
PITMTRPIT on the AFOS Cmd:  
command line, and press <Return>.


	The latest version of that product replaces the previously displayed text in the Text 1 window.  The product name appears in the Text 1 window title.
	
	
	

	26. 
	In the Text 1 window, toggle on the
 Accum radio button.
	Toggled on
	
	
	

	27. 
	From the Version menu in the Text 
1 window, select Previous.


	The previous version of the product, relative to the product version already displayed, is displayed appended to the text in the Text 1 window.  A ‑1 appears as part of the Text 1 window title.
	
	
	

	28. 
	Select Next from the Version menu.


	The next version of the product relative to the version just displayed is displayed appended to the text.  The ‑1 in the Text 1 window title disappears.  This product should be the same as the first product displayed two steps ago.
	
	
	

	29. 
	Select Latest from the Version menu.


	The latest version of the product available in the database is displayed appended to the text.  This should be the same product as displayed in the previous step.
	
	
	

	30. 
	Select All from the Version menu.


	All versions of the product available in the database appear in the Text 1 window.  The word ALL:  appears as part of the Text 1 window title.
	
	
	

	31. 
	Select Clear in the Text 1 window.
	The Text 1 window clears
	
	
	

	32. 
	Toggle off the Accum radio button.
	Toggled off
	
	
	

	33. 
	Type:  FWCDCA on the AFOS Cmd:  command line and press <Return>.
	The NGM MOS product is displayed in the Text 1 window, and the product title appears as part of the Text 1 window title.
	
	
	

	34. 
	Type:  FRH62 on the AFOS Cmd: 
 command line and press <Return>.


	The NAM model product replaces the previously displayed product in the Text 1 window, and the product title appears as part of the Text 1 window title.
	
	
	

	35. 
	From the Options menu, select Font 
Size.  In the cascading menu, select 
Large
	 The size of the text in the Text 1 window increases, and the Text 1 window resizes to accommodate the larger type.
	
	
	

	36. 
	Select Medium from the Font size
 menu.


	The text is restored to its original size, with the Text 1 window resizing accordingly.
	
	
	

	37. 
	Select Clear in the Text 1 window.
	The Text 1 window clears.
	
	
	

	38. 
	In the Text 1 window, select the Enter
 Editor button.


	The Text 1 window becomes divided into a header section and a text section.  A Header Block window also opens.
	
	
	

	39. 
	In the Header Block window, type: 
 WBC in the WSFO ID command line.
	Text typed
	
	
	

	40. 
	Type:  ZFP in the Product Category 
command line.
	Text typed
	
	
	

	41. 
	Type:  LWX in the Product 
Designator command line.
	Text typed
	
	
	

	42. 
	Type:  TBDR in the Addressee 
command line.
	Text typed
	
	
	

	43. 
	Select Enter.


	The Header Block window closes, and the header information for the product you are about to compose appears in the header section of the Text 1 window.  The text section of the window is blank and ready for composition. 
	
	
	

	44. 
	Type the words 
“TEST....TEST....TEST....TEST” in 
the window.
	The words “TEST....TEST....TEST....TEST” appear in the Text 1 window.
	
	
	

	45. 
	Select Send from the editor toolbar.


	The product is saved and transmitted to TBDR.
	
	
	

	46. 
	In the AFOS Cmd:  command line on 
the Text 1 window, type:  
WBCZFPLWX and press <Return>
	The product just edited is displayed in the Text 1 window, and the product name becomes part of the Text 1 window title
	
	
	

	47. 
	In the AFOS Cmd:  command line on
 the Text 1 window, type:  
WBCZFPAKQ and press <Return>.


	The product is displayed in the Text 1 window, and the product name becomes part of the Text 1 window title.
	
	
	

	48. 
	Select the Enter Editor button.
	The Text 1 window is split into two sections, a header section and a text section.  A Header Block window also opens.
	
	
	

	49. 
	Select Enter in the Header Block 
window.


	The Header Block window closes, and the header information for the current product appears in the header section of the Text 1 window.
	
	
	

	50. 
	In the Text Workstation Control 
window, select Text 2.
	A Text 2 window opens.


	
	
	

	51. 
	Select the Enter Editor button.


	The Text 2 window is split into two sections, a header section and a text section.  A Header Block window also opens.


	
	
	

	52. 
	In the Header Block window, type:  
FPUS65 in the TTAAii command line.
	Text typed
	
	
	

	53. 
	Type:  KBOU in the CCCC command

line.
	An AFOS ID Selection window is displayed
	
	
	

	54. 
	Select ‘DENSFPCO’ from the list and select the ‘Close’ button.
	Selected
	
	
	

	55. 
	Type:  TBW3 for the Addressee.
	Text typed
	
	
	

	56. 
	Select Enter.


	The Header Block window closes, and the header information for the current product appears in the header section of the Text 2 window.
	
	
	

	57. 
	In the text section of the Text 1 
window, press and hold mouse button 
1, and move the cursor down a section
 of the text.
	That section of text becomes highlighted.
	
	
	

	58. 
	 Press and hold mouse button 3 for a 
pop-up menu, and select Cut.
	The highlighted section of text is erased.
	
	
	

	59. 
	Select the Paste button from the 
toolbar in the Text 2 window.


	The section of text cut from the Text 1 window appears in the Text 2 window.
	
	
	

	60. 
	 In the Text 1 window, highlight 
some text.
	Highlited
	
	
	

	61. 
	From the Edit menu of the Text 1 
window, choose Select, and To end of
 Product from the submenu.
	The amount of text that is highlighted expands to the end of the product.
	
	
	

	62. 
	From the Edit menu, choose Select and To previous word.


	The amount of text that is highlighted decreases to the previous word.


	
	
	

	63. 
	 Select the Copy button.
	Selected
	
	
	

	64. 
	Select the Paste button from the 
toolbar in the Text 2 window.


	The section of text copied from the Text 1 window appears appended to the text in the Text 2 window.  Add “TEST....TEST....TEST....TEST” to the text 2 window.
	
	
	

	65. 
	In the Text 2 window, select Save 
from the editor toolbar.
	The product is saved locally.


	
	
	

	66. 
	Turn off the power to the text 
workstation central processing unit 
(CPU).
	The text workstation shuts down.


	
	
	

	67. 
	Wait 10 seconds, and then turn the 
power back on.
	The text workstation boots up.  The process is complete when the login prompt screen is displayed.
	
	
	

	68. 
	Log into the text workstation.
	A Text Workstation Control window, a Monitoring Controller window, and a Text 1 window open. 
	
	
	

	69. 
	From the File menu in the Text 1 
window, select Recover Edit Session.
	An Edit Session Recovery window opens.
	
	
	

	70. 
	Select the session that was active 
when the power was turned off.
	The listing becomes highlighted.

(take note of this ahead of time!!!)
	
	
	

	71. 
	Select Recover.


	The edit session that was in progress when the power was turned off is restored in the Text 1 window.
	
	
	

	72. 
	Select the Cancel button.
	The edit session ends
	
	
	

	73. 
	 Move to the D2D display monitors
  From the Tools menu, select Text 
window.
	 A Text 1 window opens.
	
	
	

	74. 
	In the AFOS Cmd:  command line 
type:  SFOFTMDAX, and press 
<Return>.
	The radar free text message is displayed in the Text 1 window.  The product name is erased from the AFOS Cmd:  command line and appears in the Text 1 window title.
	
	
	

	75. 
	Select Alarm/Alert from the Text 
Workstation Control window.


	A Current Alarm Queue window opens, showing any alarmed products that are currently in the queue.
	
	
	

	76. 
	Select Product List.


	An Alarm/Alert and Proximity Alarm Products window opens, showing all products currently set to alarm the system upon arrival.
	
	
	

	77. 
	Select New AA Entry.


	A New Alarm/Alert Product window opens.
	
	
	

	78. 
	In the Product ID:  command line, 
type:  WBCMTRIAD.
	Text typed
	
	
	

	79. 
	Toggle on the Alarm radio button next
 to the command line.


	Toggled on
	
	
	

	80. 
	Select OK.


	The New Alarm/Alert Product window closes.  The selected product is listed in the Alarm/Alert Products window, with the word Alarm in parentheses next to the product name.
	
	
	

	81. 
	Select New AA Entry.


	A New Alarm/Alert Product window opens.
	
	
	

	82. 
	In the Product ID:  command line, 
type:  WBCZFPLWX.
	Text typed
	
	
	

	83. 
	In the Optional Search String 
command line, type the name of the 
day four days from now.
	Text typed
	
	
	

	84. 
	 Select OK.


	The New Alarm/Alert Product window closes.  The selected product is listed in the Alarm/Alert Products window, followed by the phrase “containing ‘<name of the day four days from now>’.”
	
	
	

	85. 
	Select Save & Close under the File 
menu.


	The current list of products is saved, and the Alarm/Alert Products window closes.  An Alarm/Alert bell icon should appear within one hour of the current time.  This will be verified later in the test.
	
	
	

	86. 
	Select the Text 4 button from the Text 
Workstation Control window.
	The Text 4 window opens.


	
	
	

	87. 
	Type:  WBCMTRDCA in the AFOS 
Cmd:  command line, and then press 
<Return>.
	The most recent METAR data appear for DCA.  Note the product time
	
	
	

	88. 
	 Toggle on the Update Obs radio 
button.


	Within one hour, new METAR data should replace that displayed in the Text 4 window.  This will be verified later in the test case.
	
	
	

	89. 
	Select Clear in the Text 1 window.
	The Text 1 window clears
	
	
	

	90. 
	 From the Scripts menu, select Edit.


	The Text 1 Script Editor window opens.
	
	
	

	91. 
	Type the following lines into the 
window to create an example of a 
script:  

clear;
accum on;

load wbcafdlwx;

wait;

load miamtrmia;

wait;

load pitccfpbz;
	Text typed
	
	
	

	92. 
	From the File menu in the Text 1 
Script Editor window, select Save As.
	A Save Script As window opens.


	
	
	

	93. 
	In the Filename:  command line, 
move the cursor to the end of the path 
name and press the <Backspace> key 
once.
	The period at the end of the path name is erased.


	
	
	

	94. 
	Type the name testscript at the end of 
the path.
	Text typed
	
	
	

	95. 
	Select OK.


	The script is saved under that pathname.  The Save Script As window closes.  The name testscript appears as part of the Text 1 Script Editor window title.
	
	
	

	96. 
	From the File menu in the Text 1 
Script Editor window, select Close.
	The Text 1 Script Editor window closes.
	
	
	

	97. 
	From the Scripts menu in the Text 1 
window, select Run.
	The Run Script File window opens.
	
	
	

	98. 
	  In the Files section, select testscript.


	The name testscript becomes highlighted, and the pathname updates in the Filename:  command line.
	
	
	

	99. 
	Select OK.


	The Run Script File window

closes, and the script begins 
running.  Each product is 
displayed and is appended at the
 bottom of the window, waiting 
each time for the tester to select
 the Continue button before 
loading the next product.  A 
status message at the bottom of 
the window indicates the current 
stage of the script.
	
	
	

	100. 
	From the Scripts menu in the Text 1
 window, select Edit.
	The Text 1 Script Editor window opens.
	
	
	

	101. 
	 From the File menu in the Text 1 
Script Editor window, select Open.
	The Open Script File window opens.
	
	
	

	102. 
	 Select the file testscript by double-
clicking it with mouse button 1.


	The Open Script File window closes.  The testscript script appears in the Text 1 Script Editor window, and the name testscript appears as part of the Text 1 Script Editor window title.
	
	
	

	103. 
	Add the following lines to the end 

Of the script:

wait;
load wbcrwrakg;
	Lines added
	
	
	

	104. 
	From the File menu, select Save.


	The script is updated with the changes.
	
	
	

	105. 
	From the Execute menu, select Run.


	The script begins running.  Each product is displayed and is appended at the bottom of the window, waiting each time for the tester to select the Continue button before loading the next product.  A status message at the bottom of the window indicates the current stage of the script.
	
	
	Cannot select run??

	106. 
	Select Clear in the Text 1 window.
	The Text 1 window clears.
	
	
	

	107. 
	Toggle off the Accum radio button.


	Toggled off
	
	
	

	108. 
	From the File menu in the Text 1
 Script Editor window, select Close.
	Text 1 Script Editor window closes.
	
	
	

	109. 
	Select Text Window 3 from the Text 
Workstation Control Window.
	The Text 3 window opens.


	
	
	

	110. 
	In the AFOS ID:  command line, type:
  WBCRWRLWX and select <Enter>.


	The latest version of that product is displayed in the Text 3 window.  Note that there is a UGC code at the top of the product, e.g., VAZ042.  This code will be used later to set up a new proximity alarm.  Keep this window open for use later.


	
	
	

	111. 
	 Select Alarm/Alert from the Text 
Workstation Control Window.


	A Current Alarm Queue window opens, showing any alarmed products that are currently in the queue.
	
	
	

	112. 
	  Select Product List.


	An Alarm/Alert and Proximity Alarm Products window opens, showing all products currently set to alarm the system upon arrival
	
	
	

	113. 
	  Select New PA Entry.


	A New Alarm/Alert Proximity Alarm Product window opens.
	
	
	

	114. 
	In the Product ID:, type:  
WBCRWRLWX.  Select Alarm in the
 Alarm/Alert option menu.  Refer back
 to the open Text 3 window with the 
current WBCRWRLWX product 
displayed and the current UGC code 
included in the product.  Back on New

 Proximity Alarm Product Window, 

for the UGC List:, type a UGC code 
that is listed in the WBCRWRLWX
 product in the Text 3 window.
	The tester is creating an alarm for that UGC in the current WBCSWRVA product.


	
	
	UGC format error window for ASUS41, try MAC013

	115. 
	Select OK.


	The New Proximity window closes.  The new proximity alarm is listed at the bottom of the Alarm/Alert and Proximity Alarm Products window
	
	
	

	116. 
	  Select Save and Close at the bottom of the window.


	The current list of proximity alarms, including the new alarm, is saved and the Alarm/Alert Products window closes.
	
	
	

	117. 
	Return to the Text 3 window.  To 
activate the alarm, a new 
WBCRWRLWX product must be 
sent.  Select Enter Editor.
	The Text 3 window becomes divided into a header section and a text section.  A Header Block window also opens.
	
	
	

	118. 
	In the Header Block window, verify
 WBC is in the WSFO ID command 
line, RWR is in the Product Category 
command line, and LWX in the 
Product Designator command line.
	Verified
	
	
	

	119. 
	Type:  000 in the Addressee command
 line.
	Text typed
	
	
	

	120. 
	Select Enter.
	The Header Block window closes.
	
	
	

	121. 
	Change the time in the product to a 
few minutes ahead of the current time.
  Add 
“TEST....TEST....TEST....TEST” to 
the top of the product, then select 
Send.
	The WBCRWRLWX product is saved.  Select Go Ahead to any window message that opens.  A flashing alarm bell starts blinking in the upper left corner of the text workstation screen
	
	
	

	122. 
	Press mouse button 1 over that 
flashing bell.
	The flashing bell disappears.  A Current Alarm Queue window opens, showing the product currently in the queue.
	
	
	

	123. 
	 Select the product.


	An Alarm Display Window opens.  The WBCRWRLWX product selected to alarm the system appears.
	
	
	

	124. 
	Close all Alarm/Alert-related 
windows.
	Windows closed
	
	
	

	125. 
	When a flashing alarm bell starts 
blinking in the upper left corner of the 
text workstation screen, press mouse 
button 1 over that flashing bell.
	The flashing bell disappears.  A Current Alarm Queue window opens, showing the product currently in the queue.
	
	
	

	126. 
	 Select the product.


	An Alarm Display Window opens.  The WBCMTRIAD product selected to alarm the system appears.
	
	
	

	127. 
	Press mouse button 1 over the tab in 
the upper left corner of the window.
	A pull‑down menu appears.


	
	
	

	128. 
	 Select Close from the menu.


	Both the Alarm Display Window and the Current Alarm Queue window close.
	
	
	

	129. 
	View Text Window 4 after the hourly 
METAR arrives.


	A newer version of the WBCMTR product has automatically replaced the previous version of the product.  The station ID is highlighted in black when the product has been updated.
	
	
	

	130. 
	When a flashing alarm bell starts 
blinking again in the upper left corner
 of the text workstation screen, press 
mouse button 1 over that flashing bell 
(it may take several hours for the 
WBCZFPLWX product to come in).
	The flashing bell disappears.  A Current Alarm Queue window opens, showing the product currently in the queue.


	
	
	

	131. 
	Select the product.


	An Alarm Display Window opens.  The WBCZFPLWX product selected to alarm the system appears.
	
	
	

	132. 
	Exit application
	This concludes the test case
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