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1.0 Scope

See Software Test Plan.

2.0 APPLICABLE DOCUMENTS

2.1 Source Documents

· None

2.2 Reference Documents

· Legacy NWS GFE Acceptance Test Case ID Number: ac001.
· Legacy NWS GFE Test Cases for Test Areas AC – VP.
· Section 3.1.3 of the AWIPS D-2D User’s Manual Build 8.1.
· Software Test Plan for the Advanced Weather Information Processing System Project, Contract #DG133W-05-CQ-1067, August 2008.
· The Silver Spring NWS AWIPS 1 test bed application.
· Release OB8.1 and OB8.2 of the Weather Event Simulator (WES).
3.0 Test Case description
This test case exercises and demonstrates the capabilities of the GFE menus.

3.1 Assumptions, Constraints and Preconditions

· IFP Server running

· TO9 software has been installed successfully
· CAVE, EDEX and pgAdmin III are running
· Data has been ingested 

· Actions, Results, and Requirements highlighted in yellow indicate requirements and/or capabilities to be included in the scope of future task orders. They are included here for purposes of continuity and traceability with the original AWIPS I test case documents. 
3.2 Recommended Hardware

See Software Test Plan.

3.3 Test Inputs

Section 4.0 below contains the test procedures for this test case. Sections 2.2 – 2.9 of the Software Test Plan contain general test inputs applicable to all TO9 test cases. 
3.4 Test Outputs

The basic GFE menus will be displayed and the results outlined in section 4.0 are met. The GFE GUIs to be tested include:
· Open Perspective

· Weather Element Browser
· Copy All Grids From

· Save Weather Element
· Save Sample Set
· Load Sample Set
· Delete Sample Set
· Item Delete

· Define Samples by Latitude/Longitude
· Publish
· Formatter Launcher
· Product Scripts

· Revert Forecast

· Interpolation

· Create From Scratch
· Time Shift
· Copy Selected Grids From

· Save Weather Element(s)
· Modified Weather Elements

· Delete Weather Element Group
· Weather Element Group

· Save Select Time Range
· Time Scale Displayed Periods
· Delete Select Time Range

· Edit Area Appearance
· Vector Pick Up Value
· Scalar Pick Up Value
· Discrete Pick Up Value
· Weather Pick Up Value
· Auto Save Interval
· Set Interpolation Algorithm
4.0 TEST SCENARIO

	Step
	Action
	Result
	Pass/Fail

	1. 
	In CAVE, Mouse Button (MB) 1 click on the Perspectives icon [image: image1.jpg]


 and select ‘Other’.
	The Open Perspective dialog appears.
	

	2. 
	MB1 click ‘GFE’. Then MB1 click ‘OK’.
	The Open Perspective dialog closes.

The GFE Perspective loads in CAVE.
	

	3. 
	MB1 click ‘Weather Element’ -> ‘Weather Element Browser…’ to bring up the Weather Element Browser dialog.

Turn most of the elements off, keeping at least the T, Td, Wx, Hazards, and Wind fields selected. MB1 click ‘Load and Dismiss’ to load just those elements. 
	The Weather Element Browser dialog opens. 
The Weather Element Browser dialog closes. Only the user-selected weather elements remain in the GFE.
	

	4. 
	Close the Weather Element Browser.

Select ‘Populate’ -> ‘Copy All Grids From…’ to populate grids in the GFE. From the Copy All Grids From dialog, select the latest model run of an available model, then MB1 click ‘OK’. 
	The Weather Element Browser closes.

The Copy All Grids From dialog opens. 
The Copy All Grids From dialog closes. The selected models grids are populated into the Grid Manager. Green locks appear in the Grid Manager and grids from the model are loaded into the Grid Manager. Note: The Hazards grids will not be populated, since none of the model smart initializations produce them.
	

	5. 
	MB1 click the [image: image2.png]


 toolbar button to save the grids. In the Save Forecast dialog, select ‘Save Forecast’ with all weather elements selected. 

Note: Do not select the ‘Send Intersite Grids’ check box.
	The Save Forecast dialog appears.

The Save Forecast dialog closes. The locks are released as shown by the green areas on the Grid Manager reverting back to the default gray. The grids are saved.
	

	6. 
	MB1 click on a grid in the Grid Manager.  
	The grid is displayed as an image in the Spatial Editor. The Spatial Editor legend indicates that the grid is visible (white) and is marked for edit. The Grid Manager indicates that the grid is marked for edit and displayed (yellow block).
	

	EDIT Areas
	

	7. 
	Select an edit area from the Edit Areas menu.  
	That edit area is displayed in the spatial editor as a hatched, gray outline.
	

	8. 
	Examine the Edit Areas menu. Verify that there are subcategories of Counties, FIPS, FIPS_OAX, FireWxAOR, FireWxZones, FireWxZones_OAX, ISC, MZones, States, WFOs, Zones, Zones_OAX, and Misc. Check each of these menus and verify that the entries displayed are reasonable. Call up at least one edit area from each of the menus. Note that Misc. may not have any entries, nor will the Mzones (marine zones) have entries for sites that don't have a marine responsibility.  
	Verifies.
	

	9. 
	MB1 click ‘Verify’ -> ‘Daily Forecast Critique’.  
	The daily forecast critique program displays. Exit the daily forecast critique program.
	

	Maps

	10. 
	Toggle on topography by MB1 clicking ‘Maps’ -> ‘Topography’. 
	The topography image displays in the Spatial Editor and the topography product ID in the spatial editor legend is white. The previous image in the spatial editor is displayed as a graphic. ‘Topography’ is added to the spatial editor legend. The spatial editor legend for the previous image is no longer white, and is color-coded to match the graphic color.
	

	11. 
	Toggle off topography by MB1 clicking ‘Maps’ -> ‘Topography’. 
	The topography image is removed from the Spatial Editor. ‘Topography’ is removed from the spatial editor legend. The data displayed as a graphic continues to be displayed as a graphic.
	

	12. 
	MB1 click on the original grid which is highlighted in yellow in the Grid Manager. 
	The original grid, originally displayed as a graphic, is displayed as an image. The spatial editor legend for the grid is white to indicate that it represents an image.
	

	13. 
	From the Maps menu, MB1 click on or off several of the map backgrounds. 
	The spatial editor map backgrounds change in accordance to the menu.
	

	14. 
	MB1 click on the sample tool [image: image3.png]


 in the toolbar. MB1 click on several locations within the displayed image and outside of the image. 
	Sample displays are shown with the data and Lat/Lon values for those locations within the displayed grid. ‘<NoData>’ and Lat/Lon values display for locations outside of the grid.
	

	15. 
	MB1 click ‘Maps’ -> ‘Samples’ -> ‘Save’ to invoke the Save Sample Set dialog. Enter a name that does not already appear in the list box. MB1 click ‘Save’.
	The Save Sample Set dialog is dismissed. The Sample locations are saved.
	

	16. 
	MB1 click ‘Maps’ -> ‘Samples’ -> ‘Clear’ to erase the anchored samples on the spatial editor. 
	The samples are removed from the spatial editor.
	

	17. 
	MB1 click ‘Maps’ -> ‘Samples’ -> ‘Load’ to invoke the Load Sample Set dialog. Once the dialog appears, select the name under which you previously stored the sample set, then MB1 click ‘Replace’. 
	The Load Sample Set dialog is dismissed and the sample points previously displayed are displayed again.


	

	18. 
	MB1 click on the spatial editor legend that represents the grid displayed in the spatial editor. 
	The grid is toggled off, the legend indicates that the grid is toggled off (the grid takes on a gray appearance in the Grid Manager), and the sample points show a ‘+’ sign with Lat/Lon values.
	

	19. 
	MB1 click on the spatial editor legend that was previously clicked MB1. 
	The grid is toggled on, the legend indicates that the grid is visible (it takes on a white appearance), and the sample points show the data values.
	

	20. 
	MB1 click ‘Maps’ -> ‘Samples’ -> ‘Delete’ to bring up the Delete Sample Set dialog. Select the entry created and used in step #15 and #17. MB1 click ‘Delete’. MB1 click ‘OK’ in the Sample Set Deleted window. The Item Delete dialog displays with a Confirm Delete notice. MB1 click ‘Delete’ in the Item Delete dialog.
	The Delete Sample Set, Sample Set Deleted, and Item Delete dialogs are dismissed, and the sample points remain on the screen.
	

	21. 
	MB1 click ‘Maps’ -> ‘Samples’ -> ‘Delete…’ and verify the deleted Sample Set is not present.
	The deleted Sample Set is not present.
	

	22. 
	Toggle on the Lat/Lon values by MB1 clicking ‘Maps’ -> ‘Samples’ -> ‘Show Lat/Lon’. 
	The samples in the spatial editor display the 
Lat/Lon of the data point.
	

	23. 
	MB1 click ‘Maps’ -> ‘Samples’ -> ‘Define by Lat/Lon’.  In the Define Samples by Lat/Lon, enter an appropriate latitude/longitude into the text boxes and MB1 click ‘Set’. 
	The Define Samples by Lat/Lon dialog is presented. 
The new sample point is added to the display at the specified latitude/longitude.
	

	24. 
	MB1 click ‘Dismiss’ in the Define Samples by Lat/Lon dialog to close the dialog.  
	The Define Samples by Lat/Lon dialog is dismissed.
	

	25. 
	MB2 click on another weather element grid in the Grid Manager, a grid that intersects the current spatial editor time as shown by the yellow line.  
	Two sample values are shown along with the latitude/longitude on each sample point. The colors of the samples match that of the graphics (white for the image).
	

	26. 
	MB1 click ‘Maps’ -> ‘Samples’ -> ‘Clear’ to erase all samples on the spatial editor. 
	The samples are removed.
	

	Products

	27. 
	MB1 click ‘Products’ -> ‘Publish to Official’.  
	The Publish dialog is displayed. ‘All Grids’ is highlighted in the Time Period section, and the list of weather elements that are loaded into the GFE appear in the ‘Weather Elements’ section.
	

	28. 
	MB1 click ‘Publish’.
	If no one has any locks, the grids are published, the Publish dialog is dismissed. A green message is shown in the status bar of the GFE.
	

	29. 
	MB1 click ‘Products’ -> ‘Formatter Launcher…’. 
	The Formatter Launcher dialog displays. Note: Depending upon your configuration, you may or may not have any products listed.
	

	30. 
	Close the Formatter Launcher dialog.
	The Formatter Launcher dialog closes.
	

	31. 
	MB1 click ‘Products’ -> ‘Scripts’.

Highlight ‘Png Images...’, then MB1 click on ‘Run/Dismiss’.  
	The Product Scripts dialog displays.

Another dialog displays. Press ‘OK’ to dismiss that dialog.
	

	32. 
	Select ‘Consistency’ from the menu. 
	An ISC_Discrepancies procedure is listed, along with other items.
	

	Edit
	

	33. 
	MB1 click on the color bar to pick up a value. MB1 click ‘Edit Areas’ -> ‘ISC’ -> ‘ISC_OAX’. MB3 popup over the main area of the spatial editor and release MB3 on ‘Assign_Value’.
	The ISC area becomes hatched. The data points within the ISC_OAX modify to the selected value.
	

	34. 
	MB1 click ‘Edit’ -> ‘Undo Grid Edit’.  
	The change made in #32 is undone. 
	

	35. 
	MB1 click ‘Edit’ -> ‘Undo Grid Edit’. 
	The change made in #32 is redone.
	

	36. 
	MB1 click ‘Edit’ -> ‘Undo Edit Area’.  
	The edit area changes to the previous edit area (which was empty). The hatched area is removed from the display.
	

	37. 
	MB1 click ‘Edit’ -> ‘Save Forecast’. 
	The Save Forecast dialog displays.
	

	38. 
	MB1 click ‘Cancel’ within the Save Forecast dialog. 
	The Save Forecast dialog is dismissed. The data is not saved (as shown by the green lock still present in the Grid Manager).
	

	39. 
	MB1 click ‘Edit’ -> ‘Revert Forecast’. 
	The Revert Forecast dialog displays.
	

	40. 
	Select the desired parameters to revert. Then MB1 click ‘Revert Forecast’ within the dialog. 
	The Revert Forecast dialog is dismissed. The data is restored to that when it was last saved. The green lock in the Grid Manager is no longer shown.
	

	Grids

	41. 
	MB1 drag across several grids in the Grid Manager that contain data. 
	A blue hatched area appears indicating that the time period has been selected.
	

	42. 
	MB1 click ‘Grids’ -> ‘Interpolate...’.   In the Interpolation dialog, select ‘Based on Edited Data’ and MB1 click ‘OK’.  
	The Interpolation dialog opens.

The Interpolation dialog closes. Interpolated data blocks, indicated by an ‘I’, are created in the blue hatched area.
	

	43. 
	Use the left arrow, and right arrow keys on the keyboard to step through the grids.
	The new grids are displayed with each step, the yellow line updates in the Grid Manager to show which grid is displayed. The yellow block in the Grid Manager indicates the grid that is displayed.
	

	44. 
	MB2 drag on one of the grids in the Grid Manager and extend the drag to the right for several hours. 
	The grid's valid time is expanded to the right.
	

	45. 
	MB1 click on the ‘long’ grid that was stretched in step #44. 
	The selection time range, indicated by the blue hatching, matches the length of the grid.
	

	46. 
	MB1 drag on the time scale to select just a portion of the ‘yellow’ grid created in step #44. 
MB1 click ‘Grids’ -> ‘Split Grids’.

	The selection time range, indicated by the blue hatched area, occupies just a portion of the grid as shown
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The yellow grid in the Grid Manager splits into three, along with ends of the selection time range as shown
[image: image5.jpg]



	

	47. 
	MB1 click on a grid in the Grid Manager that takes up more than one shadow block, as shown, such that the grid is longer than the minimum grid length.
	Grid is longer that the minimum grid length.
[image: image6.jpg]N\





	

	48. 
	MB1 click ‘Grids’ -> ‘Fragment Grids’. 
	The ‘yellow’ grid is divided into the smallest time periods possible, as shown
[image: image7.jpg]



	

	49. 
	MB1 drag over an area containing grids and shadow blocks in the Grid Manager.  MB1 click ‘Grids’ -> ‘Create Grids From Scratch’.  With the default value selected, MB1 click ‘OK’ on the Create From Scratch dialog.  
	All existing grids are removed reverting to a gray grid. All shadow blocks are replaced with grids that are created from scratch. An ‘S’ appears within each grid block indicating that it was created from scratch.
	

	50. 
	MB1 click on one of the ‘S’ grids created in step #49. MB1 click on the Sample Tool [image: image8.png]


 icon. MB1 drag over the spatial editor. 
	A roaming sample is displayed and the data values are the weather element's minimum allowable value (for scalars), calm (for vectors), ‘<NoWx>’ (for weather), or the first defined type of the discrete weather element (for discrete elements).
	

	51. 
	MB1 drag over an area containing grids in the Grid Manager. 
	The selection time range is shown in blue stripes.
	

	52. 
	MB1 click on the color bar to pick up a value. MB1 click ‘Grids’ -> ‘Assign Pickup Value’.
	All of the grids within the time range are set to the pick up value.
	

	53. 
	MB1 click ‘Grids’ -> ‘Assign Default Value’.  
	All of the grids within the selected time range are set to the default value. The default value is typically the weather element's minimum allowable value (for scalars), calm (for vectors), ‘<NoWx>’ (for weather), or the first defined type of the discrete weather element (for discrete elements).
	

	54. 
	MB1 click ‘Grids’ -> ‘Delete Grids’.  
	All of the grids within the selected time range are deleted.
	

	55. 
	MB1 click ‘Grids’ -> ‘Select Grids by Time’ -> ‘Today’. 
	The selection time range changes to the defined Today period, as shown in the time scale.
	

	56. 
	MB1 click ‘Grids’ -> ‘Select All Weather Elements’.  
	Blue hatching appears on all of the weather elements for the ‘Today’ period, and the selection on/off box at the left of each Grid Manager pane now indicates on.
	

	57. 
	MB1 click ‘Grids’ -> ‘Deselect All’. 
	All blue hatching disappears since all weather elements and times have been deselected.
	

	58. 
	MB1 click on a grid in the Grid Manager. MB1 click ‘Grids’ -> ‘Time Shift...’ to bring up the Time Shift dialog. Set the slider to +24 hours, MB1 click ‘Move’. Then MB1 click ‘OK’.
	The Time Shift dialog opens.

The modifications to the Time Shift dialog are saved.

The Time Shift dialog closes.

The grid no longer appears in the same location, and has been moved forward in time 24 hours.
	

	59. 
	MB1 click ‘Grids’ -> ‘Find Weather Element’ -> <yourchoice>.  
	The Grid Manager scrolls to that weather element.
	

	60. 
	MB1 click on a T grid in the Grid Manager. MB1 click ‘Grids’ -> ‘Select Grids By Time’ -> ‘Hour 0 – 240’. MB1 click ‘Populate’ -> ‘Copy Selected Grids From...’ to bring up the Copy Selected Grids From dialog. Select the latest version of an available model. Then MB1 click ‘OK’.  
	All existing grids within the selected time period are removed, and new grids replace those grids with the chosen model.
	

	WeatherElement

	61. 
	Bring up the weather element browser by MB1 clicking on ‘WeatherElement’ -> ‘Weather Element Browser’.  MB1 click ‘D2D’, select a Source from the Source pull-down menu, select a Field from the Field pull-down menu, and select a level from the Pres or Misc pull-down menus.
	The Weather Element Browser dialog displays. 

The Source, Field and Level fields are populated.
	

	62. 
	On the weather element browser, save the selection as a weather element group by MB1 clicking ‘File’ -> ‘Save Weather Element Group’. In the Save Weather Element Group dialog, enter ‘ABC’ in the entry field and MB1 click ‘Save’.  
	The Save Weather Element Group dialog appears. 
The Save Weather Element Group dialog is dismissed.
	

	63. 
	On the weather element browser, MB1 click on ‘Edit’ -> ‘Select None’. Select ‘Prac’ for types, ‘Fcst’ for Source, ‘Weather’ for Field, and ‘SFC’ for Misc. MB1 click ‘Load and Dismiss’.  A Modified Weather Elements dialog is displayed. MB1 click ‘Discard Edits’.  
	The dialog is dismissed, only the Wx weather element remains.
	

	64. 
	MB1 click ‘WeatherElement’ -> ‘Weather Element Groups’ -> ‘ABC’ to load the weather element group.
	The original set of elements loaded near the beginning of the test case, plus the D2D entry specified in step #61 are loaded.
	

	65. 
	Bring up the weather element browser by MB1 clicking ‘WeatherElement’ -> ‘Weather Element Browser’. Then MB1 click ‘Edit’ -> ‘Select None’. Then select ‘File’ -> ‘Load Weather Element Group’ -> ‘Marine’. 
	The marine weather elements are displayed in the Weather Element Browser dialog. 
	

	66. 
	On the weather element browser, select ‘File’ -> ‘Load Weather Element Group’ -> ‘ABC’.
	The definition of the ‘ABC’ weather element group is added to the existing weather element list.
	

	67. 
	On the weather element browser, MB1 click ‘File’ -> ‘Delete Weather Element Group’. Select ‘ABC’ and MB1 click ‘Delete’. The Item Delete confirmation dialog appears. MB1 click ‘Delete’. Then dismiss the Weather Element Browser dialog. 
	The Delete Weather Element Group dialog appears. 
The Delete Weather Element Group and Item Delete dialogs close.
The Weather Element Group dialog is dismissed.
	

	68. 
	Confirm that ABC is deleted by MB1 clicking ‘File’ -> ‘Load Weather Element Group’. Ensure that there is no longer an ‘ABC’ entry. Then close the Weather Element Group dialog.
	The ‘ABC’ entry does not exist.

The Weather Element Group dialog closes.
	

	69. 
	MB1 click ‘GFE’ -> ‘Define Time Ranges’ -> ‘Save Select Time Range...’ to bring up the Save Select Time Range dialog. Enter ‘ABC’ in the identifier and select a start hour and stop hour (at least 24 hours apart). MB1 click ‘OK’. 
	The Save Select Time Range dialog is dismissed.
	

	70. 
	MB1 click ‘GFE’ -> ‘Viewing Preferences’ -> ‘Time Scale Periods...’ to bring up the Time Scale Displayed Periods dialog. Note that ‘ABC’ is listed as an option. Turn on ‘ABC’ and off all other options.  MB1 click ‘OK’.  
	The time scale contains only the markers for the ABC time range (above the date).
	

	71. 
	MB1 click ‘GFE’ -> ‘Define Time Ranges’ -> ‘Delete Select Time Range...’ to bring up the Delete Select Time Range dialog. Select ‘ABC’ on the dialog and MB1 click on ‘Delete’. The Item Delete confirmation dialog appears. MB1 click ‘Delete’.
	The Delete Select Time Range and Item Delete dialogs are dismissed. The ABC indication in the time scale is removed.
	

	72. 
	Repeat step 71 and verify ‘ABC’ is not available.
	‘ABC’ is not available.
	

	73. 
	This step is to ensure the check boxes are selected/activated. If already activated, skip this step.

Turn on the Warnings:

MB1 click ‘GFE’ -> ‘Show Warnings’ -> ‘Show Empty Edit Area Warning’. MB1 click ‘GFE’ -> ‘Show Warnings’ -> ‘Show Edit Action Time Range Warning’. 
	The Warnings check boxes are activated.
	

	74. 
	Clear any edit area with the toolbar button. MB1 click on a T grid, then MB1 drag a time range on the Grid Manager containing the ‘clicked’ upon grid, but over a longer duration.  MB3 popup over the spatial editor and select ‘Assign_Value’.
	The Time Range Warning and Empty Edit Area Warning boxes will appear (one at a time), after specifying Yes, the data is edited.
	

	75. 
	Turn off the Warnings:

MB1 click ‘GFE’ -> ‘Show Warnings’ -> ‘Show Empty Edit Area Warning’.  Then MB1 click ‘GFE’ -> ‘Show Warnings’ -> ‘Show Edit Action Time Range Warning’.  MB1 click on a T grid, then MB1 drag a time range on the Grid Manager containing the ‘clicked’ upon grid, but over a longer duration. MB1 click on the color bar to pick up a different value from before. MB3 popup over the spatial editor and select ‘Assign_Value’.  
	No warning dialogs are displayed and the data is edited.
	

	76. 
	MB1 click ‘GFE’ -> ‘Viewing Preferences’ -> ‘Quick View Mode’.  Move the mouse over different grids in the Grid Manager. 
	When the mouse pointer is over a grid, that grid appears in the spatial editor, as an image, with a single spatial editor legend. When the mouse pointer is not over a grid, the original grid appears in the spatial editor, if it was previously selected (e.g., MB1 click over a valid grid in the GM), with the original set of spatial editor legends.
	

	77. 
	MB1 click ‘GFE’ -> ‘Viewing Preferences’ -> ‘Quick View Mode’.
	Quick View Mode is cleared.
	

	78. 
	MB1 click ‘GFE’ -> ‘Viewing Preferences’ -> ‘Image on Edit’. Then MB1 click on a grid from a different weather element than is currently being shown in the spatial editor. 
	That grid is displayed as a graphic in the Grid Manager and not as an image.   The spatial editor legend indicates that grid is marked for edit, and the color of the spatial editor legend matches the graphic color of the grid.
	

	79. 
	MB1 click ‘GFE’ -> ‘Viewing Preferences’ -> ‘Image on Edit’. Then MB1 click on a grid from a different weather element than is currently being shown in the spatial editor. 
	Image on Edit viewing preference displays.
	

	80. 
	MB1 click ‘Edit Areas’ -> ‘ISC’ -> ‘ISC_OAX’. Then MB1 click ‘GFE’ -> ‘Viewing Preferences’ -> ‘Edit Area Appearance’. The Edit Area Appearance dialog appears. Change the line width and the hue, saturation, and brightness sliders. Then select ‘Apply’.  
	The edit area appears in the Spatial Editor.

The edit area becomes the specified color and the Edit Area Appearance dialog remains on the screen.
	

	81. 
	Change the colors again from the Edit Area Appearance dialog. MB1 click on ‘Apply’ and verify that the edit area appearance has changed. MB1 click ‘Cancel’ from the dialog.
	The edit area reverts back to the original color (prior to step #77).
	

	82. 
	MB1 click on a Wind grid in the Grid Manager. MB3 popup over the color bar and select ‘Set Pickup Value’.  
	The Vector Pick Up Value dialog is displayed.
	

	83. 
	MB1 click ‘GFE’ -> ‘Editing Preferences’ -> ‘Vector Editor Mode’ -> ‘Magnitude Only’.  Set the value in the Vector Pick Up Value dialog using the direction entry field to 9 (followed by the return key) and the magnitude to 25 (followed by the return key). MB1 click ‘Assign Value’.  
Then Dismiss the Set Pickup Value dialog.
	The data within the ISC_OAX is edited, but only the magnitude component is changed, i.e., all winds are not from the East.
The Set Pickup Value dialog closes.
	

	84. 
	MB1 click on another Wind grid in the Grid Manager. Select another edit area from the Edit Areas menu. MB1 click ‘GFE’ -> ‘Editing Preferences’ -> ‘Vector Editor Mode’ -> ‘Direction Only’.  MB3 popup over the color bar and select ‘Set Pickup Value’. MB1 click ‘Assign Value’ within the Vector Pick Up Value dialog.  
Then Dismiss the Set Pickup Value dialog.
	The data within the specified edit area is edited, but only the direction component is changed, i.e., all winds are not set to 25kts.
The Set Pickup Value dialog closes.
	

	85. 
	MB1 click on another Wind grid in the Grid Manager. Select another edit area from the Edit Areas menu. MB1 click ‘GFE’ -> ‘Editing Preferences’ -> ‘Vector Editor Mode’ -> ‘Both’.  MB1 click ‘Assign Value’ within the Vector Pick Up Value dialog.  
Then Dismiss the Set Pickup Value dialog.
	The data within the specified edit area is edited and set to 25kts from the East.
The Set Pickup Value dialog closes.
	

	86. 
	MB1 click on a scalar grid, such as T in the Grid Manager. 
Then open the Set Pickup Value dialog.
	The Set Pickup Value dialog opens. The Vector Pick Up Value dialog changes to reflect the new weather element and becomes the Scalar Pick Up Value dialog.
	

	87. 
	MB1 click on a discrete grid, such as Hazards in the Grid Manager. 
	The Scalar Pick Up Value dialog changes to the Discrete Pick Up Value dialog.
	

	88. 
	MB1 click on a Wx grid in the Grid Manager. 
	The Scalar Pick Up Value dialog changes to the Weather Pick Up Value dialog.
	

	89. 
	Dismiss the Set Pick Up Value dialog. MB1 click on a Wx grid in the Grid Manager that contains some weather (other than <NoWx>). Using the Select Points Tool on the toolbar, MB1 drag a circle on the spatial editor that includes differing types of weather. MB1 click ‘GFE’ -> ‘Editing Preferences’ -> ‘Wx/Discrete: Combine’. MB3 popup over the color bar and select ‘Set To Common Values’ -> ‘Patchy F’. 
	The data within the edit area is modified, and Patchy F is added to the existing types of weather and no weather.
	

	90. 
	MB1 click ‘GFE’ -> ‘Editing Preferences’ -> ‘Wx/Discrete: Combine’. MB3 popup over the color bar and select ‘Set To Common Values’ -> ‘Sct TRW-’. 
	The data within the edit area is modified all data points within the edit area are set to Sct TRW-.
	

	91. 
	MB1 click on a T grid in the Grid Manager. MB1 click ‘GFE’ -> ‘Editing Preferences’ -> ‘Select Grids When Stepping’. Use the toolbar buttons to step frames. 
	The selection time range remains the same (over the grid clicked upon in this step).
	

	92. 
	MB1 click ‘GFE’ -> ‘Editing Preferences’ -> ‘Select Grids When Stepping’. Use the toolbar buttons to step frames. 
	The selection time range matches the grid that is viewed (i.e., represented by the yellow grid in the Grid Manager).
	

	93. 
	Change the smoothing algorithm by picking a different value then the one that is highlighted in the ‘GFE’ -> ‘Editing Preferences’ -> ‘Smoothing Algorithm’ menu. Bring up the menu again and verify that the current selection now shows the selection made.
	Selected smoothing algorithm appears.
	

	94. 
	Bring up the Auto Save Interval dialog by MB1 clicking ‘GFE’ -> ‘Editing Preferences’ -> ‘Auto Save...’. Enable Auto Save by setting the slider to 1 minute and MB1 click ‘OK’. Wait about a minute. 
	The grids that have been modified and have green locks will be saved one lock at a time, with the result that the green locks will disappear.
	

	95. 
	MB1 click ‘GFE’ -> ‘Editing Preferences’ -> ‘Interpolate Algorithm’. From the Set Interpolation Algorithm dialog, verify that the list of weather elements displayed in the dialog match the scalar weather elements that are currently loaded in the Fcst database. Note: There will not be any Vector, Weather, or Discrete elements in the list. Select a weather element. Then select a different algorithm. MB1 click ‘Dismiss’.  
	Verified, dialog is dismissed
	

	96. 
	MB1 click ‘GFE’ -> ‘Editing Preferences’ -> ‘Interpolate Algorithm’. From up the Set Interpolation Algorithm dialog, select the same weather element in step #92. Verify that the algorithm displayed as selected is the one selected in step #92. Dismiss the dialog.
	Verified, dialog is dismissed.
	

	97. 
	MB3 popup the GFE tab and select ‘Close’.  
	The GFE tab closes.
	

	
	End of test.
	
	


5.0 requirements verification traceability matrix (RVTM)

	Number
	Description
	Test Step(s)

	SYSR2042
	The AWIPS system shall implement the Grid Forecast Editor (GFE) Perspective.
	1-2

	SYSR2043
	The AWIPS system shall implement the GFE Menus.
	ALL

	SYSR2047
	The AWIPS system shall implement the GFE Status Bar.
	28

	SYSR2110
	The AWIPS GFESuite shall implement the Basic GFE Menus.
	ALL

	SYSR2603
	The AWIPS GFESuite shall implement Multiple Grid Warning, Empty Edit Area Warning.
	73-74
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