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1.0 SCOPE 

See Software Test Plan. 
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2.0 APPLICABLE DOCUMENTS 

2.1 Source Documents 
• None 
 

2.2 Reference Documents 
• Legacy NWS GFE Test Case ID Numbers: gh001-gh009 
• Legacy NWS GFE Test Cases for Test Areas AC – VP 
• Section 3.1.3 of the AWIPS D-2D User’s Manual Build 8.1 
• Software Test Plan for the Advanced Weather Information Processing System 

Project, Contract #DG133W-05-CQ-1067, August 2008 
• The Silver Spring NWS AWIPS 1 test bed application 
• Release OB8.1 and OB8.2 of the Weather Event Simulator (WES) 
• Rational RequisitePro 
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3.0 TEST CASE DESCRIPTION 
This test case exercises and demonstrates the capabilities of the GHG Monitor and Make Hazard 
GUI.  This includes the following tests:  

• Prepare the Hazards Data for the GHG Monitor Tests (gh001) 
o Test Objective: This test case demonstrates preparing the hazards data for the GHG 

monitor test. 

• Saving and Loading Configurations of the GHG Monitor (gh002) 
o Test objective:  This test case demonstrates saving and loading configurations of the 

GHG monitor. 

• Using the Display Sector to view both the Map and Text Display Areas (gh003) 
o Test objective:  This test case demonstrates using the display sector to view both the 

map and test display areas. 

• Using the Pane Resizer and Scroll Bars to adjust and resize the Map/Text Display and the 
Spreadsheet Display Areas (gh004) 

o Test Objective: This test case demonstrates using the pane resizer and scroll bars to 
adjust and resize the map/text display and the Spreadsheet Display areas. 

• Using the Zoom Features from the Map Pull-Down Menu on the Map and Text Display Area 
(gh005) 

o Test Objective: This test case demonstrates using the zoom features from the map 
pull-down menu on the Map and Text Display Area. 

• To Display the Different Types of Maps from the Map Pull-Down Menu and Using the Show Label 
Feature on the Map and Text Display Area (gh006) 

o Test Objective: This test case demonstrates the display of different types of maps 
from the Map Pull-Down Menu and using the Show Label Feature on the Map and 
Text Display Area. 

• Using the Map Display Area of the GHG Monitor to Query Hazards based on a Zone (gh007) 
o Test Objective: This test case demonstrates using the Map Display Area of the GHG 

monitor to query hazards based on a zone. 

• Using the Text Display Area of the GHG Monitor (gh008) 
o Test Objective: This test case demonstrates using the Text Display Area of the GHG 

monitor. 

• Using the Spreadsheet Display Area of the GHG Monitor (gh009) 
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o Test Objective: This test case demonstrates using the Spreadsheet Display Area of the GHG 
monitor. 

 

3.1 Assumptions, Constraints and Preconditions 
• TO9 software has been installed successfully 
• CAVE, EDEX and pgAdmin III are running 
• Data has been ingested  
• Actions, Results, and Requirements highlighted in yellow indicate requirements and/or 

capabilities to be included in the scope of future task orders. They are included here for 
purposes of continuity and traceability with the original AWIPS I test case documents.  
Items highlighted in blue are capabilities added and/or Deficiency Reports (DRs) corrected 
since the Delivery Test. 

 

3.2 Recommended Hardware 
See Software Test Plan. 
 

3.3 Test Inputs 
Section 4.0 below contains the test procedures for this test case. Sections 2.2 – 2.9 of the Software 
Test Plan contain general test inputs applicable to all TO9 test cases.  
 

3.4 Test Outputs 
The basic GFE menus will be displayed and the results outlined in section 4.0 are met. The GFE 
GUIs to be tested include: 

• MakeHazard 

• Save Weather Element(s) 

• Formatter Launcher 

• GHG Hazards Monitor 

• GHG Monitor Font Choice Dialog 

• GHG Monitor Color Choice Dialog 

• GHG Monitor Alert Dialog 

• GHG Monitor Filter Dialog 

• Save GHG Display Filter 

• Save Configuration 

• Load Configuration 
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4.0 TEST SCENARIO 

Step Action Result Pass/Fail

Prepare the Hazards Data for the GHG Monitor Tests (gh001) 

1. In CAVE, MB1 click on the Perspectives icon  
and select ‘Other’. 

The Open Perspective dialog appears.  

2. MB1 click ‘GFE’. Then MB1 click ‘OK’. The Open Perspective dialog closes. 
The GFE Perspective loads in CAVE.  

3. From the Main Menu, select ‘Hazards’ -> 
‘MakeHazard’. 

The MakeHazard dialog box appears.  

4. 

From the MakeHazard dialog box, select an 
available hazard from the hazard list. Then drag or 
click MB1 over the adjacent forecast zone map to 
select a forecast zone(s) for the hazard. Adjust the 
forecast start and end times (automatically set an 
hour apart) for the hazard at the column to the 
right. MB1 click ‘Run’ to save the selections.  

The selections are made and saved. The 
MakeHazard dialog remains open. 

 

5. Repeat step 4 to create a second hazard. MB1 click 
‘Run/Dismiss’ to save the selections. 

The selections are made and saved. The 
MakeHazard dialog closes. 

 

6. 
From the Main Menu, MB1 click ‘Hazards’ -> 
‘MergeHazards’ to merge the Hazards on the main 
display. 

The Hazards merge.  

7. 

Close the MakeHazard dialog. 
From the Main Menu, MB1 click the ‘Save 

Forecast’ icon . The Save Forecast dialog box 
appears. MB1 click ‘Save Forecast’ to save 
changes made to the main display. 

The MakeHazard dialog closes.  
The changes are saved. 

 

8. From the Main Menu, select ‘Products’ -> 
‘Formatter Launcher’.  

The Formatter Launcher dialog box appears.  

9. 

From the Formatter Launcher dialog box, select 
‘Products’ -> ‘Hazard’ -> <the Hazard created 
above>. Then MB1 click the ‘Run Formatter’ icon 

 to run the Formatter Launcher. Verify that 
there is a message and that the VTEC code 
displays.  

A message displays in the text area. 
The VTEC code is present. 

 

10. MB1 click the ‘Transmit…’ button.  The Transmit to AWIPS *WAN* dialog 
box appears.  

 

11. MB1 click the ‘Simulated Transmit’ button. This 
process takes approximately 5 seconds. 

The Transmit to AWIPS *WAN* dialog 
box closes.  
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Step Action Result Pass/Fail

12. 

Select the red X at the upper right corner of the 
dialog box. Then MB1 click the ‘Hide’ button at 
the bottom of the dialog box.  
Note: The Hazards data is now ready to be 
displayed on the GHG Monitor.  

The Formatter Launcher dialog closes.  

Saving and Loading Configurations of the GHG Monitor (gh002) 

13. From the GFE menu bar, MB1 click ‘Products’ -> 
‘GHG Monitor…’. 

The GHG Hazards Monitor dialog appears.  

14. 

From the GHG Hazards Monitor menu bar, MB1 
click ‘Columns’. Then select the data fields to be 
displayed in the columns of the Spreadsheet 
Display Area. 

The Spreadsheet Display Area expands or 
contracts as the items are selected or 
deselected. 

 

15. From the Main Menu Bar, MB1 click ‘Filter’ -> 
‘Define Filter…’. 

The GHG Monitor Filter Dialog box 
appears. 

 

16. 
Select the desired filtering method and then select 
Dismiss.   

The Spreadsheet Display Area removes 
lines based on the filter settings. 
The GHG Monitor Filter Dialog box closes. 

 

17. To save the current Filter from the Filter pull-down 
menu, select ‘Save Current Filter…’.  

The Save GHG Display Filter dialog box 
appears.  

 

18. 

To finish saving the Filter, type a name in the space 
provided at the bottom of the Save GHG Display 
Filter dialog box. Then MB1 click the ‘Save’ 
button. 
Note: You can now easily access the saved Filter 
by clicking on the Filter pull-down menu and 
selecting the saved Filter. You can also delete a 
named Filter from the pull-down menu by selecting 
Delete Named Filter. 

The Filter is saved. 
The Save GHG Display Filter dialog box 
closes. 

DR 
#1378 

19. 

 Verify the filter was saved by selecting ‘Filter’ -> 
‘Default Filter’. Then select ‘Filter’ -> ‘Define 
Filter…’ to verify the Default Filter. Select the 
filter from the Filter menu and again select ‘Filter’ -
> ‘Define Filter…’. 

Verifies the Filter is saved.  

20. From the GHG Hazards Monitor menu bar, MB1 
click ‘Alerts’ -> ‘Define Alerts’. 

The GHG Monitor Alert Dialog box 
appears. 

 

21. Select the desired alert times and alert filters. Then 
MB1 click ‘Apply Filter’. 

The Filters are applied. The GHG Monitor 
Alert Dialog box closes. 

 

22. From the GHG Hazards Monitor menu bar, MB1 
click ‘Appearance’ -> ‘Font…’. 

The GHG Monitor Font Dialog box 
appears. 

 

23. 
Select the desired font size and then MB1 click 
‘Apply Font’. 

The Spreadsheet Display Area text resizes 
to the font selected.  
The GHG Monitor Font Dialog box closes. 
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Step Action Result Pass/Fail

24. From the GHG Hazards Monitor menu bar, MB1 
click ‘Appearance’ -> ‘Colors…’. 

The GHG Monitor Color Dialog box 
appears. 

 

25. 

Select the desired Text Color/Background Color for 
all Color Scheme items in the Color Scheme 
column. Then MB1 click ‘Apply Colors’. MB1 
click on the map within the GHG Hazards Monitor 
to view the changes. 
Note: if no warnings are expiring, reset the regular 
entries color scheme in the GHG Color dialog. 
Note: The Appearance pull-down menu gives the 
option to enable the ‘Identify TEST Events’ 
product. 

The GHG Monitor Color Dialog box closes. 
The Text and Background colors modify as 
selected. 

 

26. 
From the GHG Hazards Monitor menu bar, select 
‘File’ -> ‘Save Configuration’ to save the current 
configuration. 

The current configuration is saved.  

27. 

To verify the saved configuration actually worked, 
MB1 click ‘File’ -> ‘Default Configuration’. 
Then MB1 click ‘File’ -> ‘Load Configuration’ to 
re-load the saved configuration. MB1 click on the 
map within the GHG Hazards Monitor to view the 
changes. 
Note: The saved configuration will only work for 
your user name.  

The default configuration displays. 
The saved configuration displays. 

 

Using the Display Selector to view both the Map and Text Display Areas (gh003) 

28. To view the Text Display Area, select the Text 
button in the Display Selector of the GHG Monitor. 

The Text Display Area displays.  

29. To view the Map Display Area, select the Map 
button in the Display Selector of the GHG Monitor. 

The Map Display Area displays.  

Using the Pane Resizer and Scroll Bars to adjust and resize the Map/Text Display and the Spreadsheet Display 
Areas (gh004) 

30. 

To adjust the Map and Text Display using the scroll 
bars, MB1 click and drag over the scroll bars 
located between the Map/Text Display and the 
Spreadsheet Display. MB1 click and drag over the 
scroll bars to the right of the Map and Text Display.

The Map and Text displays adjust 
accordingly. 

 

31. 

To resize the Map/Text and Spreadsheet Displays 
vertically, hold the mouse over the space above the 
Spreadsheet Display until an up/down arrow 
appears. Then MB1 click and drag the cursor up or 
down to resize the displays. 

The Map, Text, and Spreadsheet displays 
adjust accordingly. 
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Step Action Result Pass/Fail

32. 

To resize the Map/Text and Spreadsheet Displays 
horizontally, hold the mouse over the left and right 
borders of the GHG Monitor until a left/right arrow 
appears. Then MB1 click and drag the cursor left or 
right to resize the displays. 

The Map, Text, and Spreadsheet displays 
adjust accordingly. 

 

33. 

To adjust the Spreadsheet Display using the scroll 
bars, MB1 click and drag over the scroll bars 
located below and to the right of the Spreadsheet 
Display. 
Note: When increasing/decreasing the GHG 
Monitor Display size horizontally, the Map forecast 
zones appear smaller/larger and more/less of the 
Spreadsheet Display is visible. When 
increasing/decreasing the Map and Text Display 
size vertically, the Map forecast zones appear 
larger/smaller and the Spreadsheet Display is 
smaller/larger.  

The Spreadsheet display adjusts 
accordingly. 

 

Using the Zoom Features from the Map Pull-Down Menu on the Map and Text Display Area (gh005)  

34. 

From the GHG Hazards Monitor menu bar, MB1 
click the ‘Map’ pull-down menu. MB1 click on the 
dotted line at the top of the Map pull-down menu. 
The Map Menu is now easily accessible. 

The Map menu displays. 
The Map cut-off menu displays as its own 
window. 

 

35. 

From the Map menu, select zoom x2. Zoom x2, 
which zooms into the map by a factor of 2, is the 
first level of zoom. Verify the change in size of the 
Forecast Zone Map. 

The Forecast Zone Map changes in size 
accordingly. 

 

36. 

From the Map menu, select zoom x4. Zoom x4, 
which zooms into the map by a factor of 4, is the 
second level of zoom. Verify the change in size of 
the Forecast Zone Map. 

The Forecast Zone Map changes in size 
accordingly. 

 

37. 

From the Map menu, select zoom x6. Zoom x6, 
which zooms into the map by a factor of 6, is the 
third level of zoom. Verify the change in size of the 
Forecast Zone Map. 

The Forecast Zone Map changes in size 
accordingly. 

 

38. 

From the Map menu, select zoom x8. Zoom x8, 
which zooms into the map by a factor of 8, is the 
fourth level of zoom. Verify the change in size of 
the Forecast Zone Map. 

The Forecast Zone Map changes in size 
accordingly. 

 

39. 

From the Map menu, select zoom x12. Zoom x12, 
which zooms into the map by a factor of 12, is the 
fifth level of zoom. Verify the change in size of the 
Forecast Zone Map. 

The Forecast Zone Map changes in size 
accordingly. 
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Step Action Result Pass/Fail

40. 

From the Map menu, select zoom x16. Zoom x16, 
which zooms into the map by a factor of 16, is the 
highest level of zoom. Verify the change in size of 
the Forecast Zone Map. 

The Forecast Zone Map changes in size 
accordingly. 

 

41. 

From the Map menu, select No Zoom to resume the 
original state of the Forecast Zone Map. The user 
may unzoom out of the Forecast Zone Map by 
selecting a smaller the zoom factor. 
Note: When increasing/decreasing the zoom, the 
user may want to use the Pane Resizer to adjust the 
Map and Text Display for enhanced viewing 
capacity.  

The Forecast Zone Map reverts to its 
original size. 

 

To Display the Different Types of Maps from the Map Pull-Down Menu and Using the Show Label Feature on the 
Map and Text Display Area (gh006) 

42. 

From the GHG Hazards Monitor menu bar, select 
the Map pull-down menu. MB1 click on the dotted 
line at the top of the Map pull-down menu. The 
Map Menu is now easily accessible. 

The Map menu displays. 
The Map cut-off menu displays as its own 
window. 

 

43. 
From the Map menu, select ‘Show FIPS’. Verify 
the Forecast Zone Map changes in the Map and 
Text Display of the GHG Monitor.  

The FIPS Map displays counties over land 
and marine zones over water. 

 

44. 

From the Map menu, select ‘Show Public’. Verify 
the Forecast Zone Map changes in the Map and 
Text Display of the GHG Monitor.  
Note: For TO9, Public is already displayed.  No 
other map has been implemented.  

The Public Map displays the public forecast 
zones. 

 

45. 
From the Map menu, select ‘Show FireWx’. Verify 
the Forecast Zone Map changes in the Map and 
Text Display of the GHG Monitor.  

The FireWx Map displays the fire weather 
zones. 

 

46. 
From the Map menu, select ‘Show Marine’. Verify 
that the Forecast Zone Map changes in the Map and 
Text Display of the GHG Monitor.  

The Marine Map displays the coastal marine 
zones and offshore marine zones. 

 

47. 

To toggle on/off the Forecast Map Zone Codes, 
MB1 click on the ‘Show Labels’ radio at the 
bottom of the Map menu. When the zone labels are 
turned on, verify that each Forecast Map Zone is 
labeled with a code. 

The labels appear on the map.  
Each Forecast Map Zone is labeled. 
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Step Action Result Pass/Fail
Using the Map Display Area of the GHG Monitor to Query Hazards based on a Zone (gh007) 

48. 

With the ‘Show Labels’ feature toggled on, MB1 
click in a zone on the Forecast Zone Map.  
Note: If there is not a hazard in the Spreadsheet 
Display Area associated with the selected zone on 
the Forecast Zone Map, then the zone will not be 
highlighted and queried.  

The selected zone is automatically 
highlighted in the "Map Selections" color 
from the Appearance menu on the GHG 
Hazards Monitor menu bar. The Hazard(s) 
relating to the selected zone(s) are 
highlighted in the Spreadsheet Display 
Area. The query highlights all zones that are 
related to the highlighted hazard(s) in the 
Spreadsheet Display Area. 

 

Using the Text Display Area of the GHG Monitor (gh008) 

49. MB1 click on a cell in a row of the Spreadsheet 
Display Area of the GHG Monitor.  

Observe that the clicked-upon row is now 
highlighted. 

 

50. 

Select ‘Text’ in the Display Selector of the GHG 
Hazards Monitor.  Verify that the hazard(s) in the 
highlighted row(s) of the Spreadsheet Display Area 
are highlighted in the Text Display Area.  Verify 
that the overview text and segment text relating to 
the hazard(s) is highlighted. 

The Text Display Area appears. DR 
#1377 

51. 

Select Map in the Display Selector of the GHG 
Hazards Monitor. MB1 click on a forecast zone(s) 
of the Forecast Zone Map.  

The Map Display Area appears.  
The clicked-upon zone(s) are highlighted 
along with the associated hazard(s) in the 
row(s) of the Spreadsheet Display Area of 
the GHG Hazards Monitor. 

 

52. 

Repeat Step 50.  
Note: Only segmented products have overview text. 
Overview text is defined as the text between the 
MND header and the first UGC line. Segment text 
is defined as the text within each segment between 
the end of the UGC/Date block and the $$ segment 
ending characters.  

The Text Display Area appears.  

Using the Spreadsheet Display Area of the GHG Monitor (gh009) 

53. 
From the GHG Hazards Monitor menu bar, Save 
and Load a Configuration. You can now refer to the 
next step. 
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Step Action Result Pass/Fail

54. 

MB1 click on a column header of choice in the 
Spreadsheet Display Area to sort the data in the 
spreadsheet by the data in that column. MB1 click 
again on the column header, this sorts the data in 
ascending order. MB1 click once more on the 
column header, this sorts the data in descending 
order. Alternating clicks with MB1 will sort the 
data in ascending order, then descending order. 

The data is assorted accordingly.  

55. 

MB1 click on a cell in a row of the Spreadsheet 
Display Area. Verify in the Map and Text Display 
Areas of the GHG Monitor that the Forecast Zone 
Map has the correct geographical hazard locations 
highlighted and that the corresponding text is 
highlighted in the Text Display.  
Note: To toggle between the Map and Text Display 
Areas, you must use the Text and Map buttons in 
the Display Selector Area of the GHG Monitor.  

The entire row is highlighted in the chosen 
‘Monitor Selection’ color. 

DR 
#1376 

56. 

From Step 20, Alerts should have been defined. 
Verify the chosen colors and warning time notice 
of Alert1, Alert2, and Expired Alerts.  
Note: An alert banner and color change will appear 
before the expiration time of the alert based upon 
the alert warning time notice. The alert warning 
time notice is based upon the Start and End times in 
the Spreadsheet Display Area. The Start and End 
times are initialized upon set up of a hazard 
warning or watch.  

The chosen colors and warning time notice 
of Alert1, Alert2, and Expired Alerts are 
present. 

DR 
#1375 

57. Close the GHG Monitor. 
Then MB3 popup the GFE tab and select ‘Close’.   

The GFE tab closes.  

 End of test.   
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5.0 REQUIREMENTS VERIFICATION TRACEABILITY MATRIX (RVTM) 

Number Description Test Step(s) 

SYSR2065 The AWIPS system shall implement the GFE Graphical Hazards ALL 

SYSR2066 The AWIPS system shall implement the GFE GHG Viewer ALL 

SYSR2067 The AWIPS system shall implement the GFE GHG Monitor ALL 

SYSR2069 The AWIPS system shall implement the GFE Formatter Launcher 9-12 

SYSR2070 The AWIPS system shall implement the GFE Formatter Data Interface. 9-12 

SYSR2358 
The AWIPS GFESuite shall implement Prepare the Hazards Data for the 
GHG Monitor Tests. 

1-12 

SYSR2359 
The AWIPS GFESuite shall implement Saving and Loading 
Configurations of the GHG Monitor. 

13-27 

SYSR2360 
The AWIPS GFESuite shall implement Using the Display Selector to 
view both the Map and Text Display Areas. 

28-29 

SYSR2361 

The AWIPS GFESuite shall implement Using the Pane Resizer and 
Scroll Bars to adjust and resize the Map/Text Display and the 
Spreadsheet Display Areas. 

30-33 

SYSR2362 
The AWIPS GFESuite shall implement Using the Zoom Features from 
the Map Pull-Down Menu on the Map and Text Display Area. 

34-41 

SYSR2363 

The AWIPS GFESuite shall implement To Display the Different Types 
of Maps from the Map Pull-Down Menu and Using the Show Label 
Feature on the Map and Text Display Area. 

42-47 

SYSR2364 
The AWIPS GFESuite shall implement Using the Map Display Area of 
the GHG Monitor to Query Hazards based on a Zone. 

48 

SYSR2365 
The AWIPS GFESuite shall implement Using the Text Display Area of 
the GHG Monitor. 

49-52 

 


