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1.0 SCOPE 

See Software Test Plan. 
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2.0 APPLICABLE DOCUMENTS 

2.1 Source Documents 
• None 
 

2.2 Reference Documents 
• Legacy NWS GFE Acceptance Test Case ID Number: ac009 
• Legacy NWS GFE Test Cases for Test Areas AC – VP 
• Section 3.1.3 of the AWIPS D-2D User’s Manual Build 8.1 
• Software Test Plan for the Advanced Weather Information Processing System 

Project, Contract #DG133W-05-CQ-1067, August 2008 
• The Silver Spring NWS AWIPS 1 test bed application 
• Release OB8.1 and OB8.2 of the Weather Event Simulator (WES) 
• Rational RequisitePro 
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3.0 TEST CASE DESCRIPTION 
This test case exercises and demonstrates the Smart Tools functionality developed during TO9. 
 

3.1 Assumptions, Constraints and Preconditions 
• Several weather elements are loaded 
• There are multiple grids available for the weather elements (at minimum T, Td, Wind, Wx, 

and Hazards weather elements) 
• TO9 software has been installed successfully 
• CAVE, EDEX and pgAdmin III are running 
• Data has been ingested 
• The GFE Perspective is displayed 
• Actions, Results, and Requirements highlighted in yellow indicate requirements and/or 

capabilities to be included in the scope of future task orders. They are included here for 
purposes of continuity and traceability with the original AWIPS I test case documents.  
Items highlighted in blue are capabilities added and/or Deficiency Reports (DRs) corrected 
since the Delivery Test. 

 

3.2 Recommended Hardware 
See Software Test Plan. 
 

3.3 Test Inputs 
Section 4.0 below contains the test procedures for this test case. Sections 2.2 – 2.9 of the Software 
Test Plan contain general test inputs applicable to all TO9 test cases.  
 

3.4 Test Outputs 
The Smart Tools will be executed on images displayed in CAVE and the results outlined in section 
4.0 are met. The GFE GUIs to be tested include: 

• Copy All Grids From 

• Edit Action Dialog 

• Weather Element Browser 

• Save Forecast 

• ProcedureCmds Values 

• QPF_SmartTool Values 

• MixHgt_Init Values 

• Item Delete 
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4.0 TEST SCENARIO 

Step Action Result Pass/Fail
Procedures 

1. 

If weather elements are not populated in 
the Grid Manager (GM), Mouse Button 
(MB)1 click ‘Populate’ -> ‘Copy All 
Grids From…’. From the Copy All Grids 
From dialog, select an available model 
and MB1 click ‘OK’. Note: If the Empty 
Edit Area Warning dialog displays, MB1 
click on the ‘Do not show this message 
again’ and MB1 click ‘Yes’. 

Grids are created from model data 
and placed into the Fcst database.  

 

2. 

For all available grids, interpolate between 
all missing grids. For weather elements 
without grids, create scratch grids for the 
first hour and last hour and interpolate 
between these grids. 
MB1 click on the Edit Action Dialog 
button. Highlight all grids between the 
first hour and last hour grids. Then run the 
associated Smart Tools (e.g., 
MaxT_SmartTool). 
Close the Edit Actions dialog when 
completed. 

All available grids have data.  
Smart Tools create additional grids 
for other weather elements.  
The Edit Actions Dialog window 
closes. 

 

3. 

MB1 click ‘WeatherElement’ -> ‘Weather 
Element Browser…’. From the Weather 
Element Browser dialog, load in the Fire 
Wx and Marine weather element groups 
selecting ‘File’ -> ‘Load Weather Element 
Group’ -> ‘Fire Wx’, and ‘File’ -> ‘Load 
Weather Element Group’ -> ‘Marine’. 
MB1 click ‘Load and Dismiss’.  

The fire weather and marine 
weather elements load into the 
GFE. 

 

4. 

Scroll through the weather elements in the 
GM.  
Use the Copy All Grids From 
functionality to populate the GM. 

The GM populates with the fire 
weather and marine weather 
elements.  Data is available for 
most of the elements.  Some of the 
elements are ‘very long’, e.g., a 
single grid spanning many days. 
Examples of this include HrsOfSun 
and InvBurnOffTemp. 

DR 
#1346 
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Step Action Result Pass/Fail

5. 

MB1 click ‘WeatherElement’ -> 
‘Weather Element Groups’ -> ‘Public’ to 
load just the public elements. Then bring 
up the Weather Element Browser 
selecting ‘WeatherElement’ -> ‘Weather 
Element Browser’. Add ‘MixHgt’ to the 
list of weather elements to be loaded by 
pulling down the Field menu. Then MB1 
click ‘Load and Dismiss’. 

Only the public elements appear. 
MixHgt is added to the list of 
weather elements. 

 

6. 

Save all forecast data by MB1 clicking 

the toolbar button. From the Save 
Forecast dialog, ensure all weather 
elements are selected. Then MB1 click 
the ‘Save Forecast’ button. 

The Save Forecast dialog appears. 
All weather elements are selected. 
The grids are saved as indicated by 
the replacement of the green locks 
with gray blocks. 
The Save Forecast dialog closes. 

 

7. MB1 click ‘Populate’ -> 
‘ProcedureCmds’.   

A ProcedureCmds Values dialog 
displays. 

 

8. 

From the ProcedureCmds Values dialog, 
select ‘All’ for the Model Elements, 
select an entry for the Model, a 
beginning hour, and select an entry from 
the Initialize Model. Then MB1 click 
‘Run/Dismiss’.  

A dialog will display stating 
‘Loading Grids’. When the 
procedure finishes, the small dialog 
is dismissed. Many grids will have 
been modified. Some will be 
interpolated. Some errors may be 
reported, such as no grids to 
interpolate or no corresponding 
grids. 

 

9. Save all forecast data using the  
toolbar button. 

The weather elements are saved.  

10. 

MB1 click ‘GFE’ -> ‘Show Warnings’ -
> ‘Show Empty Edit Area Warning’ to 
unselect the option.  MB1 click ‘GFE’ -> 
‘Show Warnings’ -> ‘Show Edit Action 
Time Range Warning’ to unselect the 
option. 

The Show Empty Edit Area 
Warning and Show Edit Action 
Time Range Warning lines are not 
checked. 
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Step Action Result Pass/Fail

11. 

MB1 click on a T grid in the GM. Then 
MB1 drag over several T grids in the 
GM to select them. Include the grid that 
was just clicked upon. Select the Sample 

Tool  from the toolbar and MB1 click 
at several points on the displayed grid. 
Note the data values and the appearance 
of the grid. Clear any existing edit area 

using the  toolbar button. MB1 click 
‘Edit’ -> ‘ExProc1’.   

The data selected in the GM is 
modified by running the Adjust_Up 
smart tool followed by the Smooth 
tool. 

 

12. Save all forecast data using the  
toolbar button. 

The forecast is saved.  

13. 

MB1 click ‘Verify’ -> ‘ExProc2’. From 
the ExProc2 Values dialog, select one of 
the GFS80 or NAM12 models. Then 
MB1 click ‘Run/Dismiss’.  

Several T grids are created from 
scratch as shown by the S indicator 
in the GM and the green locks in 
the GM. Elements T, Wind, and 
Wx are copied from the selected 
model into the Fcst database, as 
shown by the model name (or 
abbreviation) in the GM and 
additional green locks in the GM. 
Another dialog is displayed labeled 
ExSS4 Values. 

 

14. 

Choose one of the NAM12 models from 
the ExSS4 Values Dialog and press Ok.  

The ExSS4 smart tool is executed 
which makes a numerical sounding, 
and then calculates the T based on 
the model sounding data and the 
topography. Some of the T grids 
which were created from scratch in 
step #10 will now show an ‘m’ for 
modified due to the smart tool 
execution. 

 

15. Save all forecast data using the 
toolbar button. 

  

Smart Tools 

16. 

MB1 click on a QPF grid with some non-
zero QPF values that also has a 
corresponding Wind grid.   MB3 popup 
over the main area of the Spatial Editor 
(SE) and select ‘QPF_SmartTool’.  

A Title Values dialog appears. 
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Step Action Result Pass/Fail

17. 

Set the Vertical Motion Influence to the 
maximum value and MB1 click ‘OK’.  

The grid indicator in the GM turns 
cyan to indicate that grid is being 
calculated. The progress bar in the 
status bar moves from left to right 
as the grid points are calculated. 
After the calculation is finished, 
the QPF field is modified based on 
upslope/downslope conditions 
derived from the wind and 
topography. 

DR 
#1362 

18. 

MB1 click on the first T grid that 
corresponds to the time for the edited 
QPF grid. MB1 click between 20 and 30 
on the color bar to set the pickup value. 
MB3 popup over the same T grid in the 
GM and select ‘Assign xxx’, where xxx 
is your pickup value.  MB1 click on the 
corresponding (valid for the same time) 
FzLevel grid. MB1 click on the color bar 
on a value that represents the elevation 
that is below most of your terrain. MB3 
popup over the same FzLevel grid in the 
GM and select ‘Assign xxx’, where xxx 
is your pickup value. MB1 click on the 
corresponding SnowAmt grid. MB3 
popup over the main area of the SE and 
select ‘SnowAmt_SmartTool’.   

The SnowAmt data is changed 
based on the QPF, T, and FzLevel 
values. (You might need to use 
MB3 popup over the color bar and 
select ‘Fit To Data’ -> ‘Single 
Grid’ to see the detail.) 
 

DR 
#1362 

19. 

Load the FireWx weather element group 
MB1 clicking ‘WeatherElement’ -> 
‘Weather Element Groups’ -> ‘FireWx’. 
Answer ‘Save First’ to the Modified 
Weather Element(s) dialog that is 
displayed.  

The modified data is saved and the 
FireWx elements are loaded. 
 

 

20. 

Bring up the Weather Element Browser 
MB1 clicking ‘WeatherElement’ -> 
‘Weather Element Browser’. Select ‘T’ 
from the Field pull-down and MB1 click 
‘Load and Dismiss’.  

T is added to the GFE.  

21. 
MB1 click ‘GFE’ -> ‘Editing 
Preferences’ -> ‘Missing Data Mode’ -> 
‘Create’. 
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Step Action Result Pass/Fail

22. 
MB1 click on a MixHgt grid in the GM. 
MB3 popup over the main area of the SE 
and select ‘MixHgt_Init’.  

The MixHgt_Init Values dialog 
displays. 
 

 

23. 
Choose one of the previous NAM12 
models that are presented in the dialog 
and MB1 click ‘Run/Dismiss’.  

The mixing height grid is 
calculated. 

 

24. 

Revert your modified grids by selecting 
‘Edit’ -> ‘Revert Forecast’. Load the 
Public weather element group MB1 
clicking ‘WeatherElement’ -> ‘Weather 
Element Groups’ -> ‘Public’.  

Modified data is discarded and the 
public weather elements are 
displayed. 
 

 

25. 

MB1 click on the same SnowAmt grid as 
in step #17. Bring up the Edit Actions 

Dialog window using the  toolbar 
button.  Select ‘ExTool1’.  

The SnowAmt grid is modified to 
contain 10*QPF. 
 

 

26. 
Select ‘ExTool2’.  The SnowAmt grid is modified 

again, this time determined by T 
and QPF.  

 

27. 

Select ‘ExTool3’. The ExTool3 Values 
dialog appears. Enter a snow level 
corresponding to the topography in your 
area. MB1 click ‘Run/Dismiss’.  

The SnowAmt grid is modified 
again. 
 

 

28. 

MB1 click on a QPF grid in the GM that 
contains some QPF values. Select 
‘ExSS1’ from the Edit Actions Dialog 
window.  

The QPF values are recalculated 
based on the existing QPF data and 
the QPF data from the NAM12 
model. 

 

29. 

Select ‘ExSS2’ from the Edit Actions 
dialog. The ExSS2 Values dialog 
displays. Select one of the models that 
generate QPF, but not NAM12.  

The QPF values are recalculated. 
Areas where 0 QPF existed on the 
grid, but the model has QPF values 
are replaced with the model's QPF 
values. 

 

30. 

MB1 click on a T grid that corresponds to 
00z or 12z. Select ‘ExSS4’ from the Edit 
Actions dialog. Select one of the NAM12 
models and MB1 click ‘Run/Dismiss’.  

A numerical sounding is calculated 
and the T determined from the 
model data. 

 

31. 

MB1 click on another T grid that 
corresponds to 00z or 12z. Select 
‘ExSS5’ from the Edit Actions dialog. 
Select a different model (e.g., GFS80) 
and MB1 click ‘Run/Dismiss’.  

A numerical sounding is calculated 
and T is determined from the 
model data. 
 

 

32. MB1 click on a T grid that has a 
corresponding Td grid. Select ‘ExSS6’ 

A new weather element is created 
with the name of TempRH and the 
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Step Action Result Pass/Fail
from the Edit Actions dialog.  model name of TempModel. It 

appears near the bottom of the 
GM. It contains the calculated RH 
from the T and Td grids. 

33. 

MB1 click on a Wx grid in the GM that 
has a corresponding PoP grid. The PoP 
grid should have a range of values from 0 
through 100%. Select ‘ExSS7’ from the 
Edit Actions dialog. 

The Wx grid is modified based on 
the PoP.  
 

 

34. 

MB1 click on a PoP grid that has a 
corresponding Wx grid. The Wx grid 
should have some areas of <NoWx>, Chc 
RW-, Sct RW-, and Wide R. Select 
‘ExSS8’ from the Edit Actions dialog.  

The PoP grid is modified based on 
the Wx. 

 

35. 

Click on a T grid. Select ‘ExUtil1’ from 
the Edit Actions dialog. The ExUtil1 
Values dialog displays. Select one of the 
NAM12 models and MB1 click 
‘Run/Dismiss’.  

The T grid is recalculated and on 
the terminal window where GFE 
was run, a statement of ‘Using 
Utility Version of convertFtToM’ 
displays. 

 

36. 
Save all forecast data by MB1 clicking 

the  toolbar button. 

The forecast data is saved.  

37. 

MB1 click on a T grid in the GM that 
corresponds to a grid within the ‘Tonight’ 
period as displayed in the time scale. 

Select the Sample Tool  from the 
toolbar. MB1 click on several samples; 
some within the ISC_OAX edit area, and 
some outside. 

The T grid displays. 
The Samples display within and 
outside of the ISC_OAX edit area. 

DR 
#1364 

38. 

From a terminal window, and from the 
GFESuite ‘bin’ directory, issue the 
following command: 
runProcedure -n ExProc1 -d 
xxx_GRID__Fcst_00000000_0000 -u 
GFETEST -c gfeConfig -a 
ISC_Send_Area -t Tonight 
where xxx is your siteID. 

T grids that overlap the Tonight 
period will be modified. The T 
data will be increased by 1 degree 
and then smoothed, within the 
ISC_Send_Area. 

 

New Smart Tool 

39. 
Bring up the Edit Actions Dialog using 

the   toolbar button. 

The Edit Action dialog box opens.  
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Step Action Result Pass/Fail

40. 

MB3 popup over the Edit Actions Dialog 
window and select ‘New’.  On the dialog 
that will be displayed, ensure that 
‘Numeric’ is selected on the radio 
buttons (at the bottom). Enter 
‘TEST001’ for the tool name at the top. 
Select ‘T’ as the weather element to edit.  
MB1 click ‘OK’. 

The Python editor 
window/perspective appears 
containing the smart tool template. 

 

41. 

Replace the execute() function in the 
template with the following code, 
leaving the rest of the template alone:  
    def execute(self, T):  
        ‘Increment T’  
        # Determine new value  
        T = T + 5  
        # Return the new value  
        return T 

The code is modified.  

42. 

On the Python editor window, MB1 
click ‘File’ -> ‘Save’.  MB1 click the ‘X’ 
on the Python Editor window.  Then 
close the Python perspective. 

The edited code is saved.  

43. 
MB1 click the Draw Edit Area tool  
icon. Draw a closed area using MB1 
drag on the displayed grid. 

An enclosed area appears on the 
GFE display. 

 

44. 
MB1 click on the ‘TEST001’ entry in 
the Edit Actions dialog.  

The smart tool is executed and the 
data values increase incrementally 
by 5.0. 

 

45. 

MB1 drag across several T grids in the 
GM to select them. MB1 click on the 
‘TEST001’ entry in the Edit Actions 
Dialog window. 

The smart tool is executed and the 
data values increase incrementally 
by 5.0 in each of the grids.  

 

46. 
MB3 popup over the Edit Actions Dialog 
window entry of TEST001 and select 
‘Modify’.  

The Python editor window pops up, 
containing the smart tool template. 
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Step Action Result Pass/Fail

47. 

Replace the execute() function in the 
template with the following code, 
leaving the rest of the template alone:  
    def execute(self, T, Td):  
        ‘Assign T to Td+10’  
        # Determine new value  
        T = Td + 10  
        # Return the new value  
        return T 

The code is modified.  

48. 

On the Python editor window, MB1 
click ‘File’ -> ‘Save’.  MB1 click the ‘X’ 
for the Python Editor window.  Then 
close the Python perspective. 

The edited code is saved.  

49. 
Using the Draw Edit Area tool  icon, 
draw a closed area using MB1 drag on 
the displayed grid. 

An enclosed area appears on the 
GFE display. 

 

50. 

MB1 click on a T grid in the GM to 
make the T grid visible and editable. The 
T grid selected must have a 
corresponding Td grid (i.e., valid at the 
same time). If not, create from scratch a 
Td grid at the same time and then MB1 
click again on the T grid. 

The T grid is visible and in edit 
mode. 
If necessary, a Td grid is created. 

 

51. 
MB1 click on the ‘TEST001’ entry in 
the Edit Actions Dialog window.  

The smart tool is executed and the 
data values are set to 10 degrees 
above the corresponding Td field. 

 

52. 

MB3 popup over the TEST001 entry on 
the Edit Actions Dialog window and 
MB1 click ‘Delete’.  Select ‘OK’ in the 
Item Delete dialog to remove the 
‘TEST001’ smart tool. 
Verify the ‘TEST001’ smart tool entry is 
removed from the Edit Actions dialog. 

The TEST001 entry is removed 
from the Edit Actions dialog 
window.  

 

53. Exit GFE. GFE closes.  
 End of test.   



 

HARDCOPY UNCONTROLLED  

Contract DG133W-05-CQ-1067; Test Case Smart Tools and Procedures 

Use or disclosure of data contained on this sheet is subject to the restriction on the title page of this document. 

15 

5.0 TO9 REQUIREMENTS VERIFICATION TRACEABILITY MATRIX (RVTM) 

Number Description Test Step(s) 

SYSR2071 

The AWIPS system shall implement the GFE Smart Tool Widgets 
(create a set of GUI widgets that are accessible from a Smart Tool 
script). 

ALL 

SYSR2072 The AWIPS system shall implement the GFE Smart Tool Interface. ALL 

SYSR2100 
The AWIPS system shall implement the Smart Init Interface to 
enable initializing from model data. 

1 

SYSR2102 
The AWIPS system shall implement the Smart Tool Interface with 
a library of functions for use by smart tools 

2 

SYSR2118 
The AWIPS GFESuite shall implement the GFE Smart Tools and 
Procedures. 

ALL 

SYSR2491 
The AWIPS GFESuite shall implement ifpServerText - Smart 
Tools. 

ALL 

SYSR2597 
The AWIPS GFESuite shall implement Create, Modify, and Delete 
smart tools to modify scalar weather elements. 

31-52 

SYSR2601 

The AWIPS GFESuite shall implement Create, Modify, and Delete 
a Procedure that consists of tools that modify the same weather 
element. 

31-45, 52 

SYSR2602 

The AWIPS GFESuite shall implement Create, Modify, and Delete 
a Procedure that consists of tools that modify various weather 
elements. 

46-52 

 
 


